aboutsummaryrefslogtreecommitdiff
path: root/security/steghide
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2018-06-29 16:38:07 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2018-06-29 16:38:07 +0000
commit651d502b862732493ef8b022cfd24094f029e5c7 (patch)
treee1c837a3f3327cf6d41a012c68dbdbe78e5bfd46 /security/steghide
parent7a80b8a75e26e42e27c859f9c83fe02aa9b487b3 (diff)
downloadports-651d502b862732493ef8b022cfd24094f029e5c7.tar.gz
ports-651d502b862732493ef8b022cfd24094f029e5c7.zip
- Fix build with clang 6
- Switch to options helpers
Notes
Notes: svn path=/head/; revision=473558
Diffstat (limited to 'security/steghide')
-rw-r--r--security/steghide/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/security/steghide/Makefile b/security/steghide/Makefile
index a40069e77e4a..1f6f851792ee 100644
--- a/security/steghide/Makefile
+++ b/security/steghide/Makefile
@@ -20,18 +20,15 @@ USES= gmake jpeg libtool:build perl5
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include -fpermissive
LIBS+= -L${LOCALBASE}/lib -lmcrypt
+CXXFLAGS+= -Wno-static-float-init
MAKE_ARGS= LIBTOOL="${LOCALBASE}/bin/libtool"
OPTIONS_DEFINE= DOCS NLS
OPTIONS_SUB= yes
+
NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MNLS}
-LIBS+= -lintl
-.endif
+NLS_LIBS= -lintl
post-patch:
@${REINPLACE_CMD} '/CXXFLAGS=/s|-O2|${CXXFLAGS}|' ${WRKSRC}/configure