aboutsummaryrefslogtreecommitdiff
path: root/security/step-certificates
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2020-07-08 20:28:31 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2020-07-08 20:28:31 +0000
commit5e6d3976f6d4dc5322501922c96c68f485c91452 (patch)
treeb95ae9bcc8d4dfba4e8843c8758a742e584e23fe /security/step-certificates
parent8fa11dec063af50448ba1338498a0db8ba206a2d (diff)
downloadports-5e6d3976f6d4dc5322501922c96c68f485c91452.tar.gz
ports-5e6d3976f6d4dc5322501922c96c68f485c91452.zip
Fix build on i386
PR: 247855 Submitted by: Markus Wipp <mw@wipp.bayern> (maintainer)
Notes
Notes: svn path=/head/; revision=541717
Diffstat (limited to 'security/step-certificates')
-rw-r--r--security/step-certificates/Makefile1
-rw-r--r--security/step-certificates/files/patch-vendor_github.com_go-piv_piv-go_piv_pcsc__freebsd.go9
2 files changed, 10 insertions, 0 deletions
diff --git a/security/step-certificates/Makefile b/security/step-certificates/Makefile
index 45acc4cefbe2..ec6b99c4b6de 100644
--- a/security/step-certificates/Makefile
+++ b/security/step-certificates/Makefile
@@ -3,6 +3,7 @@
PORTNAME= step-certificates
DISTVERSIONPREFIX=v
DISTVERSION= 0.14.6
+PORTREVISION= 1
CATEGORIES= security
MAINTAINER= mw@wipp.bayern
diff --git a/security/step-certificates/files/patch-vendor_github.com_go-piv_piv-go_piv_pcsc__freebsd.go b/security/step-certificates/files/patch-vendor_github.com_go-piv_piv-go_piv_pcsc__freebsd.go
new file mode 100644
index 000000000000..dad2097bca1e
--- /dev/null
+++ b/security/step-certificates/files/patch-vendor_github.com_go-piv_piv-go_piv_pcsc__freebsd.go
@@ -0,0 +1,9 @@
+--- vendor/github.com/go-piv/piv-go/piv/pcsc_freebsd.go.orig 2020-05-23 07:13:27 UTC
++++ vendor/github.com/go-piv/piv-go/piv/pcsc_freebsd.go
+@@ -26,5 +26,5 @@ func scCheck(rc C.long) error {
+ }
+
+ func isRCNoReaders(rc C.long) bool {
+- return rc == 0x8010002E
++ return int64(rc) == 0x8010002E
+ }