aboutsummaryrefslogtreecommitdiff
path: root/security/strongswan/Makefile
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2020-01-31 16:39:19 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2020-01-31 16:39:19 +0000
commit26827296acb25fdc72e3aa0ad62a73ff1c3ad6e8 (patch)
tree1f1c99d3931a6cba4038ae7bd4b38e33582d9edd /security/strongswan/Makefile
parent222d29289aa30fe3f2d60064292b112cd51a280b (diff)
downloadports-26827296acb25fdc72e3aa0ad62a73ff1c3ad6e8.tar.gz
ports-26827296acb25fdc72e3aa0ad62a73ff1c3ad6e8.zip
Notes
Diffstat (limited to 'security/strongswan/Makefile')
-rw-r--r--security/strongswan/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/security/strongswan/Makefile b/security/strongswan/Makefile
index ec4bb0381ed6..b6ae86fd55eb 100644
--- a/security/strongswan/Makefile
+++ b/security/strongswan/Makefile
@@ -43,7 +43,7 @@ CONFIGURE_ARGS= --enable-kernel-pfkey \
OPTIONS_DEFINE= CURL EAPAKA3GPP2 EAPDYNAMIC EAPRADIUS EAPSIMFILE GCM IKEV1 \
IPSECKEY KERNELLIBIPSEC LOADTESTER LDAP MEDIATION MYSQL PKI \
- PKCS11 SCEP SMP SQLITE SWANCTL TESTVECTOR TPM UNBOUND UNITY \
+ PKCS11 PYTHON SCEP SMP SQLITE SWANCTL TESTVECTOR TPM UNBOUND UNITY \
VICI XAUTH
OPTIONS_DEFINE_i386= VIA
OPTIONS_DEFAULT= BUILTIN CURL IKEV1 PKI SWANCTL VICI
@@ -67,6 +67,7 @@ LOADTESTER_DESC= Enable load testing plugin
MEDIATION_DESC= Enable IKEv2 Mediation Extension
PKCS11_DESC= Enable PKCS11 token support
PKI_DESC= Enable PKI tools
+PYTHON_DESC= Python VICI protocol plugin
SCEP_DESC= Enable Simple Certificate Enrollment Protocol
SMP_DESC= Enable XML-based management protocol (DEPRECATED)
SWANCTL_DESC= Install swanctl (requires VICI)
@@ -101,6 +102,9 @@ MYSQL_CONFIGURE_ON= --enable-mysql
MYSQL_USES= mysql
PKCS11_CONFIGURE_ON= --enable-pkcs11
PKI_CONFIGURE_OFF= --disable-pki
+PYTHON_IMPLIES= VICI
+PYTHON_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}vici>0:security/py-vici@${PY_FLAVOR}
+PYTHON_USES= python
SCEP_CONFIGURE_OFF= --disable-scepclient
SMP_CONFIGURE_ON= --enable-smp
SMP_LIB_DEPENDS= libxml2.so:textproc/libxml2