aboutsummaryrefslogtreecommitdiff
path: root/security/sudo
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2020-12-07 12:43:25 +0000
committerRenato Botelho <garga@FreeBSD.org>2020-12-07 12:43:25 +0000
commitb28d26b7003f59692e43450df9f47e873bc2eb6f (patch)
tree708beff5311348b841cf030934b27fffb2749536 /security/sudo
parent6dfe0bd3bc4dba5abd847f63730266634aa41508 (diff)
downloadports-b28d26b7003f59692e43450df9f47e873bc2eb6f.tar.gz
ports-b28d26b7003f59692e43450df9f47e873bc2eb6f.zip
security/sudo: Fix build without sendmail
PR: 251582 Reported by: Alexander Kuznetsov <alex@kuznetcoff.ru> Obtained from: https://www.sudo.ws/repos/sudo/raw-rev/41db1aad85bb Sponsored by: Rubicon Communications, LLC (Netgate)
Notes
Notes: svn path=/head/; revision=557225
Diffstat (limited to 'security/sudo')
-rw-r--r--security/sudo/Makefile1
-rw-r--r--security/sudo/files/patch-fix_build_without_sendmail45
2 files changed, 46 insertions, 0 deletions
diff --git a/security/sudo/Makefile b/security/sudo/Makefile
index fe31aa26e3e1..1e06550593c4 100644
--- a/security/sudo/Makefile
+++ b/security/sudo/Makefile
@@ -3,6 +3,7 @@
PORTNAME= sudo
PORTVERSION= 1.9.4
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= SUDO
diff --git a/security/sudo/files/patch-fix_build_without_sendmail b/security/sudo/files/patch-fix_build_without_sendmail
new file mode 100644
index 000000000000..5efe192f5d7b
--- /dev/null
+++ b/security/sudo/files/patch-fix_build_without_sendmail
@@ -0,0 +1,45 @@
+
+# HG changeset patch
+# User Todd C. Miller <Todd.Miller@sudo.ws>
+# Date 1606767492 25200
+# Node ID 41db1aad85bbce444b511bcb28b9628a0a22fcd9
+# Parent 96a5cfe3c66b6ee84d7f7b6fb26d932f45a44b76
+Fix build when configured using --without-sendmail
+Bug #947
+
+diff -r 96a5cfe3c66b -r 41db1aad85bb lib/eventlog/eventlog.c
+--- lib/eventlog/eventlog.c Sun Nov 29 15:11:34 2020 -0700
++++ lib/eventlog/eventlog.c Mon Nov 30 13:18:12 2020 -0700
+@@ -78,7 +78,7 @@
+ static FILE *eventlog_stub_open_log(int type, const char *logfile);
+ static void eventlog_stub_close_log(int type, FILE *fp);
+
+-/* Eventlog config settings */
++/* Eventlog config settings (default values). */
+ static struct eventlog_config evl_conf = {
+ EVLOG_NONE, /* type */
+ EVLOG_SUDO, /* format */
+@@ -91,7 +91,11 @@
+ false, /* omit_hostname */
+ _PATH_SUDO_LOGFILE, /* logpath */
+ "%h %e %T", /* time_fmt */
++#ifdef _PATH_SUDO_SENDMAIL
+ _PATH_SUDO_SENDMAIL, /* mailerpath */
++#else
++ NULL, /* mailerpath (disabled) */
++#endif
+ "-t", /* mailerflags */
+ NULL, /* mailfrom */
+ MAILTO, /* mailto */
+@@ -1436,8 +1440,10 @@
+ evl_conf.logpath = _PATH_SUDO_LOGFILE;
+ if (evl_conf.time_fmt == NULL)
+ evl_conf.time_fmt = "%h %e %T";
++#ifdef _PATH_SUDO_SENDMAIL
+ if (evl_conf.mailerpath == NULL)
+ evl_conf.mailerpath = _PATH_SUDO_SENDMAIL;
++#endif
+ if (evl_conf.mailerflags == NULL)
+ evl_conf.mailerflags = "-t";
+ if (evl_conf.mailto == NULL)
+