aboutsummaryrefslogtreecommitdiff
path: root/security/super
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2018-07-26 23:28:32 +0000
committerRenato Botelho <garga@FreeBSD.org>2018-07-26 23:28:32 +0000
commit99fa9a1472697ae64749f9870e49840c6a5061d0 (patch)
tree8cef2315b2171d8bf9bb227671a9629e5a1e7e75 /security/super
parent7aed89abb6df084d6e392827efdf7549c3b3bb5f (diff)
downloadports-99fa9a1472697ae64749f9870e49840c6a5061d0.tar.gz
ports-99fa9a1472697ae64749f9870e49840c6a5061d0.zip
- Update security/super to 3.30.1
- Re-generate patches with make makepatch - Pass maintainership to submitter PR: 230061 Submitted by: Vinícius Zavam <egypcio@googlemail.com>
Notes
Notes: svn path=/head/; revision=475405
Diffstat (limited to 'security/super')
-rw-r--r--security/super/Makefile5
-rw-r--r--security/super/distinfo5
-rw-r--r--security/super/files/patch-checks.c8
-rw-r--r--security/super/files/patch-localsys.h7
4 files changed, 12 insertions, 13 deletions
diff --git a/security/super/Makefile b/security/super/Makefile
index 8c1da5132a1e..7c5833056e3a 100644
--- a/security/super/Makefile
+++ b/security/super/Makefile
@@ -2,14 +2,13 @@
# $FreeBSD$
PORTNAME= super
-PORTVERSION= 3.30.0
-PORTREVISION= 1
+PORTVERSION= 3.30.1
CATEGORIES= security sysutils
MASTER_SITES= ftp://ftp.ucolick.org/pub/users/will/ \
http://www.ucolick.org/~will/RUE/super/
EXTRACT_SUFX= -tar.gz
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= egypcio@googlemail.com
COMMENT= Allow others to run commands as root
LICENSE= ART10 GPLv1+
diff --git a/security/super/distinfo b/security/super/distinfo
index b24fe3c1434d..30007cce7a7c 100644
--- a/security/super/distinfo
+++ b/security/super/distinfo
@@ -1,2 +1,3 @@
-SHA256 (super-3.30.0-tar.gz) = 04738c46ef1c1dc0c400dd9d7bec4b63bd12664e67a774d243f03c1f7a8fafeb
-SIZE (super-3.30.0-tar.gz) = 233353
+TIMESTAMP = 1532647430
+SHA256 (super-3.30.1-tar.gz) = 50036d932d85fc1e2d9a78d6d20a531dc190eeec895ca464bbba577c10c5db27
+SIZE (super-3.30.1-tar.gz) = 239989
diff --git a/security/super/files/patch-checks.c b/security/super/files/patch-checks.c
index 5b53e1034eb2..1d25665474c0 100644
--- a/security/super/files/patch-checks.c
+++ b/security/super/files/patch-checks.c
@@ -1,6 +1,6 @@
---- checks.c
+--- checks.c.orig 2018-05-21 22:43:28 UTC
+++ checks.c
-@@ -567,7 +567,6 @@
+@@ -567,7 +567,6 @@ int
set_u_g()
{
/* Return 0 on success, -1 on failure */
@@ -8,7 +8,7 @@
void endgrent();
int i, j, k = -1;
int found_gid = -1, found_egid = -1;
-@@ -1425,7 +1424,6 @@
+@@ -1425,7 +1424,6 @@ int allowbrackets; /* accept names like <caller> */
char *grouplabel; /* name or numeric form */
{
struct group *gp;
@@ -16,7 +16,7 @@
void endgrent();
int numeric_gid;
int found_gid, is_numeric=0;
-@@ -1897,7 +1895,6 @@
+@@ -1897,7 +1895,6 @@ char *gp_pat; /* pattern to match */
struct group *gp;
char **mem;
char buf[20];
diff --git a/security/super/files/patch-localsys.h b/security/super/files/patch-localsys.h
index 05f1f836d77b..a299ad1597c2 100644
--- a/security/super/files/patch-localsys.h
+++ b/security/super/files/patch-localsys.h
@@ -1,4 +1,4 @@
---- localsys.h.orig 2007-12-20 19:14:53 UTC
+--- localsys.h.orig 2018-05-21 22:43:28 UTC
+++ localsys.h
@@ -16,14 +16,14 @@
#ifndef LOCALSYS_H
@@ -17,15 +17,14 @@
#ifdef HAVE_UNISTD_H
#include <unistd.h>
#endif
-@@ -293,9 +293,11 @@ extern int sysinfo();
+@@ -293,8 +293,10 @@ extern int sysinfo();
#include <unistd.h>
#endif
+#ifndef __FreeBSD__ /* FBSD has a malloc.h that tells people to obey C89. */
#ifdef HAVE_MALLOC_H
#include <malloc.h>
- #endif
+#endif
+ #endif
#ifdef HAVE_SYSLOG_H
- #include <syslog.h>