aboutsummaryrefslogtreecommitdiff
path: root/security/suricata
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2014-11-11 15:57:52 +0000
committerRenato Botelho <garga@FreeBSD.org>2014-11-11 15:57:52 +0000
commit16910802f2a2ea6e0b35319bbe90d92dfc5dc619 (patch)
tree12580e7417be9f7f02a2e7ef6c69543cd13b4757 /security/suricata
parent05c440e10b8ce7764516afe28cd1e644a2c1b785 (diff)
downloadports-16910802f2a2ea6e0b35319bbe90d92dfc5dc619.tar.gz
ports-16910802f2a2ea6e0b35319bbe90d92dfc5dc619.zip
Notes
Diffstat (limited to 'security/suricata')
-rw-r--r--security/suricata/Makefile30
-rw-r--r--security/suricata/distinfo4
-rw-r--r--security/suricata/pkg-plist27
3 files changed, 49 insertions, 12 deletions
diff --git a/security/suricata/Makefile b/security/suricata/Makefile
index c417fa002156..69de9c946238 100644
--- a/security/suricata/Makefile
+++ b/security/suricata/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= suricata
-PORTVERSION= 2.0.3
+PORTVERSION= 2.0.4
CATEGORIES= security
MASTER_SITES= http://www.openinfosecfoundation.org/download/ \
http://mirrors.rit.edu/zi/
@@ -13,20 +13,22 @@ COMMENT= High Performance Network IDS, IPS and Security Monitoring engine
LICENSE= GPLv2
LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre \
- libhtp.so:${PORTSDIR}/devel/libhtp \
libnet.so:${PORTSDIR}/net/libnet \
libyaml.so:${PORTSDIR}/textproc/libyaml
-OPTIONS_DEFINE= IPFW PRELUDE PORTS_PCAP TESTS
-OPTIONS_DEFAULT=IPFW PRELUDE
+OPTIONS_DEFINE= IPFW PRELUDE PORTS_PCAP TESTS JSON GEOIP HTP_PORT
+OPTIONS_DEFAULT=IPFW PRELUDE HTP_PORT
OPTIONS_SUB= yes
IPFW_DESC= Enable IPFW and IP Divert support for inline IDP
PRELUDE_DESC= Enable Prelude support for NIDS alerts
PORTS_PCAP_DESC=Use libpcap from ports
TESTS_DESC= Enable unit tests in suricata binary
+JSON_DESC= Enable Suricata JSON output
+GEOIP_DESC= Enable GeoIP support for Suricata
+HTP_PORT_DESC= Use libhtp from ports instead of bundled
-USES= gmake pkgconfig libtool
+USES= gmake pkgconfig libtool pathfix
USE_AUTOTOOLS= aclocal autoconf automake
USE_LDCONFIG= yes
USE_RC_SUBR= ${PORTNAME}
@@ -43,10 +45,18 @@ PRELUDE_LIB_DEPENDS= libprelude.so:${PORTSDIR}/security/libprelude
PRELUDE_CONFIGURE_ENABLE= prelude
PRELUDE_CONFIGURE_ON= --with-libprelude-prefix=${LOCALBASE}
TESTS_CONFIGURE_ENABLE= unittests
+JSON_CONFIGURE_OFF= --with-libjansson-includes=${LOCALBASE}/include \
+ --with-libjansson-libraries=${LOCALBASE}/lib
+JSON_LIB_DEPENDS= libjansson.so:${PORTSDIR}/devel/jansson
+GEOIP_CONFIGURE_ON= --enable-geoip
+GEOIP_LIB_DEPENDS= libGeoIP.so:${PORTSDIR}/net/GeoIP
+HTP_PORT_CONFIGURE_ON= --enable-non-bundled-htp
+HTP_PORT_LIB_DEPENDS= libhtp.so:${PORTSDIR}/devel/libhtp
+HTP_PORT_CONFLICT_OFF= libhtp-[0-9]* libhtp-suricata
SUB_FILES= pkg-message
-CONFIGURE_ARGS+=--enable-non-bundled-htp --enable-gccprotect \
+CONFIGURE_ARGS+=--enable-gccprotect \
--with-libpcre-includes=${LOCALBASE}/include \
--with-libpcre-libraries=${LOCALBASE}/lib \
--with-libyaml-includes=${LOCALBASE}/include \
@@ -66,6 +76,12 @@ LOGS_DIR?= /var/log/${PORTNAME}
.include <bsd.port.pre.mk>
+.if ${PORT_OPTIONS:MHTP_PORT}
+PLIST_SUB+= HTPPORT="@comment "
+.else
+PLIST_SUB+= HTPPORT=""
+.endif
+
.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
BROKEN= Does not compile on ia64, powerpc, or sparc64
.endif
@@ -80,7 +96,7 @@ post-install:
${MKDIR} ${STAGEDIR}${CONFIG_DIR}
${MKDIR} ${STAGEDIR}${RULES_DIR}
.for f in ${CONFIG_FILES}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${CONFIG_DIR}/${f}-sample
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${CONFIG_DIR}/${f}.sample
.endfor
TMPDIR?= /tmp
diff --git a/security/suricata/distinfo b/security/suricata/distinfo
index c245148e01a7..941ac43fd124 100644
--- a/security/suricata/distinfo
+++ b/security/suricata/distinfo
@@ -1,2 +1,2 @@
-SHA256 (suricata-2.0.3.tar.gz) = b6e554cbacb925bbcf88dd4554c9222b51b21796c39e198cdf5b0b9cdc1ed383
-SIZE (suricata-2.0.3.tar.gz) = 3083891
+SHA256 (suricata-2.0.4.tar.gz) = 677d97a829d9e05f664c82eb0372e870d5f6e9501ccee20130dfde4014bd5084
+SIZE (suricata-2.0.4.tar.gz) = 3085919
diff --git a/security/suricata/pkg-plist b/security/suricata/pkg-plist
index 8fd918f4c1f8..ac2eb6ffd4ed 100644
--- a/security/suricata/pkg-plist
+++ b/security/suricata/pkg-plist
@@ -28,7 +28,28 @@ bin/suricata
%%DOCSDIR%%/Ubuntu_Installation.txt
%%DOCSDIR%%/Ubuntu_Installation_from_GIT.txt
%%DOCSDIR%%/Windows.txt
-@sample etc/suricata/suricata.yaml-sample
-@sample etc/suricata/classification.config-sample
-@sample etc/suricata/reference.config-sample
+%%HTPPORT%%include/htp/bstr.h
+%%HTPPORT%%include/htp/bstr_builder.h
+%%HTPPORT%%include/htp/htp.h
+%%HTPPORT%%include/htp/htp_base64.h
+%%HTPPORT%%include/htp/htp_config.h
+%%HTPPORT%%include/htp/htp_connection_parser.h
+%%HTPPORT%%include/htp/htp_core.h
+%%HTPPORT%%include/htp/htp_decompressors.h
+%%HTPPORT%%include/htp/htp_hooks.h
+%%HTPPORT%%include/htp/htp_list.h
+%%HTPPORT%%include/htp/htp_multipart.h
+%%HTPPORT%%include/htp/htp_table.h
+%%HTPPORT%%include/htp/htp_transaction.h
+%%HTPPORT%%include/htp/htp_urlencoded.h
+%%HTPPORT%%include/htp/htp_utf8_decoder.h
+%%HTPPORT%%include/htp/htp_version.h
+%%HTPPORT%%lib/libhtp-0.5.15.so.1
+%%HTPPORT%%lib/libhtp-0.5.15.so.1.0.0
+%%HTPPORT%%lib/libhtp.a
+%%HTPPORT%%lib/libhtp.so
+%%HTPPORT%%libdata/pkgconfig/htp.pc
+@sample etc/suricata/suricata.yaml.sample
+@sample etc/suricata/classification.config.sample
+@sample etc/suricata/reference.config.sample
@dir etc/suricata/rules