aboutsummaryrefslogtreecommitdiff
path: root/security/tclsasl
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-01-14 09:22:26 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-01-14 09:22:26 +0000
commit747aa787c5fa317d85f50ed2a11a1d9e4adbf5a0 (patch)
tree12d3e183007ccb939255548b53eb01e17ab39dfa /security/tclsasl
parent0fdc2deabfcce27d4c55602e3be7beec15c72995 (diff)
downloadports-747aa787c5fa317d85f50ed2a11a1d9e4adbf5a0.tar.gz
ports-747aa787c5fa317d85f50ed2a11a1d9e4adbf5a0.zip
- Convert to USES=tcl
- Convert to new LIB_DEPENDS format - Remove article from COMMENT - STAGE-clean
Notes
Notes: svn path=/head/; revision=339668
Diffstat (limited to 'security/tclsasl')
-rw-r--r--security/tclsasl/Makefile19
-rw-r--r--security/tclsasl/files/patch-Makefile.in12
-rw-r--r--security/tclsasl/files/patch-configure2
3 files changed, 18 insertions, 15 deletions
diff --git a/security/tclsasl/Makefile b/security/tclsasl/Makefile
index 3e782a3fdcf3..4db4957b301e 100644
--- a/security/tclsasl/Makefile
+++ b/security/tclsasl/Makefile
@@ -9,27 +9,24 @@ MASTER_SITES= http://beepcore-tcl.sourceforge.net/
EXTRACT_SUFX= .tgz
MAINTAINER= dsh@vlink.ru
-COMMENT= A Tcl interface to the Cyrus SASLv2 library
+COMMENT= Tcl interface to the Cyrus SASLv2 library
-LIB_DEPENDS= sasl2:${PORTSDIR}/security/cyrus-sasl2
+LIB_DEPENDS= libsasl2.so:${PORTSDIR}/security/cyrus-sasl2
+USES= tcl
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USE_TCL= yes
-USE_TCL_BUILD= yes
CONFIGURE_ARGS= --with-tcl=${TCL_LIBDIR} \
--with-tclinclude=${TCL_INCLUDEDIR} \
- --with-cyrus-sasl=${LOCALBASE}
-CONFIGURE_ENV= INSTALL="${INSTALL_DATA}"
+ --with-cyrus-sasl=${LOCALBASE} \
+ --prefix=${PREFIX}
+CONFIGURE_ENV= INSTALL="${INSTALL_DATA}" STAGEDIR="${STAGEDIR}"
PORTDOCS= tclsasl.html
-NO_STAGE= yes
post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/tclsasl.html ${DOCSDIR}
-.endif
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/tclsasl.html ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/security/tclsasl/files/patch-Makefile.in b/security/tclsasl/files/patch-Makefile.in
index fc524ece1962..9defb6ce961a 100644
--- a/security/tclsasl/files/patch-Makefile.in
+++ b/security/tclsasl/files/patch-Makefile.in
@@ -1,5 +1,5 @@
---- Makefile.in.orig Sat Jun 8 11:10:07 2002
-+++ Makefile.in Wed Apr 26 13:14:22 2006
+--- Makefile.in.orig 2002-06-08 09:10:07.000000000 +0200
++++ Makefile.in 2014-01-14 10:23:11.000000000 +0100
@@ -137,7 +137,7 @@
WISH_PROG = @WISH_PROG@
tclsasl_LIB_FILE = @tclsasl_LIB_FILE@
@@ -18,7 +18,13 @@
all-redirect: all-am
install-strip:
$(MAKE) $(AM_MAKEFLAGS) AM_INSTALL_PROGRAM_FLAGS=-s install
-@@ -437,7 +437,6 @@
+@@ -432,12 +432,11 @@
+ $(mkinstalldirs) @PKG_TCL@
+ echo "package ifneeded sasl" \
+ `echo $(VERSION) | awk -F. '{ printf "%s.%s", $$1, $$2 }'` \
+- "[list load $(DESTDIR)$(libdir)/libtclsasl.so]" \
++ "[list load $(libdir)/libtclsasl.so]" \
+ > @PKG_TCL@/pkgIndex.tcl
sed -e 's%load .libs/libtclsasl.so%package require sasl%' \
< test.tcl \
> @PKG_TCL@/test.tcl
diff --git a/security/tclsasl/files/patch-configure b/security/tclsasl/files/patch-configure
index 658de24ad48d..2a103af23369 100644
--- a/security/tclsasl/files/patch-configure
+++ b/security/tclsasl/files/patch-configure
@@ -5,7 +5,7 @@
-PKG_TCL=${TCL_PACKAGE_PATH}/sasl-${VERSION}
-+PKG_TCL=${TCL_PREFIX}/lib/tclsasl
++PKG_TCL=${STAGEDIR}${prefix}/lib/tclsasl
# Check whether --with-cyrus-sasl or --without-cyrus-sasl was given.