aboutsummaryrefslogtreecommitdiff
path: root/security/teleport
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-06-29 03:51:13 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-06-29 03:51:13 +0000
commit3726f942547e374490d375baf83216d7644a7162 (patch)
tree8c7c440762c72012824110ba9cdd44c8c1765017 /security/teleport
parent1de291090d9121f4d238a639b441f64372c239c1 (diff)
downloadports-3726f942547e374490d375baf83216d7644a7162.tar.gz
ports-3726f942547e374490d375baf83216d7644a7162.zip
Convert all Go ports to USES=go
This allows for port testing with lang/go-devel via GO_PORT, setting up the Go build environment in a single place, and is step one in simplifying Go ports that often define too complicated do-build targets themselves. USES=go gains new arguments 'run' to add lang/go to RUN_DEPENDS and 'no_targets' for ports with composite builds that call 'go' themselves and do not need the do-build/do-install targets of USES=go. PR: 238849 Submitted by: dg@syrec.org (also D20745) Reviewed by: mat, tobik Exp-run by: antoine Differential Revision: https://reviews.freebsd.org/D20746
Notes
Notes: svn path=/head/; revision=505321
Diffstat (limited to 'security/teleport')
-rw-r--r--security/teleport/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/security/teleport/Makefile b/security/teleport/Makefile
index e6bdd4ce2fdb..6ba534f53aa1 100644
--- a/security/teleport/Makefile
+++ b/security/teleport/Makefile
@@ -13,10 +13,9 @@ LICENSE= APACHE20
NOT_FOR_ARCHS= i386
NOT_FOR_ARCHS_REASON= Uses 64bit types
-BUILD_DEPENDS= go:lang/go \
- zip:archivers/zip
+BUILD_DEPENDS= zip:archivers/zip
-USES= compiler gmake
+USES= compiler gmake go
USE_GITHUB= yes
GH_ACCOUNT= gravitational