aboutsummaryrefslogtreecommitdiff
path: root/security/teleport
diff options
context:
space:
mode:
authorSean Chittenden <seanc@FreeBSD.org>2018-07-02 14:55:47 +0000
committerSean Chittenden <seanc@FreeBSD.org>2018-07-02 14:55:47 +0000
commit3ce02a00363b9f5b5e37897aaa5f69af3b30f874 (patch)
treeac2ba75db370fe8c52e543800909135043ca600d /security/teleport
parent9fbb2ea85aed4b1a813311d7cd0011c2807952f4 (diff)
downloadports-3ce02a00363b9f5b5e37897aaa5f69af3b30f874.tar.gz
ports-3ce02a00363b9f5b5e37897aaa5f69af3b30f874.zip
Optimize teleport build steps by invoking sed(1) and find(1) only once.
Submitted by: mat (mentor) Approved by: mat (mentor, implicit)
Notes
Notes: svn path=/head/; revision=473745
Diffstat (limited to 'security/teleport')
-rw-r--r--security/teleport/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/security/teleport/Makefile b/security/teleport/Makefile
index f09b0e9102f6..5ec5c1e75dff 100644
--- a/security/teleport/Makefile
+++ b/security/teleport/Makefile
@@ -45,8 +45,9 @@ post-extract:
post-patch:
@${REINPLACE_CMD} -e 's|^GITREF=.*|GITREF=${GH_TAG_COMMIT}|' \
${WRKDIR}/${GO_TELEPORT_SRC_DIR}/version.mk
- @${FIND} ${WRKDIR} -type f -exec ${SED} -i '' -e 's|\/var\/lib|/var/db|g' {} \;
- @${FIND} ${WRKDIR} -type f -exec ${SED} -i '' -e 's|\/usr\/bin\/hostname|/bin/hostname|g' {} \;
+ @${FIND} ${WRKDIR} -type f \
+ -exec ${SED} -i '' -e 's|\/var\/lib|/var/db|g' {} \; \
+ -exec ${SED} -i '' -e 's|\/usr\/bin\/hostname|/bin/hostname|g' {} \;
do-build:
@cd ${WRKDIR}/${GO_TELEPORT_SRC_DIR} && \
@@ -56,8 +57,10 @@ do-build:
do-install:
${WRKDIR}/${GO_TELEPORT_SRC_DIR}/build/teleport configure > ${STAGEDIR}${PREFIX}/etc/teleport.yaml.sample
- @${SED} -i '' -e "s|nodename: .*|nodename: |g" ${STAGEDIR}${PREFIX}/etc/teleport.yaml.sample
- @${SED} -i '' -e "s|cluster-join-token||g" ${STAGEDIR}${PREFIX}/etc/teleport.yaml.sample
+ @${SED} -i '' \
+ -e "s|nodename: .*|nodename: |g" \
+ -e "s|cluster-join-token||g" \
+ ${STAGEDIR}${PREFIX}/etc/teleport.yaml.sample
${INSTALL_PROGRAM} ${WRKDIR}/${GO_TELEPORT_SRC_DIR}/build/teleport ${STAGEDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKDIR}/${GO_TELEPORT_SRC_DIR}/build/tsh ${STAGEDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKDIR}/${GO_TELEPORT_SRC_DIR}/build/tctl ${STAGEDIR}${PREFIX}/bin