aboutsummaryrefslogtreecommitdiff
path: root/security/teleport
diff options
context:
space:
mode:
authorSean Chittenden <seanc@FreeBSD.org>2018-05-11 20:35:39 +0000
committerSean Chittenden <seanc@FreeBSD.org>2018-05-11 20:35:39 +0000
commit5655610037f9f6ed97bbe5cba19274e8f397150c (patch)
treeac80b49fcdd0d00a6018e03019f28504415b6ba9 /security/teleport
parentf60413669da9f57e7f96d3695008f343b9f340a6 (diff)
downloadports-5655610037f9f6ed97bbe5cba19274e8f397150c.tar.gz
ports-5655610037f9f6ed97bbe5cba19274e8f397150c.zip
Upgrade gravitational teleport to 2.5.7.
Explicitly specify the git sha when building teleport. Restrict builds to amd64. Reviewed by: swills, mat Approved by: swills (mentor) Differential Revision: https://reviews.freebsd.org/D15311
Notes
Notes: svn path=/head/; revision=469693
Diffstat (limited to 'security/teleport')
-rw-r--r--security/teleport/Makefile11
-rw-r--r--security/teleport/distinfo6
-rw-r--r--security/teleport/files/patch-version.mk8
3 files changed, 20 insertions, 5 deletions
diff --git a/security/teleport/Makefile b/security/teleport/Makefile
index 4e5df12cb77f..dabb1455c55e 100644
--- a/security/teleport/Makefile
+++ b/security/teleport/Makefile
@@ -2,7 +2,7 @@
PORTNAME= teleport
DISTVERSIONPREFIX= v
-DISTVERSION= 2.5.6
+DISTVERSION= 2.5.7
CATEGORIES= security
MAINTAINER= seanc@FreeBSD.org
@@ -10,6 +10,8 @@ COMMENT= Gravitational Telport SSH
LICENSE= APACHE20
+ONLY_FOR_ARCHS= amd64
+
BUILD_DEPENDS= ${LOCALBASE}/bin/go:lang/go \
${LOCALBASE}/bin/zip:archivers/zip
@@ -18,6 +20,7 @@ USES= compiler gmake
USE_GITHUB= yes
GH_ACCOUNT= gravitational
GH_TAGNAME= v${DISTVERSION}${DISTVERSIONSUFFIX}
+GH_TAG_COMMIT= b3f4ecb
USE_RC_SUBR= teleport
@@ -38,11 +41,15 @@ post-extract:
@${CP} -rp ${WRKDIR}/${PRE_GOPATH_DIR}/vendor/* ${WRKDIR}/src/
@${CP} -rp ${WRKDIR}/${PRE_GOPATH_DIR}/* ${WRKDIR}/${GO_TELEPORT_SRC_DIR}/
+post-patch:
+ @${REINPLACE_CMD} -e "s|%%GH_TAG_COMMIT%%|${GH_TAG_COMMIT}|g" \
+ ${WRKDIR}/${GO_TELEPORT_SRC_DIR}/version.mk
+
do-build:
@cd ${WRKDIR}/${GO_TELEPORT_SRC_DIR} && \
${SETENV} ${MAKE_ENV} ${BUILD_ENV} \
CGO_ENABLED=1 GOPATH=${WRKDIR} \
- ${GMAKE} full
+ ${GMAKE} -s full
do-install:
${WRKDIR}/${GO_TELEPORT_SRC_DIR}/build/teleport configure > ${STAGEDIR}${PREFIX}/etc/teleport.yaml.sample
diff --git a/security/teleport/distinfo b/security/teleport/distinfo
index afa9b81a61d7..ccf73fd660fe 100644
--- a/security/teleport/distinfo
+++ b/security/teleport/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1524207284
-SHA256 (gravitational-teleport-v2.5.6_GH0.tar.gz) = 7a7168df106b1d4ea3b81b5078eaf6ea8f6063b11c7171202d2e2b9bfbdcfe2c
-SIZE (gravitational-teleport-v2.5.6_GH0.tar.gz) = 16216649
+TIMESTAMP = 1525898627
+SHA256 (gravitational-teleport-v2.5.7_GH0.tar.gz) = 26a62a4ae91482d51191f53edde01a93b13e23a257b5336de06e336ed39c8e7e
+SIZE (gravitational-teleport-v2.5.7_GH0.tar.gz) = 16216353
diff --git a/security/teleport/files/patch-version.mk b/security/teleport/files/patch-version.mk
new file mode 100644
index 000000000000..92d7ca36ec11
--- /dev/null
+++ b/security/teleport/files/patch-version.mk
@@ -0,0 +1,8 @@
+--- ../src/github.com/gravitational/teleport/version.mk.orig 2018-05-05 22:53:11 UTC
++++ ../src/github.com/gravitational/teleport/version.mk
+@@ -1,4 +1,4 @@
+-GITREF=`git describe --dirty --long --tags`
++GITREF="%%GH_TAG_COMMIT%%"
+
+ # $(VERSION_GO) will be written to version.go
+ VERSION_GO="/* DO NOT EDIT THIS FILE. IT IS GENERATED BY 'make setver'*/\n\n\