aboutsummaryrefslogtreecommitdiff
path: root/security/testssl.sh
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-04-10 08:13:16 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-04-10 08:13:16 +0000
commit85a79fab40d543764005acb6de12fec02b304fb0 (patch)
tree3a017d71ddf8ad9863e7df79447c34f8ba4ab9a9 /security/testssl.sh
parenta69606911e0e4d6f810bf08a15a793d591a32690 (diff)
downloadports-85a79fab40d543764005acb6de12fec02b304fb0.tar.gz
ports-85a79fab40d543764005acb6de12fec02b304fb0.zip
security/testssl.sh: Update to 2.9.5-4
Notes
Notes: svn path=/head/; revision=466943
Diffstat (limited to 'security/testssl.sh')
-rw-r--r--security/testssl.sh/Makefile2
-rw-r--r--security/testssl.sh/distinfo6
-rw-r--r--security/testssl.sh/files/patch-testssl.sh9
3 files changed, 4 insertions, 13 deletions
diff --git a/security/testssl.sh/Makefile b/security/testssl.sh/Makefile
index 3ac1b4b2a536..678a4581af09 100644
--- a/security/testssl.sh/Makefile
+++ b/security/testssl.sh/Makefile
@@ -2,7 +2,7 @@
PORTNAME= testssl.sh
DISTVERSIONPREFIX= v
-DISTVERSION= 2.9.5-3
+DISTVERSION= 2.9.5-4
CATEGORIES= security
MAINTAINER= tobik@FreeBSD.org
diff --git a/security/testssl.sh/distinfo b/security/testssl.sh/distinfo
index 908ad9c3ce97..90e741a108d0 100644
--- a/security/testssl.sh/distinfo
+++ b/security/testssl.sh/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1521967012
-SHA256 (drwetter-testssl.sh-v2.9.5-3_GH0.tar.gz) = 03abee78d1373098b2a99766bc57cf498e0d9ddaf8b9eb3389fac2540fd5af0d
-SIZE (drwetter-testssl.sh-v2.9.5-3_GH0.tar.gz) = 8955546
+TIMESTAMP = 1523347210
+SHA256 (drwetter-testssl.sh-v2.9.5-4_GH0.tar.gz) = 5163f76d40acfe404d65145c498cbe8fb716bb49119e8d0773e063203cff9c03
+SIZE (drwetter-testssl.sh-v2.9.5-4_GH0.tar.gz) = 9017058
diff --git a/security/testssl.sh/files/patch-testssl.sh b/security/testssl.sh/files/patch-testssl.sh
index f88e60f7f4cb..f22cbcc0ea7f 100644
--- a/security/testssl.sh/files/patch-testssl.sh
+++ b/security/testssl.sh/files/patch-testssl.sh
@@ -10,12 +10,3 @@
declare -x OPENSSL OPENSSL_TIMEOUT
FAST_SOCKET=${FAST_SOCKET:-false} # EXPERIMENTAL feature to accelerate sockets -- DO NOT USE it for production
COLOR=${COLOR:-2} # 2: Full color, 1: b/w+positioning, 0: no ESC at all
-@@ -6221,7 +6224,7 @@ certificate_info() {
- # best we are able to do under OpenBSD
- days2expire=""
- else
-- days2expire=$(( $(parse_date "$enddate" "+%s" "%F %H:%M %z") - $(LC_ALL=C date "+%s") )) # in seconds
-+ days2expire=$(( $(parse_date "$enddate" "+%s" "%F %H:%M") - $(LC_ALL=C date "+%s") )) # in seconds
- days2expire=$((days2expire / 3600 / 24 ))
-
- if grep -q "^Let's Encrypt Authority" <<< "$issuer_CN"; then # we take the half of the thresholds for LE certificates