aboutsummaryrefslogtreecommitdiff
path: root/security/tinc-devel
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2019-11-24 19:16:40 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2019-11-24 19:16:40 +0000
commit3f02e0abb4305ed83f18b4bba76274cbc83e4c38 (patch)
treef1b4cb437992c6671c07c7ecdf96de4c76dc705c /security/tinc-devel
parent2b022808db4a919c9d62a5e88965c6ed8a6a4a13 (diff)
downloadports-3f02e0abb4305ed83f18b4bba76274cbc83e4c38.tar.gz
ports-3f02e0abb4305ed83f18b4bba76274cbc83e4c38.zip
- fix EVP_DecryptUpdate with OpenSSL versions 1.0.2r and 1.1.1b
Notes
Notes: svn path=/head/; revision=518353
Diffstat (limited to 'security/tinc-devel')
-rw-r--r--security/tinc-devel/Makefile2
-rw-r--r--security/tinc-devel/files/patch-cipher.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/security/tinc-devel/Makefile b/security/tinc-devel/Makefile
index b16a8e7a7606..37fa08fce688 100644
--- a/security/tinc-devel/Makefile
+++ b/security/tinc-devel/Makefile
@@ -2,7 +2,7 @@
PORTNAME= tinc
PORTVERSION= 1.1pre17
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= security net-vpn
MASTER_SITES= https://www.tinc-vpn.org/packages/ \
http://www.tinc-vpn.org/packages/
diff --git a/security/tinc-devel/files/patch-cipher.c b/security/tinc-devel/files/patch-cipher.c
new file mode 100644
index 000000000000..206b330567de
--- /dev/null
+++ b/security/tinc-devel/files/patch-cipher.c
@@ -0,0 +1,11 @@
+--- src/openssl/cipher.c.orig 2018-10-07 11:43:07 UTC
++++ src/openssl/cipher.c
+@@ -189,7 +189,7 @@ bool cipher_decrypt(cipher_t *cipher, const void *inda
+ } else {
+ int len;
+
+- if(EVP_EncryptUpdate(cipher->ctx, outdata, &len, indata, inlen)) {
++ if(EVP_DecryptUpdate(cipher->ctx, outdata, &len, indata, inlen)) {
+ if(outlen) {
+ *outlen = len;
+ }