aboutsummaryrefslogtreecommitdiff
path: root/security/tor/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-05-29 07:30:00 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-05-29 07:30:00 +0000
commit1bdeb191e96affe67b27880f9a7c5b7d20d2c67b (patch)
tree664fb2f33d173c7684171db92e2ad99720298204 /security/tor/Makefile
parent9c1df109f25cb5faa5513df66b94b1b14089df8e (diff)
downloadports-1bdeb191e96affe67b27880f9a7c5b7d20d2c67b.tar.gz
ports-1bdeb191e96affe67b27880f9a7c5b7d20d2c67b.zip
Notes
Diffstat (limited to 'security/tor/Makefile')
-rw-r--r--security/tor/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/security/tor/Makefile b/security/tor/Makefile
new file mode 100644
index 000000000000..ff21c9f181f6
--- /dev/null
+++ b/security/tor/Makefile
@@ -0,0 +1,30 @@
+# ports collection makefile for: tor
+# Date created: 2004.05.28
+# Whom: freebsd-ports@rikrose.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= tor
+PORTVERSION= 0.0.6.2
+CATEGORIES= security
+MASTER_SITES= http://freehaven.net/tor/dist/
+
+MAINTAINER= freebsd-ports@rikrose.net
+COMMENT= An anonymizing overlay network for TCP
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_OPENSSL= yes
+USE_REINPLACE= yes
+
+MANCOMPRESSED= no
+MAN1= tor.1 torify.1
+
+post-patch:
+ @${MV} ${WRKSRC}/contrib/tor-tsocks.conf \
+ ${WRKSRC}/contrib/tor-tsocks.conf.sample
+ @${REINPLACE_CMD} -e "s|tor-tsocks.conf|tor-tsocks.conf.sample|g" \
+ ${WRKSRC}/contrib/Makefile.in
+
+.include <bsd.port.mk>