aboutsummaryrefslogtreecommitdiff
path: root/security/tpm2-tools
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-10-07 12:23:51 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-10-07 12:23:51 +0000
commit12faa7eed0f2b5628d90677b42e326ccbd98e4b0 (patch)
tree7e25268db9feb79467851e9e5335b59972e7538c /security/tpm2-tools
parent508262737cead50bdcaba5f80b09b13453c302bc (diff)
downloadports-12faa7eed0f2b5628d90677b42e326ccbd98e4b0.tar.gz
ports-12faa7eed0f2b5628d90677b42e326ccbd98e4b0.zip
security/tpm2-tools: fix build on GCC architectures
Use C11 compiler: tools/tpm2_tool.c:92: error: 'tpm2_option_flags' has no member named 'verbose' tools/tpm2_tool.c:103: error: 'tpm2_option_flags' has no member named 'quiet' tools/tpm2_tool.c:116: error: 'tpm2_option_flags' has no member named 'enable_errata'
Notes
Notes: svn path=/head/; revision=551632
Diffstat (limited to 'security/tpm2-tools')
-rw-r--r--security/tpm2-tools/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/security/tpm2-tools/Makefile b/security/tpm2-tools/Makefile
index fd6b7eb5843e..13bae0a01721 100644
--- a/security/tpm2-tools/Makefile
+++ b/security/tpm2-tools/Makefile
@@ -14,7 +14,7 @@ LIB_DEPENDS= libtss2-esys.so:security/tpm2-tss \
libcurl.so:ftp/curl \
libuuid.so:misc/e2fsprogs-libuuid
-USES= gmake libtool pkgconfig ssl
+USES= compiler:c11 gmake libtool pkgconfig ssl
GNU_CONFIGURE= yes
CONFIGURE_ENV= CRYPTO_CFLAGS="-I${OPENSSLINC}" CRYPTO_LIBS="-L${OPENSSLLIB} -lcrypto"