aboutsummaryrefslogtreecommitdiff
path: root/security/tripwire-131
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2005-05-13 23:49:46 +0000
committerCy Schubert <cy@FreeBSD.org>2005-05-13 23:49:46 +0000
commit85a2430bdaba89c3424e804b0588396d0b92bbad (patch)
treedd0c2059ea1ea32989a6039621e313a8343abe05 /security/tripwire-131
parentc7559159b83547794a1e7d82ae0361250290bc22 (diff)
downloadports-85a2430bdaba89c3424e804b0588396d0b92bbad.tar.gz
ports-85a2430bdaba89c3424e804b0588396d0b92bbad.zip
Remove code to create a tripwire floppy disk. As FreeBSD no longer supports
gzipped binaries and since systems with larger data stores, it is no longer reasonable to expect to fit the tripwire binary and database onto a single floppy disk. PR: 80978
Notes
Notes: svn path=/head/; revision=135216
Diffstat (limited to 'security/tripwire-131')
-rw-r--r--security/tripwire-131/Makefile14
1 files changed, 0 insertions, 14 deletions
diff --git a/security/tripwire-131/Makefile b/security/tripwire-131/Makefile
index b0528c2d3c21..5bb4d57c9b67 100644
--- a/security/tripwire-131/Makefile
+++ b/security/tripwire-131/Makefile
@@ -38,20 +38,6 @@ post-install:
.ifndef NO_DB_BUILD
@ ${ECHO} Creating tripwire database
@ (cd /var/adm/tcheck; tripwire -initialize)
-.if defined(TRIPWIRE_FLOPPY) && ${TRIPWIRE_FLOPPY} == YES
- @ disklabel -w -B /dev/rfd0c fd1440
- @ newfs -u 0 -t 0 -i 196608 -m 0 -T minimum -o space /dev/rfd0c
- @ mount /dev/fd0c /mnt
- @ ${GZIP_CMD} < ${PREFIX}/bin/tripwire > /mnt/tripwire
- @ ${CP} -p /var/adm/tcheck/tw.config /mnt/tw.config
- @ ${GZIP_CMD} < /var/adm/tcheck/databases/tw.db_`hostname` \
- > /mnt/tw.db_`hostname`.gz
- @ ${CP} -p ${FILESDIR}/twcheck /mnt/twcheck
- @ ${GZIP_CMD} < /usr/bin/gunzip > /mnt/gunzip
- @ ${CHMOD} 555 /mnt/tripwire /mnt/gunzip /mnt/twcheck
- @ umount /mnt
- @ ${ECHO} Do not forget to remove and write-protect the floppy.
-.endif
.endif
.include <bsd.port.post.mk>