aboutsummaryrefslogtreecommitdiff
path: root/security/tripwire12
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2008-09-12 21:00:07 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2008-09-12 21:00:07 +0000
commitcb240e58aed6f60a95fd87cdc87935707783d9bf (patch)
tree94d202f17b95cafb7493a82a1e66cfd736e9e8a0 /security/tripwire12
parent8770aa32efe7c3a583395ba809a5ca0a44a17587 (diff)
downloadports-cb240e58aed6f60a95fd87cdc87935707783d9bf.tar.gz
ports-cb240e58aed6f60a95fd87cdc87935707783d9bf.zip
Notes
Diffstat (limited to 'security/tripwire12')
-rw-r--r--security/tripwire12/Makefile2
-rw-r--r--security/tripwire12/files/patch-aux_Makefile12
2 files changed, 14 insertions, 0 deletions
diff --git a/security/tripwire12/Makefile b/security/tripwire12/Makefile
index 275427dfd381..57bd817857ae 100644
--- a/security/tripwire12/Makefile
+++ b/security/tripwire12/Makefile
@@ -28,6 +28,8 @@ post-extract:
post-patch:
@${PERL} -pi -e 's|/secureplace/bin|${PREFIX}/bin|g;' \
-e 's|/usr/man|${PREFIX}/man|g;' ${WRKSRC}/Makefile
+ ${FIND} ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|bs_ntohl|ntohl|g;s|bs_htonl|htonl|g'
pre-configure:
@ ${CP} ${FILESDIR}/conf-freebsd2.h ${WRKSRC}/configs
diff --git a/security/tripwire12/files/patch-aux_Makefile b/security/tripwire12/files/patch-aux_Makefile
new file mode 100644
index 000000000000..40f6a69614e4
--- /dev/null
+++ b/security/tripwire12/files/patch-aux_Makefile
@@ -0,0 +1,12 @@
+--- aux/Makefile.orig 2008-09-12 17:24:07.293242000 +0000
++++ aux/Makefile 2008-09-12 17:25:08.192241000 +0000
+@@ -13,7 +13,8 @@
+ @echo "### Ignore warnings about shift count negative/too large on line 36"
+ @echo "###"
+ $(CC) $(CFLAGS) $(LDFLAGS) byteorder.c -o byteorder
+- (./byteorder; cat ./ntohl.h) > $(BORDER)
++ (./byteorder; cat ./ntohl.h) > /dev/null
++ @touch $(BORDER)
+
+ $(INODE): types.sh types.c types
+ $(SHELL) ./types.sh "$(CPP)" > $(INODE)