aboutsummaryrefslogtreecommitdiff
path: root/security/tripwire12
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2014-06-09 19:58:33 +0000
committerCy Schubert <cy@FreeBSD.org>2014-06-09 19:58:33 +0000
commitebe8ac6b286d85b435a5bf3cd734e505163bbb71 (patch)
tree8bab566f1b50af3280b96fc071d17e3e86d6f2ea /security/tripwire12
parente4e4a051e7a044f1695bce7dc47f83297c13ac31 (diff)
downloadports-ebe8ac6b286d85b435a5bf3cd734e505163bbb71.tar.gz
ports-ebe8ac6b286d85b435a5bf3cd734e505163bbb71.zip
Notes
Diffstat (limited to 'security/tripwire12')
-rw-r--r--security/tripwire12/Makefile23
-rw-r--r--security/tripwire12/files/patch-ab108
-rw-r--r--security/tripwire12/files/patch-src-Makefile23
-rw-r--r--security/tripwire12/pkg-plist9
4 files changed, 91 insertions, 72 deletions
diff --git a/security/tripwire12/Makefile b/security/tripwire12/Makefile
index 2ac098c880a0..797c06f88724 100644
--- a/security/tripwire12/Makefile
+++ b/security/tripwire12/Makefile
@@ -8,26 +8,31 @@ CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_NETBSD}
PKGNAMESUFFIX= 12
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= cy@FreeBSD.org
COMMENT= File system security and verification program
-MAN5= tw.config.5
-MAN8= siggen.8 tripwire.8
NO_CDROM= cannot be redistributed for more than the cost of duplication
NO_PACKAGE= requires local database to be built
+ONLY_FOR_ARCHS= i386
+ONLY_FOR_ARCHS_REASON= Unknown BYTEORDER
USES= perl5
USE_PERL5= build
MAKE_JOBS_UNSAFE=yes
+.include <bsd.port.pre.mk>
+
+TDATADIR= ${STAGEDIR}/var/local/tcheck
+MAKE_ARGS= BINDIR=${STAGEDIR}${PREFIX}/bin \
+ MANDIR=${STAGEDIR}${PREFIX}/man \
+ DATADIR=${DATADIR}
+NO_DB_BUILD= yes
+
TWCONFIG?= ${FILESDIR}/tw.conf.freebsd8
-NO_STAGE= yes
post-extract:
@ (cd ${WRKDIR}; tar xpf T1.2.tar)
post-patch:
- @${REINPLACE_CMD} -i '' -e 's|/secureplace/bin|${PREFIX}/bin|' \
- -e 's|/usr/man|${PREFIX}/man|' ${WRKSRC}/Makefile
${FIND} ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} -e \
's|bs_ntohl|ntohl|g;s|bs_htonl|htonl|g'
@@ -36,8 +41,8 @@ pre-configure:
@ ${CP} ${TWCONFIG} ${WRKSRC}/configs/tw.conf.freebsd8
post-install:
- @ ${MKDIR} /var/adm/tcheck
- @ ${CP} ${TWCONFIG} /var/adm/tcheck/tw.config
+ @ ${MKDIR} ${TDATADIR}
+ @ ${CP} ${TWCONFIG} /${TDATADIR}/tw.config.dist
# Creating tripwire database
.ifndef NO_DB_BUILD
@ (cd /var/adm/tcheck; tripwire -initialize)
@@ -59,4 +64,4 @@ post-install:
.endif
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/tripwire12/files/patch-ab b/security/tripwire12/files/patch-ab
index 7dcf3348984f..4c9bc53f16e1 100644
--- a/security/tripwire12/files/patch-ab
+++ b/security/tripwire12/files/patch-ab
@@ -1,62 +1,46 @@
-*** Makefile Mon Jul 25 10:59:41 1994
---- Makefile Thu Jan 2 12:04:35 1997
-***************
-*** 34,36 ****
- # you can use ANSI C if you like, but K&R is equally fine.
-! CC = cc # common
- #CC = gcc # also common
---- 34,36 ----
- # you can use ANSI C if you like, but K&R is equally fine.
-! #CC = cc # common
- #CC = gcc # also common
-***************
-*** 38,40 ****
-
-! CFLAGS = -O # common
- #CFLAGS = -g # common
---- 38,40 ----
-
-! #CFLAGS = -O # common
- #CFLAGS = -g # common
-***************
-*** 60,66 ****
- #CPP = /lib/cpp # on older systems
-
- # make sure libraries are not linked dynamically (as a security measure)
-! LDFLAGS= # common
- #LDFLAGS= -non_shared # OSF/1
- #LDFLAGS= -Bstatic # SunOS 4 (cannot statically link tripwire
- # on Solaris 2.3)
---- 60,67 ----
- #CPP = /lib/cpp # on older systems
-
- # make sure libraries are not linked dynamically (as a security measure)
-! LDFLAGS= -static
-! #LDFLAGS= # common
- #LDFLAGS= -non_shared # OSF/1
- #LDFLAGS= -Bstatic # SunOS 4 (cannot statically link tripwire
- # on Solaris 2.3)
-
-
---- src/Makefile.orig Mon Jul 25 10:40:54 1994
-+++ src/Makefile Sun May 28 15:52:25 2000
-@@ -3,7 +3,7 @@
- # Tripwire build
- #
-
--CFLAGS = -O
-+#CFLAGS = -O
-
- OFILES = config.parse.o main.o list.o ignorevec.o dbase.build.o \
- utils.o preen.o preen.interp.o preen.report.o \
-@@ -103,8 +103,9 @@
- .c.o:
- $(CC) $(CFLAGS) -c $<
-
--install: tripwire
-+install: tripwire siggen
- $(INSTALL) tripwire $(DESTDIR)
-+ $(INSTALL) siggen $(DESTDIR)
-
- clean:
- -rm -f $(OFILES) config.lex.c config.pre.c y.tab.c lex.yy.c help.c \
+--- Makefile.orig 2014-06-09 12:38:51.784239761 -0700
++++ Makefile 2014-06-09 12:43:05.345562324 -0700
+@@ -12,10 +12,8 @@
+ ###
+
+ # destination directory for final executables
+-DESTDIR = /secureplace/bin
+
+ # destination for man pages
+-MANDIR = /usr/man
+
+ # system utilities
+ LEX = lex
+@@ -32,11 +30,11 @@
+ #SHELL = /bin/bash # For the GNU fanatics
+
+ # you can use ANSI C if you like, but K&R is equally fine.
+-CC = cc # common
++#CC = cc # common
+ #CC = gcc # also common
+ #CC = /usr/ccs/bin/cc # Pyramid DC/OSx (SVR4)
+
+-CFLAGS = -O # common
++#CFLAGS = -O # common
+ #CFLAGS = -g # common
+ #CFLAGS = -g # debugging
+ #CFLAGS = -O -cckr # SGI
+@@ -60,7 +58,8 @@
+ #CPP = /lib/cpp # on older systems
+
+ # make sure libraries are not linked dynamically (as a security measure)
+-LDFLAGS= # common
++LDFLAGS= -static
++#LDFLAGS= # common
+ #LDFLAGS= -non_shared # OSF/1
+ #LDFLAGS= -Bstatic # SunOS 4 (cannot statically link tripwire
+ # on Solaris 2.3)
+@@ -103,7 +102,7 @@
+ YACC="$(YACC)" LEX="$(LEX)" all)
+
+ install: all
+- (cd src; make INSTALL=$(INSTALL) DESTDIR=$(DESTDIR) install)
++ (cd src; make INSTALL=$(INSTALL) DESTDIR=$(BINDIR) install)
+ (cd man; make INSTALL=$(INSTALL) MANDIR=$(MANDIR) install)
+
+ test: all
diff --git a/security/tripwire12/files/patch-src-Makefile b/security/tripwire12/files/patch-src-Makefile
new file mode 100644
index 000000000000..9c0cbad8b23f
--- /dev/null
+++ b/security/tripwire12/files/patch-src-Makefile
@@ -0,0 +1,23 @@
+--- src/Makefile.orig Mon Jul 25 10:40:54 1994
++++ src/Makefile Sun May 28 15:52:25 2000
+@@ -3,7 +3,7 @@
+ # Tripwire build
+ #
+
+-CFLAGS = -O
++#CFLAGS = -O
+
+ OFILES = config.parse.o main.o list.o ignorevec.o dbase.build.o \
+ utils.o preen.o preen.interp.o preen.report.o \
+@@ -103,8 +103,9 @@
+ .c.o:
+ $(CC) $(CFLAGS) -c $<
+
+-install: tripwire
++install: tripwire siggen
+- $(INSTALL) tripwire $(DESTDIR)
++ $(INSTALL) tripwire $(BINDIR)
++ $(INSTALL) siggen $(BINDIR)
+
+ clean:
+ -rm -f $(OFILES) config.lex.c config.pre.c y.tab.c lex.yy.c help.c \
diff --git a/security/tripwire12/pkg-plist b/security/tripwire12/pkg-plist
index f34115341fbe..aec88b6983ba 100644
--- a/security/tripwire12/pkg-plist
+++ b/security/tripwire12/pkg-plist
@@ -1,2 +1,9 @@
-bin/siggen
bin/tripwire
+bin/siggen
+man/man5/tw.config.5.gz
+man/man8/siggen.8.gz
+man/man8/tripwire.8.gz
+/var/local/tcheck/tw.config.dist
+@unexec rmdir "/var/local/tcheck" >/dev/null 2>&1 || :
+@unexec rmdir "/var/local" >/dev/null 2>&1 || :
+