aboutsummaryrefslogtreecommitdiff
path: root/security/tripwire
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-04-28 21:02:39 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-04-28 21:02:39 +0000
commit0b881b0ecebc9440a559f1c2b27758488a1188fa (patch)
tree933fd11da647dda8c169bc24693094174bdc0355 /security/tripwire
parent928d434bd206738b7213dd9b5802c680794a9b10 (diff)
downloadports-0b881b0ecebc9440a559f1c2b27758488a1188fa.tar.gz
ports-0b881b0ecebc9440a559f1c2b27758488a1188fa.zip
Convert security to new options framework
Notes
Notes: svn path=/head/; revision=316749
Diffstat (limited to 'security/tripwire')
-rw-r--r--security/tripwire/Makefile44
1 files changed, 18 insertions, 26 deletions
diff --git a/security/tripwire/Makefile b/security/tripwire/Makefile
index b4cb17c9f0d2..808d02424143 100644
--- a/security/tripwire/Makefile
+++ b/security/tripwire/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: tripwire 2.3.1
-# Date created: Tue Mar 6 06:57:58 PST 2001
-# Whom: Cy Schubert <Cy.Schubert@uumail.gov.bc.ca>
-#
+# Created by: Cy Schubert <Cy.Schubert@uumail.gov.bc.ca>
# $FreeBSD$
-#
PORTNAME= tripwire
PORTVERSION= 2.4.2.2
@@ -36,38 +32,34 @@ TWDB?= /var/db/tripwire
#
# If TW_PROMPT is set to true, the install script is interactive.
-OPTIONS= TWCFG_ETC "Put config files in ${ETCDIR}" on \
- TWCFG_TWDB "Put config files in ${TWDB}/etc" off \
- TW_CLOBBER "Clobber existing database files at install" off \
- TW_PROMPT "Interactive install (ignored when PACKAGE_BUILDING)" on \
- SW_ONLY "Install software only, do not post-configure (ignored when PACKAGE_BUILDING)" off \
- DB_BUILD "Build database during post-install (ignored when PACKAGE_BUILDING)" on
+OPTIONS_SINGLE= TWCFG
+OPTIONS_SINGLE_TWCFG= TWCFG_ETC TWCFG_TWDB
+OPTIONS_DEFINE= TW_CLOBBER TW_PROMPT SW_ONLY DB_BUILD
+OPTIONS_DEFAULT= TWCFG_ETC TW_PROMPT DB_BUILD
+TWCFG_ETC_DESC= Put config files in ${ETCDIR}
+TWCFG_TWDB_DESC= Put config files in ${TWDB}/etc
+TW_CLOBBER_DESC= Clobber existing database files at install
+TW_PROMPT_DESC= Interactive install (ignored when PACKAGE_BUILDING)
+SW_ONLY_DESC= Install software only, do not post-configure (ignored when PACKAGE_BUILDING)
+DB_BUILD_DESC= Build database during post-install (ignored when PACKAGE_BUILDING)
.include <bsd.port.pre.mk>
-.if defined(WITH_TWCFG_ETC) && ${WITH_TWCFG_ETC} == "true" && defined(WITH_TWCFG_TWDB) && ${WITH_TWCFG_TWDB} == "true"
-BROKEN= Must select only one of WITH_TWCFG_ETC or WITH_TWCFG_TWDB
-.endif
-
# Tripwire config files are stored in TWCFG
-.if defined(WITH_TWCFG_ETC) && ${WITH_TWCFG_ETC} == "true"
+.if ${PORT_OPTIONS:MTWCFG_ETC}
TWCFG?= ${ETCDIR}
.endif
-.if defined(WITH_TWCFG_TWDB) && ${WITH_TWCFG_TWDB} == "true"
+.if ${PORT_OPTIONS:MTWCFG_TWDB}
TWCFG?= ${TWDB}/etc
.endif
-.ifndef TWCFG
-BROKEN= TWCFG must be defined
-.endif
-
-.if defined(WITH_TW_CLOBBER) && ${WITH_TW_CLOBBER} == "true"
+.if ${PORT_OPTIONS:MTW_CLOBBER}
TW_CLOBBER= true
.else
TW_CLOBBER= false
.endif
-.if defined(WITH_TW_PROMPT) && ${WITH_TW_PROMPT} == "true"
+.if ${PORT_OPTIONS:MTW_PROMPT}
TW_PROMPT= true
.else
TW_PROMPT= false
@@ -125,7 +117,7 @@ install-config-files:
.ifdef PACKAGE_BUILDING
@ cd ${WRKSRC} && PREFIX=${PREFIX} TW_CLOBBER=${TW_CLOBBER} DO_NOT_CONFIG="yes" TW_PROMPT="false" ${GMAKE} install-data-hook
.else
-.if defined(WITH_SW_ONLY) && ${WITH_SW_ONLY} == "true"
+.if ${PORT_OPTIONS:MSW_ONLY} && ${WITH_SW_ONLY} == "true"
@ cd ${WRKSRC} && PREFIX=${PREFIX} TW_CLOBBER=${TW_CLOBBER} DO_NOT_CONFIG="yes" TW_PROMPT="false" ${GMAKE} install-data-hook
.else
@ cd ${WRKSRC} && PREFIX=${PREFIX} TW_CLOBBER=${TW_CLOBBER} TW_PROMPT=${TW_PROMPT} ${GMAKE} install-data-hook
@@ -167,8 +159,8 @@ make-pkg-install:
@ ${SED} "/^\. /s/^/: /;/^BASE_DIR=/d;s/BIN_DIR=/: BIN_DIR=/;/^POLICYSRC/d" ${WRKSRC}/install/install.sh >> ${PKGINSTALL}
create-database:
-.if defined(WITH_DB_BUILD) && ${WITH_DB_BUILD} == "true"
-.if defined(WITH_SW_ONLY) && ${WITH_SW_ONLY} == "true"
+.if ${PORT_OPTIONS:MDB_BUILD} && ${WITH_DB_BUILD} == "true"
+.if ${PORT_OPTIONS:MSW_ONLY} && ${WITH_SW_ONLY} == "true"
@ ${ECHO} SW_ONLY has been specified, database will not be built.
.else
@ ${MKDIR} -p ${TWCFG} ${TWPOLICY} ${TWSITEKEYDIR} ${TWLOCALKEYDIR} \