aboutsummaryrefslogtreecommitdiff
path: root/security/tripwire
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2005-08-23 22:34:14 +0000
committerCy Schubert <cy@FreeBSD.org>2005-08-23 22:34:14 +0000
commitbcbce02d6108b7bf0a75a2d4b890bfab6028abcf (patch)
treeeabb5e295be6e57d60249a1e0c8675b6fb2e8ca2 /security/tripwire
parent5fff46907efa71ee8bac2bd9fccf3c26f9eb343e (diff)
downloadports-bcbce02d6108b7bf0a75a2d4b890bfab6028abcf.tar.gz
ports-bcbce02d6108b7bf0a75a2d4b890bfab6028abcf.zip
Fix for broken build under 4.X.
Approved by: portsmgr (clement)
Notes
Notes: svn path=/head/; revision=140961
Diffstat (limited to 'security/tripwire')
-rw-r--r--security/tripwire/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/security/tripwire/Makefile b/security/tripwire/Makefile
index 90f469894b1c..b954e5a5c699 100644
--- a/security/tripwire/Makefile
+++ b/security/tripwire/Makefile
@@ -27,9 +27,6 @@ ALL_TARGET= release
MAKE_ARGS= SYSPRE=${ARCH}-unknown-freebsd
IS_INTERACTIVE= yes
-USE_GCC= 2.95
-USE_REINPLACE= YES
-
# Tripwire config files are stored in TWCFG
TWCFG?= /usr/local/etc/tripwire
# Tripwire policy files are stored in TWPOLICY.
@@ -55,6 +52,11 @@ TRIPWIRE_CLOBBER?= NO
PLIST_SUB+= TWCFG=${TWCFG} TWDB=${TWDB}
+.if ${OSVERSION} > 501000
+USE_GCC= 2.95
+USE_REINPLACE= YES
+.endif
+
pre-configure:
@ ${CP} ${TWPOL_TXT} ${WRKSRC}/policy/twpol.txt
@ ${MV} ${WRKSRC}/src/core/stdcore.h ${WRKSRC}/src/core/stdcore.h.orig
@@ -62,7 +64,7 @@ pre-configure:
@ ${MV} ${WRKSRC}/man/man4/twconfig.4 ${WRKSRC}/man/man5/twconfig.5
@ ${MV} ${WRKSRC}/man/man4/twpolicy.4 ${WRKSRC}/man/man5/twpolicy.5
-
+.if ${OSVERSION} > 501000
post-extract:
@ ${REINPLACE_CMD} -e "s|CC \= gcc|CC \= gcc295|g" ${WRKSRC}/src/STLport-4.0/src/gcc.mak
@ ${REINPLACE_CMD} -e "s|CXX \= c\+\+|CXX \= g\+\+295|g" ${WRKSRC}/src/STLport-4.0/src/gcc.mak
@@ -75,6 +77,7 @@ post-extract:
@ ${REINPLACE_CMD} -e "s|malloc.h|stdlib.h|g" ${WRKSRC}/src/core/msystem.cpp
@ ${REINPLACE_CMD} -e "s|malloc.h|stdlib.h|g" ${WRKSRC}/src/twparser/yylex.cpp
@ ${REINPLACE_CMD} -e "s|malloc.h|stdlib.h|g" ${WRKSRC}/src/tripwire/tripwiremain.cpp
+.endif
install-software:
@ ${ECHO_CMD} TWPOLICY=${TWPOLICY} >> ${WRKSRC}/install/install.cfg