aboutsummaryrefslogtreecommitdiff
path: root/security/trousers
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2013-12-05 07:59:03 +0000
committerHiroki Sato <hrs@FreeBSD.org>2013-12-05 07:59:03 +0000
commit2ff8392ce2c672998d4d06f7d2b23beb86374dbf (patch)
tree5631a4f25e8791f1d8ddbcdc86cdb9a384226092 /security/trousers
parent1fd2c0f0945c61ab560647b7d8b91ea6e3fe96d0 (diff)
downloadports-2ff8392ce2c672998d4d06f7d2b23beb86374dbf.tar.gz
ports-2ff8392ce2c672998d4d06f7d2b23beb86374dbf.zip
Fix iconv and pthread dependency.
Notes
Notes: svn path=/head/; revision=335654
Diffstat (limited to 'security/trousers')
-rw-r--r--security/trousers/Makefile9
-rw-r--r--security/trousers/files/extra-patch-src-tcsd-Makefile.am2
-rw-r--r--security/trousers/files/patch-src-trspi-Makefile.am6
-rw-r--r--security/trousers/files/patch-src-tspi-Makefile.am4
4 files changed, 9 insertions, 12 deletions
diff --git a/security/trousers/Makefile b/security/trousers/Makefile
index 29cfa84a681c..5d572421d9ba 100644
--- a/security/trousers/Makefile
+++ b/security/trousers/Makefile
@@ -3,7 +3,7 @@
PORTNAME= trousers
PORTVERSION= 0.3.10
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
@@ -20,11 +20,12 @@ USE_OPENSSL= YES
USE_LDCONFIG= YES
USE_AUTOTOOLS= autoconf automake libtool
USE_RC_SUBR= tcsd
-WRKSRC= ${WRKDIR}/${DISTNAME}
GNU_CONFIGURE= YES
CONFIGURE_ARGS= --with-gui=none --enable-static \
--localstatedir=${PREFIX}/var \
--with-tssuser=${USERS} --with-tssgroup=${GROUPS}
+MAKE_ENV= PTHREAD_LIBS=${PTHREAD_LIBS} ICONV_LIB=${ICONV_LIB} \
+ ICONV_PREFIX=${ICONV_PREFIX}
SUB_FILES= pkg-message
SUB_LIST= USERS=${USERS} GROUPS=${GROUPS}
USERS= _tss
@@ -51,10 +52,6 @@ CONFLICTS+= tpm-emulator-[0-9]*
PLIST_SUB+= TDDL=""
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's/-liconv$$/${ICONV_LIB}/' \
- ${WRKSRC}/src/tspi/Makefile.am
-
run-autotools: run-autotools-autoreconf
run-autotools-autoreconf:
diff --git a/security/trousers/files/extra-patch-src-tcsd-Makefile.am b/security/trousers/files/extra-patch-src-tcsd-Makefile.am
index c8b73b26b908..daa4e7d5e0c5 100644
--- a/security/trousers/files/extra-patch-src-tcsd-Makefile.am
+++ b/security/trousers/files/extra-patch-src-tcsd-Makefile.am
@@ -5,7 +5,7 @@
tcsd_CFLAGS=-DAPPID=\"TCSD\" -DVAR_PREFIX=\"@localstatedir@\" -DETC_PREFIX=\"@sysconfdir@\" -I${top_srcdir}/src/include -fPIE -DPIE
-tcsd_LDADD=${top_builddir}/src/tcs/libtcs.a ${top_builddir}/src/tddl/libtddl.a -lpthread @CRYPTOLIB@
-+tcsd_LDADD=${LOCALBASE}/lib/libtcs.a ${LOCALBASE}/lib/libtddl.a ${PTHREAD_LIB} @CRYPTOLIB@
++tcsd_LDADD=${LOCALBASE}/lib/libtcs.a ${LOCALBASE}/lib/libtddl.a ${PTHREAD_LIBS} @CRYPTOLIB@
tcsd_LDFLAGS=-pie -Wl,-z,relro -Wl,-z,now
tcsd_SOURCES=svrside.c tcsd_conf.c tcsd_threads.c platform.c
diff --git a/security/trousers/files/patch-src-trspi-Makefile.am b/security/trousers/files/patch-src-trspi-Makefile.am
index ab16997c76ba..e9fd99e550c7 100644
--- a/security/trousers/files/patch-src-trspi-Makefile.am
+++ b/security/trousers/files/patch-src-trspi-Makefile.am
@@ -1,12 +1,12 @@
---- src/trspi/Makefile.am.orig 2010-03-12 05:41:54.000000000 +0900
-+++ src/trspi/Makefile.am 2010-10-24 21:04:04.839558584 +0900
+--- src/trspi/Makefile.am.orig 2012-09-20 02:24:48.000000000 +0900
++++ src/trspi/Makefile.am 2013-12-05 15:12:35.000000000 +0900
@@ -1,7 +1,8 @@
noinst_LTLIBRARIES=libtrousers.la
libtrousers_la_SOURCES=trousers.c crypto/@CRYPTO_PACKAGE@/hash.c
-libtrousers_la_CFLAGS=-DAPPID=\"TSPI\" -I${top_srcdir}/src/include
+libtrousers_la_CFLAGS=-DAPPID=\"TSPI\" -I${top_srcdir}/src/include \
-+ -I${LOCALBASE}/include -I@prefix@/include
++ -I${ICONV_PREFIX}/include
if TSS_BUILD_ASYM_CRYPTO
libtrousers_la_SOURCES+=crypto/@CRYPTO_PACKAGE@/rsa.c
diff --git a/security/trousers/files/patch-src-tspi-Makefile.am b/security/trousers/files/patch-src-tspi-Makefile.am
index 4274ae1173c4..1c9e96318be8 100644
--- a/security/trousers/files/patch-src-tspi-Makefile.am
+++ b/security/trousers/files/patch-src-tspi-Makefile.am
@@ -1,11 +1,11 @@
--- src/tspi/Makefile.am.orig 2012-09-20 02:24:48.000000000 +0900
-+++ src/tspi/Makefile.am 2013-07-27 04:01:03.000000000 +0900
++++ src/tspi/Makefile.am 2013-12-05 11:10:14.000000000 +0900
@@ -17,7 +17,7 @@
# 5. If any interfaces have been added since the last public release, then increment age.
# 6. If any interfaces have been removed since the last public release, then set age to 0.
-libtspi_la_LDFLAGS=-version-info 3:0:2 -lpthread @CRYPTOLIB@
-+libtspi_la_LDFLAGS=-version-info 3:0:2 ${PTHREAD_LIB} @CRYPTOLIB@ -L@prefix@/lib -liconv
++libtspi_la_LDFLAGS=-version-info 3:0:2 ${PTHREAD_LIBS} @CRYPTOLIB@ -L${ICONV_PREFIX}/lib ${ICONV_LIB}
libtspi_la_CFLAGS=-I$(top_srcdir)/src/include -DAPPID=\"TSPI\" -DVAR_PREFIX=\"@localstatedir@\" -DETC_PREFIX=\"@sysconfdir@\"