aboutsummaryrefslogtreecommitdiff
path: root/security/tthsum
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2016-08-08 14:46:25 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2016-08-08 14:46:25 +0000
commitd5e210f440755f4b3b1dfc29cdc1c90fee8ef6c9 (patch)
treed72a0551d5bba5817d627adcce76718f0f154d42 /security/tthsum
parentea9aa57517152db8e2612092396ce9f77bafca23 (diff)
downloadports-d5e210f440755f4b3b1dfc29cdc1c90fee8ef6c9.tar.gz
ports-d5e210f440755f4b3b1dfc29cdc1c90fee8ef6c9.zip
- Strip binary
- Pacify portlint
Notes
Notes: svn path=/head/; revision=419856
Diffstat (limited to 'security/tthsum')
-rw-r--r--security/tthsum/Makefile4
-rw-r--r--security/tthsum/files/patch-Makefile8
2 files changed, 8 insertions, 4 deletions
diff --git a/security/tthsum/Makefile b/security/tthsum/Makefile
index f0bf85b835b9..62a325f864f2 100644
--- a/security/tthsum/Makefile
+++ b/security/tthsum/Makefile
@@ -3,6 +3,7 @@
PORTNAME= tthsum
PORTVERSION= 1.3.2
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://tthsum.devs.nu/pkg/ \
LOCAL/ehaupt
@@ -21,6 +22,9 @@ PLIST_FILES= bin/tthsum man/man1/tthsum.1.gz
MAKE_ENV+= STAGEDIR=${STAGEDIR}
WRKSRC= ${WRKDIR}/${PORTNAME}
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
regression-test: build
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} test runtest
diff --git a/security/tthsum/files/patch-Makefile b/security/tthsum/files/patch-Makefile
index cd42b6eafe49..1373840a700a 100644
--- a/security/tthsum/files/patch-Makefile
+++ b/security/tthsum/files/patch-Makefile
@@ -1,6 +1,6 @@
---- ./Makefile.orig 2013-08-13 20:58:36.000000000 +0200
-+++ ./Makefile 2013-08-14 14:40:58.335943659 +0200
-@@ -11,16 +11,6 @@
+--- Makefile.orig 2013-08-13 18:58:36 UTC
++++ Makefile
+@@ -11,16 +11,6 @@ ifeq ($(MAN),)
MAN = $(DESTDIR)/usr/local/man
endif
@@ -17,7 +17,7 @@
CC ?= gcc
GZIP = gzip -9 -c
RM = rm -rf
-@@ -47,12 +37,12 @@
+@@ -47,12 +37,12 @@ TSTENTRY = $(BINS)/test.o
override CPPFLAGS += $(shell cat $(BINS)/autoconf.cppflags)