aboutsummaryrefslogtreecommitdiff
path: root/security/vault
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2020-08-28 18:53:06 +0000
committerSteve Wills <swills@FreeBSD.org>2020-08-28 18:53:06 +0000
commit3bc951f6db41917538dd45ba2833936f50740ac1 (patch)
tree68e4c5ada529c63523eafd0521aa7c2ccb0f6f20 /security/vault
parent5d8433a9b072514bb67410be98c28caa9a96b8bb (diff)
downloadports-3bc951f6db41917538dd45ba2833936f50740ac1.tar.gz
ports-3bc951f6db41917538dd45ba2833936f50740ac1.zip
security/vault: update to 1.5.3
Notes
Notes: svn path=/head/; revision=546798
Diffstat (limited to 'security/vault')
-rw-r--r--security/vault/Makefile7
-rw-r--r--security/vault/distinfo12
-rw-r--r--security/vault/files/patch-go.mod20
-rw-r--r--security/vault/files/patch-vendor_modules.txt11
4 files changed, 7 insertions, 43 deletions
diff --git a/security/vault/Makefile b/security/vault/Makefile
index 51dccd292111..c3d077bbbbaf 100644
--- a/security/vault/Makefile
+++ b/security/vault/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= vault
-PORTVERSION= 1.5.2
+PORTVERSION= 1.5.3
DISTVERSIONPREFIX= v
CATEGORIES= security
@@ -15,8 +15,7 @@ USES= go:modules
USE_GITHUB= yes
GH_TUPLE= hashicorp:${PORTNAME}:${VAULTTAG}:DEFAULT \
- swills:vaultui:${VAULTUITAG}:vaultui \
- hashicorp:vault-plugin-auth-gcp:07ff53341dfe:hashicorp_vault_plugin_auth_gcp
+ swills:vaultui:${VAULTUITAG}:vaultui
GO_PKGNAME= github.com/${GH_ACCOUNT}/${PORTNAME}
COMMIT_ID= 685fdfa
@@ -42,7 +41,5 @@ PORTSCOUT= limit:^(v?)[0-9]+\.[0-9]+\.[0-9]+$
post-patch:
@${CP} ${WRKDIR}/vaultui-${PORTVERSION}/http/bindata_assetfs.go ${WRKDIR}/vault-${PORTVERSION}/http/bindata_assetfs.go
- @${RM} -r ${WRKSRC}/vendor/github.com/hashicorp/vault-plugin-auth-gcp
- @${MV} ${WRKSRC_hashicorp_vault_plugin_auth_gcp} ${WRKSRC}/vendor/github.com/hashicorp/vault-plugin-auth-gcp
.include <bsd.port.mk>
diff --git a/security/vault/distinfo b/security/vault/distinfo
index 21f7b634718a..1e1958da2d0a 100644
--- a/security/vault/distinfo
+++ b/security/vault/distinfo
@@ -1,7 +1,5 @@
-TIMESTAMP = 1598377568
-SHA256 (hashicorp-vault-v1.5.2_GH0.tar.gz) = b1f96830b27a8717cab2b80a21bfb62ac928249b9ef359b4796a0eb426e2dfbe
-SIZE (hashicorp-vault-v1.5.2_GH0.tar.gz) = 35118624
-SHA256 (swills-vaultui-v1.5.2_GH0.tar.gz) = 9981f980a4a547e305acd49c3031f1e622b5cdd85dab55cba4375e2b30926c8d
-SIZE (swills-vaultui-v1.5.2_GH0.tar.gz) = 1614180
-SHA256 (hashicorp-vault-plugin-auth-gcp-07ff53341dfe_GH0.tar.gz) = ae515d604c7aba64e4c4409b19a397fde4d73880ca69808695521bd2a43e9746
-SIZE (hashicorp-vault-plugin-auth-gcp-07ff53341dfe_GH0.tar.gz) = 3505128
+TIMESTAMP = 1598640047
+SHA256 (hashicorp-vault-v1.5.3_GH0.tar.gz) = 65a9e3b8de40650ffa72a54716ff26d0a42788c3844500ff6028fe87f13c05e7
+SIZE (hashicorp-vault-v1.5.3_GH0.tar.gz) = 35123873
+SHA256 (swills-vaultui-v1.5.3_GH0.tar.gz) = e22cd3eb186a0fb7ca4f1342a0d86ab7a997553e4e33ab0ac87679d8b4cbb0c3
+SIZE (swills-vaultui-v1.5.3_GH0.tar.gz) = 1614206
diff --git a/security/vault/files/patch-go.mod b/security/vault/files/patch-go.mod
deleted file mode 100644
index 71a3c6ea0d2a..000000000000
--- a/security/vault/files/patch-go.mod
+++ /dev/null
@@ -1,20 +0,0 @@
---- go.mod.orig 2020-08-25 17:39:09 UTC
-+++ go.mod
-@@ -6,8 +6,6 @@ replace github.com/hashicorp/vault/api => ./api
-
- replace github.com/hashicorp/vault/sdk => ./sdk
-
--replace github.com/hashicorp/vault-plugin-auth-gcp => github.com/hashicorp/vault-plugin-auth-gcpent v0.0.0-20200721115240-07ff53341dfe
--
- require (
- cloud.google.com/go v0.56.0
- cloud.google.com/go/spanner v1.5.1
-@@ -71,7 +69,7 @@ require (
- github.com/hashicorp/vault-plugin-auth-azure v0.5.6
- github.com/hashicorp/vault-plugin-auth-centrify v0.5.5
- github.com/hashicorp/vault-plugin-auth-cf v0.5.4
-- github.com/hashicorp/vault-plugin-auth-gcp v0.7.0
-+ github.com/hashicorp/vault-plugin-auth-gcp v0.7.1-0.20200721115240-07ff53341dfe
- github.com/hashicorp/vault-plugin-auth-jwt v0.7.3
- github.com/hashicorp/vault-plugin-auth-kerberos v0.1.6
- github.com/hashicorp/vault-plugin-auth-kubernetes v0.7.0
diff --git a/security/vault/files/patch-vendor_modules.txt b/security/vault/files/patch-vendor_modules.txt
deleted file mode 100644
index 3eb0a8970577..000000000000
--- a/security/vault/files/patch-vendor_modules.txt
+++ /dev/null
@@ -1,11 +0,0 @@
---- vendor/modules.txt.orig 2020-08-25 17:50:07 UTC
-+++ vendor/modules.txt
-@@ -458,7 +458,7 @@ github.com/hashicorp/vault-plugin-auth-cf/signatures
- github.com/hashicorp/vault-plugin-auth-cf/testing/certificates
- github.com/hashicorp/vault-plugin-auth-cf/testing/cf
- github.com/hashicorp/vault-plugin-auth-cf/util
--# github.com/hashicorp/vault-plugin-auth-gcp v0.7.0 => github.com/hashicorp/vault-plugin-auth-gcpent v0.0.0-20200721115240-07ff53341dfe
-+# github.com/hashicorp/vault-plugin-auth-gcp v0.7.1-0.20200721115240-07ff53341dfe
- github.com/hashicorp/vault-plugin-auth-gcp/plugin
- github.com/hashicorp/vault-plugin-auth-gcp/plugin/cache
- # github.com/hashicorp/vault-plugin-auth-jwt v0.7.3