aboutsummaryrefslogtreecommitdiff
path: root/security/veracrypt
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2019-09-05 04:40:34 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2019-09-05 04:40:34 +0000
commit1b8df01dc34a7d9e20a905afa54988baa961e2ed (patch)
treed276624565ac059bc1408b77c890d36834d411d9 /security/veracrypt
parented44dcd35dfca5db79ca33a8db91e62a13d2f212 (diff)
downloadports-1b8df01dc34a7d9e20a905afa54988baa961e2ed.tar.gz
ports-1b8df01dc34a7d9e20a905afa54988baa961e2ed.zip
- Fix build on i386
PR: 234858 Reported by: emaste
Notes
Notes: svn path=/head/; revision=511154
Diffstat (limited to 'security/veracrypt')
-rw-r--r--security/veracrypt/Makefile6
-rw-r--r--security/veracrypt/files/patch-src_Makefile11
2 files changed, 16 insertions, 1 deletions
diff --git a/security/veracrypt/Makefile b/security/veracrypt/Makefile
index 3c957a550c01..2110b891db60 100644
--- a/security/veracrypt/Makefile
+++ b/security/veracrypt/Makefile
@@ -2,7 +2,7 @@
PORTNAME= veracrypt
PORTVERSION= 1.23
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= security
MASTER_SITES= SF/${PORTNAME}/${PORTNAME:S/v/V/:S/c/C/}%20${PORTVERSION}/
DISTNAME= ${PORTNAME:S/v/V/:S/c/C/}_${PORTVERSION}_Source
@@ -25,6 +25,10 @@ SUB_FILES= pkg-message
OPTIONS_DEFINE= DOCS
+.if ${ARCH} == "i386"
+MAKE_ENV+= LFLAGS=-Wl,-z,notext
+.endif
+
post-patch:
${REINPLACE_CMD} -e 's|wx-config|${WX_CONFIG}|g' ${WRKSRC}/src/Makefile
${REINPLACE_CMD} -e 's|/usr/bin|${PREFIX}/bin|g' -e \
diff --git a/security/veracrypt/files/patch-src_Makefile b/security/veracrypt/files/patch-src_Makefile
new file mode 100644
index 000000000000..cc0748da2b1b
--- /dev/null
+++ b/security/veracrypt/files/patch-src_Makefile
@@ -0,0 +1,11 @@
+--- src/Makefile 2019-09-04 22:50:16.539918000 -0500
++++ src/Makefile 2019-09-04 22:50:32.706875000 -0500
+@@ -46,7 +46,7 @@
+ export CXXFLAGS := -Wall -Wno-unused-parameter
+ C_CXX_FLAGS := -MMD -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGE_FILES -I$(BASE_DIR) -I$(BASE_DIR)/Crypto
+ export ASFLAGS := -D __GNUC__ -D __YASM__
+-export LFLAGS :=
++export LFLAGS ?=
+
+ export PKG_CONFIG_PATH ?= /usr/local/lib/pkgconfig
+