aboutsummaryrefslogtreecommitdiff
path: root/security/vpnd/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-03-31 02:17:37 +0000
committerWill Andrews <will@FreeBSD.org>2001-03-31 02:17:37 +0000
commit8fb67c9a73b2ce4cad85e34d9b40efb8c09f91a6 (patch)
tree2f404f4e977fdbbf5d5803cb2bc1b5ecc7dd0abf /security/vpnd/Makefile
parent7a8d05f3a0d066f801ade1ade1919a021286e996 (diff)
downloadports-8fb67c9a73b2ce4cad85e34d9b40efb8c09f91a6.tar.gz
ports-8fb67c9a73b2ce4cad85e34d9b40efb8c09f91a6.zip
Notes
Diffstat (limited to 'security/vpnd/Makefile')
-rw-r--r--security/vpnd/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/security/vpnd/Makefile b/security/vpnd/Makefile
new file mode 100644
index 000000000000..4c79961205ae
--- /dev/null
+++ b/security/vpnd/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: vpnd
+# Date created: 25 March 2001
+# Whom: Anders Nordby <anders@fix.no>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vpnd
+PORTVERSION= 1.1.0
+CATEGORIES= security
+MASTER_SITES= http://sunsite.dk/vpnd/archive/ \
+ http://www.freenix.no/~anders/
+
+MAINTAINER= anders@fix.no
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+HAS_CONFIGURE= yes
+
+DOCFILES= README FAQ.TXT SPEED.TXT VERSIONS
+
+post-patch:
+ @${MV} ${WRKSRC}/Makefile.FreeBSD.in ${WRKSRC}/Makefile.FreeBSD.in_tmp
+ @${SED} -e "s:^ETC_DIR=:ETC_DIR= ${PREFIX}/etc:" \
+ < ${WRKSRC}/Makefile.FreeBSD.in_tmp > ${WRKSRC}/Makefile.FreeBSD.in
+
+pre-configure:
+ ${PERL} -pi.orig -e "s@-O3@${CFLAGS}@g; s@gcc@${CC}@g" ${WRKSRC}/configure
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/vpnd ${PREFIX}/sbin/vpnd
+ @${INSTALL_DATA} ${WRKSRC}/vpnd.conf ${PREFIX}/etc/vpnd.conf.sample
+ @${INSTALL_DATA} ${WRKSRC}/vpnd.chat ${PREFIX}/etc/vpnd.chat.sample
+.if !defined(NOPORTDOCS)
+ ${INSTALL} -d -m 555 ${PREFIX}/share/doc/vpnd
+.for i in ${DOCFILES}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${PREFIX}/share/doc/vpnd
+.endfor
+.endif
+
+post-install:
+ @${ECHO} "================================================================================"
+ @${ECHO} "Make sure you set up a few IRQ's for random generation with rndcontrol before"
+ @${ECHO} "trying to generate a master key file."
+ @${ECHO} "================================================================================"
+
+.include <bsd.port.mk>