aboutsummaryrefslogtreecommitdiff
path: root/security/webfwlog
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-10-17 07:08:45 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-10-17 07:08:45 +0000
commit7aecdc91d47d5b8064b3c6c34fd87e72d82b9b7e (patch)
treec3eaa8b9ba59b8047e7dbd8b9d69040b606a8cd1 /security/webfwlog
parentb7803d99a44f299c45b0ab39e596a53d09dd912b (diff)
downloadports-7aecdc91d47d5b8064b3c6c34fd87e72d82b9b7e.tar.gz
ports-7aecdc91d47d5b8064b3c6c34fd87e72d82b9b7e.zip
Notes
Diffstat (limited to 'security/webfwlog')
-rw-r--r--security/webfwlog/Makefile23
-rw-r--r--security/webfwlog/distinfo6
-rw-r--r--security/webfwlog/pkg-plist18
3 files changed, 15 insertions, 32 deletions
diff --git a/security/webfwlog/Makefile b/security/webfwlog/Makefile
index dfb4705b1b4b..1699a4b9bc43 100644
--- a/security/webfwlog/Makefile
+++ b/security/webfwlog/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= webfwlog
-PORTVERSION= 0.93
-PORTREVISION= 1
+PORTVERSION= 0.94
CATEGORIES= security
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -28,11 +27,10 @@ WANT_PHP_WEB= yes
# want to install webfwlog, relative to ${PREFIX}.
SUB_FILES= pkg-message
-DOCS= README AUTHORS COPYING \
- CREDITS ChangeLog INSTALL \
- README ReleaseNotes
-.include <bsd.port.pre.mk>
+PORTDOCS= AUTHORS COPYING CREDITS ChangeLog INSTALL \
+ README ReleaseNotes
+PORTEXAMPLES= *
.if defined(WITH_MYSQL)
USE_MYSQL= yes
@@ -47,8 +45,6 @@ CONFIGURE_ARGS+=--with-pgsql
do-install:
@${MKDIR} ${WWWDIR}
@${MKDIR} ${WWWDIR}/include/
- @${MKDIR} ${EXAMPLESDIR}
- @(cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} \* ${EXAMPLESDIR}/)
@(cd ${WRKSRC}/webfwlog/include/ && ${COPYTREE_SHARE} \* ${WWWDIR}/include/)
${INSTALL_PROGRAM} ${WRKSRC}/syslog/wfwl_syslog ${PREFIX}/bin/
${INSTALL_DATA} ${WRKSRC}/webfwlog/style.css ${WWWDIR}
@@ -60,11 +56,16 @@ post-install:
@${MKDIR} ${DOCSDIR}/pgsql
@(cd ${WRKSRC}/mysql/ && ${COPYTREE_SHARE} \* ${DOCSDIR}/mysql/)
@(cd ${WRKSRC}/pgsql/ && ${COPYTREE_SHARE} \* ${DOCSDIR}/pgsql/)
-.for FILE in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
+.for docs in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${docs} ${DOCSDIR}
.endfor
.endif
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.endif
+
@if test -f ${PREFIX}/etc/webfwlog.conf; \
then \
${CHOWN} :${WWWGRP} ${PREFIX}/etc/webfwlog.conf; \
@@ -86,4 +87,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/webfwlog/distinfo b/security/webfwlog/distinfo
index 2ef70b58b2cb..51e180438fd4 100644
--- a/security/webfwlog/distinfo
+++ b/security/webfwlog/distinfo
@@ -1,3 +1,3 @@
-MD5 (webfwlog-0.93.tar.gz) = 85f863bf11f882486169ac0b5bb36d22
-SHA256 (webfwlog-0.93.tar.gz) = 25cf014e1580c9e270cc07bbc6a5c51e12617d6695f67e281f5a1bb4ed9779ef
-SIZE (webfwlog-0.93.tar.gz) = 271426
+MD5 (webfwlog-0.94.tar.gz) = 5af2fbbd36b039c004592e9dbf10ccc1
+SHA256 (webfwlog-0.94.tar.gz) = c1b84dd4036aa9f81fc4fbd527eda202e51c3767659b8f1eef12bfb3381c5b36
+SIZE (webfwlog-0.94.tar.gz) = 288138
diff --git a/security/webfwlog/pkg-plist b/security/webfwlog/pkg-plist
index 368590930395..4e07820aacd9 100644
--- a/security/webfwlog/pkg-plist
+++ b/security/webfwlog/pkg-plist
@@ -1,12 +1,5 @@
bin/wfwl_syslog
etc/webfwlog.conf.sample
-%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
-%%PORTDOCS%%%%DOCSDIR%%/COPYING
-%%PORTDOCS%%%%DOCSDIR%%/CREDITS
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
-%%PORTDOCS%%%%DOCSDIR%%/INSTALL
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/ReleaseNotes
%%PORTDOCS%%%%DOCSDIR%%/mysql/README
%%PORTDOCS%%%%DOCSDIR%%/mysql/setup
%%PORTDOCS%%%%DOCSDIR%%/mysql/scripts/temp_grants
@@ -32,15 +25,6 @@ etc/webfwlog.conf.sample
%%PORTDOCS%%%%DOCSDIR%%/pgsql/scripts/wfwl_reports_addcol
%%PORTDOCS%%%%DOCSDIR%%/pgsql/scripts/wfwl_reports_create
%%PORTDOCS%%%%DOCSDIR%%/pgsql/scripts/wfwl_services_create
-%%EXAMPLESDIR%%/basic
-%%EXAMPLESDIR%%/current_count
-%%EXAMPLESDIR%%/current_dport
-%%EXAMPLESDIR%%/last20hosts
-%%EXAMPLESDIR%%/latest_logged_packets
-%%EXAMPLESDIR%%/recent_active
-%%EXAMPLESDIR%%/tcpports
-%%EXAMPLESDIR%%/tcpsyn
-%%EXAMPLESDIR%%/udpports
%%WWWDIR%%/include/config.php
%%WWWDIR%%/include/criteria.php
%%WWWDIR%%/include/debug.php
@@ -68,7 +52,5 @@ etc/webfwlog.conf.sample
%%PORTDOCS%%@dirrm %%DOCSDIR%%/pgsql
%%PORTDOCS%%@dirrm %%DOCSDIR%%/mysql/scripts
%%PORTDOCS%%@dirrm %%DOCSDIR%%/mysql
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm %%EXAMPLESDIR%%
@dirrm %%WWWDIR%%/include
@dirrmtry %%WWWDIR%%