aboutsummaryrefslogtreecommitdiff
path: root/security/wipe
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-03-12 14:09:35 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-03-12 14:09:35 +0000
commit705c9445928a2d6b47f397ab12f7c82d5337df4e (patch)
tree51a0950c8c9709d1d84e851ccf96cabec8589100 /security/wipe
parent6232f06698059cd66569966bf9c9117cadc08960 (diff)
downloadports-705c9445928a2d6b47f397ab12f7c82d5337df4e.tar.gz
ports-705c9445928a2d6b47f397ab12f7c82d5337df4e.zip
- Clarify LICENSE
- Don't install unneeded docs - Switch to options helpers - Regenerate patches with `make makepatch`
Notes
Notes: svn path=/head/; revision=410885
Diffstat (limited to 'security/wipe')
-rw-r--r--security/wipe/Makefile8
-rw-r--r--security/wipe/files/patch-Makefile.in6
-rw-r--r--security/wipe/files/patch-blkdev.c8
-rw-r--r--security/wipe/files/patch-prompt.c8
4 files changed, 16 insertions, 14 deletions
diff --git a/security/wipe/Makefile b/security/wipe/Makefile
index 18059075b4fb..c1145496b8a2 100644
--- a/security/wipe/Makefile
+++ b/security/wipe/Makefile
@@ -9,14 +9,14 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= File and block device wiping utility
-LICENSE= GPLv2
+LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= tar:bzip2
GNU_CONFIGURE= yes
PLIST_FILES= bin/wipe man/man1/wipe.1.gz
-PORTDOCS= CHANGES INSTALL LICENSE README TESTING TODO copyright
+PORTDOCS= CHANGES README TESTING TODO
OPTIONS_DEFINE= DOCS
@@ -26,7 +26,9 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
diff --git a/security/wipe/files/patch-Makefile.in b/security/wipe/files/patch-Makefile.in
index 0512b45988d3..a2b23068958a 100644
--- a/security/wipe/files/patch-Makefile.in
+++ b/security/wipe/files/patch-Makefile.in
@@ -1,6 +1,6 @@
---- Makefile.in.orig Sat Aug 30 18:18:03 2003
-+++ Makefile.in Sat Mar 5 00:24:22 2005
-@@ -60,13 +60,7 @@
+--- Makefile.in.orig 2009-11-01 21:11:30 UTC
++++ Makefile.in
+@@ -60,13 +60,7 @@ install: $(BIN_OUT)
$(INSTALL_BIN) -d $(bindir)
$(INSTALL_BIN) -s $(BIN_OUT) $(bindir)
$(INSTALL) -d $(mandir)/man1
diff --git a/security/wipe/files/patch-blkdev.c b/security/wipe/files/patch-blkdev.c
index bc03f0e83fa5..ff059692caa3 100644
--- a/security/wipe/files/patch-blkdev.c
+++ b/security/wipe/files/patch-blkdev.c
@@ -1,5 +1,5 @@
---- blkdev.c.orig 2009-04-06 06:09:27.000000000 +0400
-+++ blkdev.c 2015-02-03 23:00:08.000000000 +0300
+--- blkdev.c.orig 2009-04-06 02:09:27 UTC
++++ blkdev.c
@@ -46,7 +46,9 @@
#ifdef HAVE_SYS_DISKLABEL_H
@@ -11,7 +11,7 @@
#endif
#ifndef LINUX_BLKDEV
-@@ -141,6 +143,10 @@
+@@ -141,6 +143,10 @@ public int destroy_blkdev(struct file_s
int code;
#ifdef BSD_BLKDEV
@@ -22,7 +22,7 @@
struct partinfo pinfo;
#endif
-@@ -173,7 +179,7 @@
+@@ -173,7 +179,7 @@ public int destroy_blkdev(struct file_s
}
#ifdef BSD_BLKDEV
diff --git a/security/wipe/files/patch-prompt.c b/security/wipe/files/patch-prompt.c
index c08de188dfca..d27dfa64f5f2 100644
--- a/security/wipe/files/patch-prompt.c
+++ b/security/wipe/files/patch-prompt.c
@@ -1,5 +1,5 @@
---- prompt.c.orig 2009-04-25 20:18:13.000000000 -0700
-+++ prompt.c 2009-10-18 15:29:39.000000000 -0700
+--- prompt.c.orig 2009-04-26 03:18:13 UTC
++++ prompt.c
@@ -41,9 +41,9 @@
#include "std.h"
@@ -11,7 +11,7 @@
#include "wipe.h"
#include "blkdev.h"
#include "prompt.h"
-@@ -69,7 +69,10 @@
+@@ -69,7 +69,10 @@ public void prompt_destroy(struct file_s
}
#endif
@@ -23,7 +23,7 @@
permdenied = access(f->name, perm);
if (options.interactive) /* force overrides interaction */
-@@ -119,7 +122,10 @@
+@@ -119,7 +122,10 @@ public void prompt_destroy(struct file_s
fgets(prompt, sizeof(prompt), stdin);