aboutsummaryrefslogtreecommitdiff
path: root/security/wipe
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-08 17:53:48 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-08 17:53:48 +0000
commitc0da8c6b5422deb0d4fbc19440667a62654ffe2b (patch)
tree7bb0d4beb90f694767d687d6df7a7016ec288edf /security/wipe
parente5726ecc71a2414c53b141f510f65670389b2d2c (diff)
downloadports-c0da8c6b5422deb0d4fbc19440667a62654ffe2b.tar.gz
ports-c0da8c6b5422deb0d4fbc19440667a62654ffe2b.zip
Support staging.
Notes
Notes: svn path=/head/; revision=343370
Diffstat (limited to 'security/wipe')
-rw-r--r--security/wipe/Makefile25
1 files changed, 12 insertions, 13 deletions
diff --git a/security/wipe/Makefile b/security/wipe/Makefile
index b90de20aab59..4032278d5ab7 100644
--- a/security/wipe/Makefile
+++ b/security/wipe/Makefile
@@ -14,23 +14,22 @@ LICENSE= GPLv2
USE_BZIP2= yes
GNU_CONFIGURE= yes
-PLIST_FILES= bin/wipe
-
-MAN1= wipe.1
+PLIST_FILES= bin/wipe man/man1/wipe.1.gz
PORTDOCS= CHANGES INSTALL LICENSE README TESTING TODO copyright
-NO_STAGE= yes
-post-patch:
- @${REINPLACE_CMD} -e 's|@CFLAGS@|${CFLAGS}|' ${WRKSRC}/Makefile.in
+OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
-post-install:
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- for i in ${PORTDOCS}; do \
- ${INSTALL_DATA} ${WRKSRC}/$$i ${DOCSDIR}; \
- done
-.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|@CFLAGS@|${CFLAGS}|' ${WRKSRC}/Makefile.in
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
+.endfor
.include <bsd.port.mk>