aboutsummaryrefslogtreecommitdiff
path: root/security/xca
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2020-04-30 20:24:14 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2020-04-30 20:24:14 +0000
commit077b3eaa204384707e622457d7c6af7e21a19a61 (patch)
tree7567aa1577053dd84789879d65b5dddabf71e163 /security/xca
parent8e468cf9a24bbea7b397676a8e9293f35c429f05 (diff)
Notes
Diffstat (limited to 'security/xca')
-rw-r--r--security/xca/Makefile10
-rw-r--r--security/xca/distinfo6
-rw-r--r--security/xca/files/patch-img_Makefile10
-rw-r--r--security/xca/pkg-plist5
4 files changed, 21 insertions, 10 deletions
diff --git a/security/xca/Makefile b/security/xca/Makefile
index 2ef50ee5265d..49c3b47864cd 100644
--- a/security/xca/Makefile
+++ b/security/xca/Makefile
@@ -2,9 +2,9 @@
# $FreeBSD$
PORTNAME= xca
-PORTVERSION= 2.2.1
-DISTVERSIONPREFIX= RELEASE.
+PORTVERSION= 2.3.0
CATEGORIES= security
+MASTER_SITES= https://github.com/${GH_ACCOUNT}/xca/releases/download/RELEASE.${PORTVERSION}/
MAINTAINER= madpilot@FreeBSD.org
COMMENT= Graphical certification authority
@@ -14,8 +14,8 @@ LICENSE_FILE= ${WRKSRC}/COPYRIGHT
LIB_DEPENDS= libltdl.so:devel/libltdl
-USES= autoreconf compiler:c++11-lang desktop-file-utils gmake \
- localbase pkgconfig qt:5 shared-mime-info shebangfix ssl
+USES= compiler:c++11-lang desktop-file-utils gmake localbase \
+ pkgconfig qt:5 shared-mime-info shebangfix ssl
USE_QT= buildtools_build core gui linguist_build sql widgets
USE_CXXSTD= c++11
@@ -24,10 +24,8 @@ CONFIGURE_ARGS= --with-openssl=${OPENSSLDIR} \
--with-qt=${PREFIX} \
--with-qt-version=5
MAKE_ARGS= DOCTOOL="${TRUE}"
-DESTDIRNAME= destdir
SHEBANG_FILES= doc/code2html
-USE_GITHUB= yes
GH_ACCOUNT= chris2511
OPTIONS_DEFINE= DOCS
diff --git a/security/xca/distinfo b/security/xca/distinfo
index a8a971f0f7ab..59459ba0bbb0 100644
--- a/security/xca/distinfo
+++ b/security/xca/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1580463281
-SHA256 (chris2511-xca-RELEASE.2.2.1_GH0.tar.gz) = 595e71d3b2b5b944a30cf87d3364427c47234730d995f0044fbf68aec9490bbd
-SIZE (chris2511-xca-RELEASE.2.2.1_GH0.tar.gz) = 1313088
+TIMESTAMP = 1588241325
+SHA256 (xca-2.3.0.tar.gz) = 3d168a225efaf9b2213e9ad2ba0abbccfcad139181dd2be668c2bbe21955a248
+SIZE (xca-2.3.0.tar.gz) = 1354154
diff --git a/security/xca/files/patch-img_Makefile b/security/xca/files/patch-img_Makefile
new file mode 100644
index 000000000000..a5a664b56225
--- /dev/null
+++ b/security/xca/files/patch-img_Makefile
@@ -0,0 +1,10 @@
+--- img/Makefile.orig 2020-04-29 13:18:49 UTC
++++ img/Makefile
+@@ -29,6 +29,7 @@ install-pixmaps: $(PIXMAPS)
+ install-icons: $(ICONS)
+ for SZ in 16 32 64; do \
+ if [ -f xca-$${SZ}x$${SZ}.png ]; then \
++ install -d $(DESTDIR)$(ICONDIR)/$${SZ}x$${SZ}/apps ; \
+ install -D -m 0644 xca-$${SZ}x$${SZ}.png $(DESTDIR)$(ICONDIR)/$${SZ}x$${SZ}/apps/$(ICON_NAME).png ; \
+ fi ; \
+ done
diff --git a/security/xca/pkg-plist b/security/xca/pkg-plist
index a7b6065af4d1..2b85f311d598 100644
--- a/security/xca/pkg-plist
+++ b/security/xca/pkg-plist
@@ -18,7 +18,10 @@ share/applications/xca.desktop
%%PORTDOCS%%%%DOCSDIR%%/xca-9.html
%%PORTDOCS%%%%DOCSDIR%%/xca.html
share/mime/packages/xca.xml
-share/pixmaps/xca-32x32.xpm
+share/icons/hicolor/16x16/apps/xca.png
+share/icons/hicolor/32x32/apps/xca.png
+share/icons/hicolor/64x64/apps/xca.png
+share/pixmaps/xca.xpm
%%DATADIR%%/CA.xca
%%DATADIR%%/TLS_client.xca
%%DATADIR%%/TLS_server.xca