aboutsummaryrefslogtreecommitdiff
path: root/security/xca
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-10-14 23:51:30 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-10-14 23:51:30 +0000
commit6000b270e0f2c33af60a58b9c6d5258a0428d40e (patch)
treed5e6f96f457dd3ac0b2305097610986095b5bd55 /security/xca
parentce4086cec5ac941dc4f056a0f2826c834028394f (diff)
downloadports-6000b270e0f2c33af60a58b9c6d5258a0428d40e.tar.gz
ports-6000b270e0f2c33af60a58b9c6d5258a0428d40e.zip
- Add LICENSE_FILE
- Regenerate patches with `make makepatch`
Notes
Notes: svn path=/head/; revision=399318
Diffstat (limited to 'security/xca')
-rw-r--r--security/xca/Makefile1
-rw-r--r--security/xca/files/patch-doc__Makefile10
-rw-r--r--security/xca/files/patch-img__Makefile6
-rw-r--r--security/xca/files/patch-lib__x509v3ext.cpp4
4 files changed, 11 insertions, 10 deletions
diff --git a/security/xca/Makefile b/security/xca/Makefile
index 471d798db643..8dd5e3c546cc 100644
--- a/security/xca/Makefile
+++ b/security/xca/Makefile
@@ -11,6 +11,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Graphical certification authority
LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYRIGHT
LIB_DEPENDS= libltdl.so:${PORTSDIR}/devel/libltdl
diff --git a/security/xca/files/patch-doc__Makefile b/security/xca/files/patch-doc__Makefile
index 5a977c31a197..2592aea26988 100644
--- a/security/xca/files/patch-doc__Makefile
+++ b/security/xca/files/patch-doc__Makefile
@@ -1,6 +1,6 @@
---- doc/Makefile.orig 2012-05-12 11:37:14.000000000 +0200
-+++ doc/Makefile 2012-05-14 11:19:34.000000000 +0200
-@@ -5,7 +5,7 @@
+--- doc/Makefile.orig 2012-05-12 09:37:14 UTC
++++ doc/Makefile
+@@ -5,7 +5,7 @@ endif
DELFILES=xca*.html xca.1.gz
@@ -9,7 +9,7 @@
include $(TOPDIR)/Rules.mak
mandir=man
-@@ -15,10 +15,7 @@
+@@ -15,10 +15,7 @@ xca.1.gz: xca.1
xca.html: xca.sgml
rm -f xca*.html
@@ -21,7 +21,7 @@
install: xca.1.gz xca.html
install -m 755 -d $(destdir)$(docdir) \
-@@ -26,8 +23,4 @@
+@@ -26,8 +23,4 @@ install: xca.1.gz xca.html
install -m 644 xca*.html $(destdir)$(docdir)
install xca.1.gz $(destdir)$(prefix)/$(mandir)/man1
diff --git a/security/xca/files/patch-img__Makefile b/security/xca/files/patch-img__Makefile
index 3350de844e52..5497f5b652f0 100644
--- a/security/xca/files/patch-img__Makefile
+++ b/security/xca/files/patch-img__Makefile
@@ -1,6 +1,6 @@
---- img/Makefile.orig 2011-11-07 07:09:32.000000000 +0100
-+++ img/Makefile 2011-11-23 11:15:40.000000000 +0100
-@@ -13,7 +13,7 @@
+--- img/Makefile.orig 2012-05-12 09:37:14 UTC
++++ img/Makefile
+@@ -13,7 +13,7 @@ include $(TOPDIR)/Rules.mak
sinclude .depend
install: xca-32x32.xpm
diff --git a/security/xca/files/patch-lib__x509v3ext.cpp b/security/xca/files/patch-lib__x509v3ext.cpp
index c399d2534f0b..b713f083c0d0 100644
--- a/security/xca/files/patch-lib__x509v3ext.cpp
+++ b/security/xca/files/patch-lib__x509v3ext.cpp
@@ -1,6 +1,6 @@
--- lib/x509v3ext.cpp.orig 2012-05-12 09:37:14 UTC
+++ lib/x509v3ext.cpp
-@@ -27,6 +27,8 @@
+@@ -27,6 +27,8 @@ x509v3ext::x509v3ext(const X509_EXTENSIO
x509v3ext::x509v3ext(const x509v3ext &n)
{
ext = NULL;
@@ -9,7 +9,7 @@
set(n.ext);
}
-@@ -743,7 +745,7 @@
+@@ -743,7 +745,7 @@ X509_EXTENSION *x509v3ext::get() const
bool x509v3ext::isValid() const
{