aboutsummaryrefslogtreecommitdiff
path: root/security/xca
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-12-15 13:37:30 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-12-15 13:37:30 +0000
commitce521238d54451a5bc1f37813810c7137849fc99 (patch)
treede7bdc840c08a3b71068d11e8c2a2b587e5d0207 /security/xca
parentb2bd528e93a1b82fbe06d4ee5a17d8338cccfcdc (diff)
downloadports-ce521238d54451a5bc1f37813810c7137849fc99.tar.gz
ports-ce521238d54451a5bc1f37813810c7137849fc99.zip
- List QT components
- Try if it builds now PR: ports/117658 Submitted by: Mark D. Foster <mark@foster.cc> (maintainer)
Notes
Notes: svn path=/head/; revision=203726
Diffstat (limited to 'security/xca')
-rw-r--r--security/xca/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/security/xca/Makefile b/security/xca/Makefile
index 7580a419f7d9..9a1502786fe0 100644
--- a/security/xca/Makefile
+++ b/security/xca/Makefile
@@ -14,11 +14,10 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= mark@foster.cc
COMMENT= Graphical certification authority
-BROKEN= Does not compile
-
USE_GMAKE= yes
USE_OPENSSL= yes
USE_QT_VER= 4
+QT_COMPONENTS= gui moc uic qmake rcc linguist
CC?= gcc
CXX?= g++
@@ -28,7 +27,7 @@ MANCOMPRESSED= yes
.include <bsd.port.pre.mk>
post-patch:
- @echo "CPPFLAGS=-I. -I.. -I${WRKSRC}/ui -I/usr/X11R6/include -I${QT_PREFIX}/include/Qt" > ${WRKSRC}/Local.mak
+ @echo "CPPFLAGS=-I. -I.. -I${WRKSRC}/ui -I${LOCALBASE}/include -I${QT_PREFIX}/include/Qt" > ${WRKSRC}/Local.mak
@echo "CFLAGS= ${CFLAGS} -Wall -ggdb" >> ${WRKSRC}/Local.mak
@echo "LDFLAGS= ${LDFLAGS} -L${LOCALBASE}/lib" >> ${WRKSRC}/Local.mak
@echo "LIBS= -lQtGui -lc_r -lcrypto" >> ${WRKSRC}/Local.mak