aboutsummaryrefslogtreecommitdiff
path: root/security/xmlsec1
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-02-12 13:52:15 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-02-12 13:52:15 +0000
commit0d5e8b9b3947f702d264bbc721db89901c3c1660 (patch)
tree61645fea6da404c677f024348e6f9449e6447c89 /security/xmlsec1
parent7511636551a90700c1c43e7cd3df150bb8389e6a (diff)
downloadports-0d5e8b9b3947f702d264bbc721db89901c3c1660.tar.gz
ports-0d5e8b9b3947f702d264bbc721db89901c3c1660.zip
Notes
Diffstat (limited to 'security/xmlsec1')
-rw-r--r--security/xmlsec1/Makefile23
-rw-r--r--security/xmlsec1/distinfo2
-rw-r--r--security/xmlsec1/files/patch-configure10
-rw-r--r--security/xmlsec1/pkg-plist186
4 files changed, 18 insertions, 203 deletions
diff --git a/security/xmlsec1/Makefile b/security/xmlsec1/Makefile
index ddbda28c08e5..91b073c3a999 100644
--- a/security/xmlsec1/Makefile
+++ b/security/xmlsec1/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= xmlsec1
-PORTVERSION= 1.0.1
-PORTREVISION= 2
+PORTVERSION= 1.2.4
+PORTREVISION= 0
CATEGORIES= security
MASTER_SITES= http://www.aleksey.com/xmlsec/download/ \
ftp://ftp.aleksey.com/pub/xmlsec/releases/ \
@@ -21,21 +21,19 @@ RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
BUILD_DEPENDS= ${RUN_DEPENDS}
USE_OPENSSL= yes
-USE_GNOME= gnomehack libxslt
+USE_GNOME= gnomehack lthack libxslt gnometarget
USE_REINPLACE= yes
USE_LIBTOOL= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
INSTALLS_SHLIB= yes
+PLIST_FILES= bin/xmlsec1 bin/xmlsec1-config etc/xmlsec1Conf.sh
MAN1= xmlsec1.1 xmlsec1-config.1
.if defined(WITH_GNUTLS)
CONFIGURE_ARGS+= --with-gnutls="${LOCALBASE}"
LIB_DEPENDS+= gnutls.7:${PORTSDIR}/security/gnutls
-PLIST_SUB+= GNUTLS=""
.else
CONFIGURE_ARGS+= --without-gnutls
-PLIST_SUB+= GNUTLS="@comment "
.endif
.if !defined(NOPORTDOCS)
@@ -54,4 +52,17 @@ post-patch:
s|^confexecdir =.*$$|confexecdir = \$$(sysconfdir)|g' \
${WRKSRC}/Makefile.in
+post-install:
+ @${FIND} ${PREFIX}/include/xmlsec1 -type f | \
+ ${SED} 's,${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/include/xmlsec1 -type d | ${SORT} -r | \
+ ${SED} 's,${PREFIX}/,, ; s,^,@dirrm ,' >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/lib/libxmlsec1* | \
+ ${SED} 's,${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/libdata/pkgconfig/xmlsec1* | \
+ ${SED} 's,${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${DOCSDIR} -type f | ${SED} 's,${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${DOCSDIR} -type d | ${SORT} -r | \
+ ${SED} 's,${PREFIX}/,, ; s,^,@dirrm ,' >> ${TMPPLIST}
+
.include <bsd.port.mk>
diff --git a/security/xmlsec1/distinfo b/security/xmlsec1/distinfo
index 4cb88c8411f8..2022e4ff713f 100644
--- a/security/xmlsec1/distinfo
+++ b/security/xmlsec1/distinfo
@@ -1 +1 @@
-MD5 (xmlsec1-1.0.1.tar.gz) = b331b3e0a3f85552716d5286db2cd73c
+MD5 (xmlsec1-1.2.4.tar.gz) = 1d6ef139d74434da78051de610e7a4f3
diff --git a/security/xmlsec1/files/patch-configure b/security/xmlsec1/files/patch-configure
deleted file mode 100644
index 948c41138b67..000000000000
--- a/security/xmlsec1/files/patch-configure
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.orig Tue Apr 29 13:32:15 2003
-+++ configure Tue May 13 05:20:21 2003
-@@ -7873,6 +7873,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/security/xmlsec1/pkg-plist b/security/xmlsec1/pkg-plist
deleted file mode 100644
index 0f8d5c813396..000000000000
--- a/security/xmlsec1/pkg-plist
+++ /dev/null
@@ -1,186 +0,0 @@
-bin/xmlsec1
-bin/xmlsec1-config
-etc/xmlsec1Conf.sh
-include/xmlsec1/xmlsec/base64.h
-include/xmlsec1/xmlsec/buffer.h
-include/xmlsec1/xmlsec/crypto.h
-include/xmlsec1/xmlsec/errors.h
-include/xmlsec1/xmlsec/exports.h
-%%GNUTLS%%include/xmlsec1/xmlsec/gnutls/app.h
-%%GNUTLS%%include/xmlsec1/xmlsec/gnutls/crypto.h
-%%GNUTLS%%include/xmlsec1/xmlsec/gnutls/symbols.h
-include/xmlsec1/xmlsec/io.h
-include/xmlsec1/xmlsec/keyinfo.h
-include/xmlsec1/xmlsec/keys.h
-include/xmlsec1/xmlsec/keysdata.h
-include/xmlsec1/xmlsec/keysmngr.h
-include/xmlsec1/xmlsec/list.h
-include/xmlsec1/xmlsec/membuf.h
-include/xmlsec1/xmlsec/nodeset.h
-include/xmlsec1/xmlsec/openssl/app.h
-include/xmlsec1/xmlsec/openssl/bn.h
-include/xmlsec1/xmlsec/openssl/crypto.h
-include/xmlsec1/xmlsec/openssl/evp.h
-include/xmlsec1/xmlsec/openssl/symbols.h
-include/xmlsec1/xmlsec/openssl/x509.h
-include/xmlsec1/xmlsec/parser.h
-include/xmlsec1/xmlsec/strings.h
-include/xmlsec1/xmlsec/templates.h
-include/xmlsec1/xmlsec/transforms.h
-include/xmlsec1/xmlsec/version.h
-include/xmlsec1/xmlsec/xmldsig.h
-include/xmlsec1/xmlsec/xmlenc.h
-include/xmlsec1/xmlsec/xmlsec.h
-include/xmlsec1/xmlsec/xmltree.h
-%%GNUTLS%%lib/libxmlsec1-gnutls.a
-%%GNUTLS%%lib/libxmlsec1-gnutls.so
-%%GNUTLS%%lib/libxmlsec1-gnutls.so.1
-lib/libxmlsec1-openssl.a
-lib/libxmlsec1-openssl.so
-lib/libxmlsec1-openssl.so.1
-lib/libxmlsec1.a
-lib/libxmlsec1.so
-lib/libxmlsec1.so.1
-libdata/pkgconfig/xmlsec1.pc
-%%PORTDOCS%%share/doc/xmlsec1/api/chapters/compiling-and-linking.sgml
-%%PORTDOCS%%share/doc/xmlsec1/api/chapters/creating-templates.sgml
-%%PORTDOCS%%share/doc/xmlsec1/api/chapters/examples.sgml
-%%PORTDOCS%%share/doc/xmlsec1/api/chapters/init-and-shutdown.sgml
-%%PORTDOCS%%share/doc/xmlsec1/api/chapters/new-crypto.sgml
-%%PORTDOCS%%share/doc/xmlsec1/api/chapters/sign-and-encrypt.sgml
-%%PORTDOCS%%share/doc/xmlsec1/api/chapters/using-contexts.sgml
-%%PORTDOCS%%share/doc/xmlsec1/api/chapters/using-keys.sgml
-%%PORTDOCS%%share/doc/xmlsec1/api/chapters/using-keysmngr.sgml
-%%PORTDOCS%%share/doc/xmlsec1/api/chapters/using-transforms.sgml
-%%PORTDOCS%%share/doc/xmlsec1/api/chapters/using-x509-certs.sgml
-%%PORTDOCS%%share/doc/xmlsec1/api/chapters/verify-and-decrypt.sgml
-%%PORTDOCS%%share/doc/xmlsec1/api/images/encryption-structure.png
-%%PORTDOCS%%share/doc/xmlsec1/api/images/key.png
-%%PORTDOCS%%share/doc/xmlsec1/api/images/keysmngr.png
-%%PORTDOCS%%share/doc/xmlsec1/api/images/sign-enc-model.png
-%%PORTDOCS%%share/doc/xmlsec1/api/images/signature-structure.png
-%%PORTDOCS%%share/doc/xmlsec1/api/images/structure.png
-%%PORTDOCS%%share/doc/xmlsec1/api/images/transform.png
-%%PORTDOCS%%share/doc/xmlsec1/api/images/transforms-chain.png
-%%PORTDOCS%%share/doc/xmlsec1/api/images/verif-dec-model.png
-%%PORTDOCS%%share/doc/xmlsec1/api/index.html
-%%PORTDOCS%%share/doc/xmlsec1/api/index.sgml
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-base64.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-buffer.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-custom-keys-manager.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-decrypt-with-keys-mngr.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-decrypt-with-signle-key.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-encrypt-dynamic-template.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-encrypt-template-file.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-encrypt-with-session-key.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-encryption-klasses.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-errors.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-examples-sign-dynamimc-template.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-examples-sign-template-file.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-examples-sign-x509.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-examples.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-gnutls-app.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-gnutls-crypto.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-gnutls-ref.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-gnutls.sgml
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-index.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-index.sgml
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-io.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-keyinfo.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-keys.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-keysdata.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-keysmngr.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-list.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-membuf.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-nodeset.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-notes-compiling-others.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-notes-compiling-unix.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-notes-compiling-windows.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-notes-compiling.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-notes-contexts.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-notes-custom-keys-store.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-notes-decrypt.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-notes-dynamic-encryption-templates.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-notes-dynamic-signature-templates.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-notes-encrypt.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-notes-include-files.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-notes-init-shutdown.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-notes-keys-manager-sign-enc.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-notes-keys-mngr-verify-decrypt.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-notes-keys.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-notes-keysmngr.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-notes-new-crypto-functions.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-notes-new-crypto-key-stores.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-notes-new-crypto-keys.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-notes-new-crypto-klasses.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-notes-new-crypto-sharing-results.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-notes-new-crypto-simple-keys-mngr.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-notes-new-crypto-skeleton.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-notes-new-crypto-transforms.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-notes-new-crypto.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-notes-overview.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-notes-sign-encrypt.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-notes-sign-x509.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-notes-sign.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-notes-simple-keys-store.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-notes-structure.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-notes-templates.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-notes-transforms.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-notes-verify-decrypt.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-notes-verify-x509.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-notes-verify.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-notes-x509.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-notes.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-nss-app.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-nss-crypto.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-nss-ref.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-nss.sgml
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-openssl-app.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-openssl-bn.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-openssl-crypto.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-openssl-ref.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-openssl-x509.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-openssl.sgml
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-parser.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-ref.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-reference.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-signature-klasses.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-templates.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-transforms.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-verify-with-key.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-verify-with-keys-mngr.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-verify-with-restrictions.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-verify-with-x509.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-version.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-xmldsig.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-xmlenc.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-xmlsec.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec-xmltree.html
-%%PORTDOCS%%share/doc/xmlsec1/api/xmlsec.sgml
-%%PORTDOCS%%share/doc/xmlsec1/bugs.html
-%%PORTDOCS%%share/doc/xmlsec1/c14n.html
-%%PORTDOCS%%share/doc/xmlsec1/documentation.html
-%%PORTDOCS%%share/doc/xmlsec1/download.html
-%%PORTDOCS%%share/doc/xmlsec1/faq.html
-%%PORTDOCS%%share/doc/xmlsec1/images/bart.gif
-%%PORTDOCS%%share/doc/xmlsec1/images/libxml2-logo.png
-%%PORTDOCS%%share/doc/xmlsec1/images/libxslt-logo.png
-%%PORTDOCS%%share/doc/xmlsec1/images/logo.gif
-%%PORTDOCS%%share/doc/xmlsec1/images/openssl-logo.png
-%%PORTDOCS%%share/doc/xmlsec1/images/xmlsec-logo.gif
-%%PORTDOCS%%share/doc/xmlsec1/index.html
-%%PORTDOCS%%share/doc/xmlsec1/news.html
-%%PORTDOCS%%share/doc/xmlsec1/related.html
-%%PORTDOCS%%share/doc/xmlsec1/xmldsig-verifier.html
-%%PORTDOCS%%share/doc/xmlsec1/xmldsig.html
-%%PORTDOCS%%share/doc/xmlsec1/xmlenc.html
-%%PORTDOCS%%share/doc/xmlsec1/xmlsec-man.html
-%%PORTDOCS%%@dirrm share/doc/xmlsec1/images
-%%PORTDOCS%%@dirrm share/doc/xmlsec1/api/images
-%%PORTDOCS%%@dirrm share/doc/xmlsec1/api/chapters
-%%PORTDOCS%%@dirrm share/doc/xmlsec1/api
-%%PORTDOCS%%@dirrm share/doc/xmlsec1
-@dirrm include/xmlsec1/xmlsec/openssl
-%%GNUTLS%%@dirrm include/xmlsec1/xmlsec/gnutls
-@dirrm include/xmlsec1/xmlsec
-@dirrm include/xmlsec1