aboutsummaryrefslogtreecommitdiff
path: root/security/xmlsec1
diff options
context:
space:
mode:
authorMichael Gmelin <grembo@FreeBSD.org>2017-01-16 14:24:34 +0000
committerMichael Gmelin <grembo@FreeBSD.org>2017-01-16 14:24:34 +0000
commit10ad85aeefe3109eb2d1bc4c97468cd3fe49d178 (patch)
tree976a28e2f0f605f0740bad4366710604abd8564b /security/xmlsec1
parent8798967c016e3cc694dc850feafdb3700e9139ec (diff)
downloadports-10ad85aeefe3109eb2d1bc4c97468cd3fe49d178.tar.gz
ports-10ad85aeefe3109eb2d1bc4c97468cd3fe49d178.zip
Fix build with LibreSSL
Even though building worked ok, linking to the resulting library libxmlsec1-openssl.so caused various symbol lookup errors such as: /usr/local/lib/libxmlsec1-openssl.so: undefined reference to `X509_OBJECT_get0_X509' /usr/local/lib/libxmlsec1-openssl.so: undefined reference to `ASN1_STRING_get0_data' As the problem only appears at runtime I bumped the revision. Approved by: ssl blanket
Notes
Notes: svn path=/head/; revision=431649
Diffstat (limited to 'security/xmlsec1')
-rw-r--r--security/xmlsec1/Makefile1
-rw-r--r--security/xmlsec1/files/patch-src-openssl-openssl11_wrapper.h11
2 files changed, 12 insertions, 0 deletions
diff --git a/security/xmlsec1/Makefile b/security/xmlsec1/Makefile
index c758c3315b0f..b4806d182efe 100644
--- a/security/xmlsec1/Makefile
+++ b/security/xmlsec1/Makefile
@@ -3,6 +3,7 @@
PORTNAME= xmlsec1
PORTVERSION= 1.2.23
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://www.aleksey.com/xmlsec/download/ \
ftp://ftp.aleksey.com/pub/xmlsec/releases/ \
diff --git a/security/xmlsec1/files/patch-src-openssl-openssl11_wrapper.h b/security/xmlsec1/files/patch-src-openssl-openssl11_wrapper.h
new file mode 100644
index 000000000000..d0c2d9cfb503
--- /dev/null
+++ b/security/xmlsec1/files/patch-src-openssl-openssl11_wrapper.h
@@ -0,0 +1,11 @@
+--- src/openssl/openssl11_wrapper.h.orig 2016-10-16 22:48:17.000000000 +0000
++++ src/openssl/openssl11_wrapper.h 2017-01-16 14:02:41.553210002 +0000
+@@ -9,7 +9,7 @@
+ * same syntax. This file won't be required once OpenSSL 1.1.0 is the minimum
+ * suported version.
+ */
+-#if (OPENSSL_VERSION_NUMBER < 0x10100000)
++#if (OPENSSL_VERSION_NUMBER < 0x10100000 || defined(LIBRESSL_VERSION_NUMBER))
+
+ #define EVP_PKEY_up_ref(pKey) CRYPTO_add(&((pKey)->references), 1, CRYPTO_LOCK_EVP_PKEY)
+