aboutsummaryrefslogtreecommitdiff
path: root/security/xmlsec1
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2018-02-08 07:07:43 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2018-02-08 07:07:43 +0000
commitff60ec0369d961330317ac658680cd2234abda9d (patch)
tree5c9b9126e960bd756a0c7d75e8502939eb9a3189 /security/xmlsec1
parent80769f5857e37f34d9cacdc719397e37f4755605 (diff)
downloadports-ff60ec0369d961330317ac658680cd2234abda9d.tar.gz
ports-ff60ec0369d961330317ac658680cd2234abda9d.zip
- Update to 1.2.25
PR: 224282 Submitted by: Greg V <greg@unrelenting.technology> Approved by: maintainer timeout
Notes
Notes: svn path=/head/; revision=461199
Diffstat (limited to 'security/xmlsec1')
-rw-r--r--security/xmlsec1/Makefile30
-rw-r--r--security/xmlsec1/distinfo6
-rw-r--r--security/xmlsec1/files/patch-Makefile.in13
-rw-r--r--security/xmlsec1/files/patch-src-openssl-app.c20
-rw-r--r--security/xmlsec1/files/patch-src-openssl-openssl11_wrapper.h11
-rw-r--r--security/xmlsec1/files/patch-src_openssl_signatures.c10
-rw-r--r--security/xmlsec1/pkg-plist10
7 files changed, 28 insertions, 72 deletions
diff --git a/security/xmlsec1/Makefile b/security/xmlsec1/Makefile
index dc6cf7bb2ed3..ca240a3a40ec 100644
--- a/security/xmlsec1/Makefile
+++ b/security/xmlsec1/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= xmlsec1
-PORTVERSION= 1.2.23
-PORTREVISION= 1
+PORTVERSION= 1.2.25
CATEGORIES= security
MASTER_SITES= http://www.aleksey.com/xmlsec/download/ \
ftp://ftp.aleksey.com/pub/xmlsec/releases/ \
@@ -20,26 +19,22 @@ LIB_DEPENDS= libgcrypt.so:security/libgcrypt \
libgpg-error.so:security/libgpg-error \
libltdl.so:devel/libltdl
-USES= libtool localbase pathfix pkgconfig ssl
+USES= libtool localbase pathfix pkgconfig ssl gmake
USE_GNOME= libxml2 libxslt
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-openssl="${OPENSSLBASE}" \
- --with-gcrypt="${LOCALBASE}"
+ --with-gcrypt="${LOCALBASE}" \
+ --enable-soap \
+ --disable-docs-build
MAKE_ENV= ABS_BUILDDIR=${WRKSRC} TMPFOLDER=${WRKSRC}
INSTALL_TARGET= install-strip
-PORTDOCS= api authors.html bugs.html c14n.html documentation.html \
- download.html faq.html favicon.ico images/bart.gif \
- images/libxml2-logo.png images/libxslt-logo.png \
- images/logo.gif images/openssl-logo.png \
- images/xmlsec-logo.gif index.html news.html related.html \
- xmldsig-verifier.html xmldsig.html xmlenc.html \
- xmlsec-man.html
+PORTDOCS= *
-OPTIONS_DEFINE= DOCS GNUTLS NSS
+OPTIONS_DEFINE= GNUTLS NSS
+OPTIONS_DEFAULT= NSS
OPTIONS_SUB= yes
-DOCS_MAKE_ENV= DOCS=docs
GNUTLS_DESC= Enable GNUTLS support
GNUTLS_CONFIGURE_ON= --with-gnutls="${LOCALBASE}"
GNUTLS_CONFIGURE_OFF= --without-gnutls
@@ -54,6 +49,15 @@ NSS_LIB_DEPENDS= libnss3.so:security/nss \
libplds4.so:devel/nspr \
libplc4.so:devel/nspr
+post-patch:
+ @${REINPLACE_CMD} -e 's/mozilla-nss/nss/' \
+ -e 's/mozilla-nspr/nspr/' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's/(CP) -ru/(CP) -r/' \
+ -e 's/(CP) -u/(CP)/' \
+ ${WRKSRC}/docs/Makefile.am ${WRKSRC}/docs/Makefile.in \
+ ${WRKSRC}/docs/api/Makefile.am ${WRKSRC}/docs/api/Makefile.in \
+ ${WRKSRC}/man/Makefile.am ${WRKSRC}/man/Makefile.in
+
post-patch-GNUTLS-on:
# Don't rely on broken autodetection
@${REINPLACE_CMD} -e '/^GNUTLS_FOUND/s/no/yes/' \
diff --git a/security/xmlsec1/distinfo b/security/xmlsec1/distinfo
index 432b875f7f88..171164c90d16 100644
--- a/security/xmlsec1/distinfo
+++ b/security/xmlsec1/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1483094320
-SHA256 (xmlsec1-1.2.23.tar.gz) = 41d463d16c9894cd3317098d027c038039c6d896b9cbb9bad9c4e29959e10e9f
-SIZE (xmlsec1-1.2.23.tar.gz) = 1794694
+TIMESTAMP = 1513083917
+SHA256 (xmlsec1-1.2.25.tar.gz) = 967ca83edf25ccb5b48a3c4a09ad3405a63365576503bf34290a42de1b92fcd2
+SIZE (xmlsec1-1.2.25.tar.gz) = 1839160
diff --git a/security/xmlsec1/files/patch-Makefile.in b/security/xmlsec1/files/patch-Makefile.in
index 746f880e0720..40393dc3aeb4 100644
--- a/security/xmlsec1/files/patch-Makefile.in
+++ b/security/xmlsec1/files/patch-Makefile.in
@@ -1,13 +1,6 @@
---- Makefile.in.orig 2017-01-05 17:38:02.402682000 +0900
-+++ Makefile.in 2017-01-05 17:39:12.079701000 +0900
-@@ -468,13 +468,13 @@
- top_srcdir = @top_srcdir@
- NULL =
- SAFE_VERSION = @XMLSEC_VERSION_SAFE@
--SUBDIRS = include src apps man docs
-+SUBDIRS = include src apps man ${DOCS}
- TEST_APP = apps/xmlsec1$(EXEEXT)
- DEFAULT_CRYPTO = @XMLSEC_DEFAULT_CRYPTO@
+--- Makefile.in.orig 2017-12-12 16:05:23.187628000 +0300
++++ Makefile.in 2017-12-12 16:07:19.241092000 +0300
+@@ -480,7 +480,7 @@
bin_SCRIPTS = xmlsec1-config
pkgconfig_DATA = xmlsec1.pc @XMLSEC_CRYPTO_PC_FILES_LIST@
pkgconfigdir = $(prefix)/libdata/pkgconfig
diff --git a/security/xmlsec1/files/patch-src-openssl-app.c b/security/xmlsec1/files/patch-src-openssl-app.c
deleted file mode 100644
index e60470446e93..000000000000
--- a/security/xmlsec1/files/patch-src-openssl-app.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/openssl/app.c.orig 2017-01-05 18:07:26.936917000 +0900
-+++ src/openssl/app.c 2017-01-05 18:08:34.388575000 +0900
-@@ -61,7 +61,7 @@
- int
- xmlSecOpenSSLAppInit(const char* config) {
-
--#if (OPENSSL_VERSION_NUMBER < 0x10100000)
-+#if !defined(XMLSEC_OPENSSL_110)
- ERR_load_crypto_strings();
- OPENSSL_config(NULL);
- OpenSSL_add_all_algorithms();
-@@ -119,7 +119,7 @@
- xmlSecOpenSSLAppShutdown(void) {
- xmlSecOpenSSLAppSaveRANDFile(NULL);
-
--#if (OPENSSL_VERSION_NUMBER < 0x10100000)
-+#if !defined(XMLSEC_OPENSSL_110)
- RAND_cleanup();
- EVP_cleanup();
-
diff --git a/security/xmlsec1/files/patch-src-openssl-openssl11_wrapper.h b/security/xmlsec1/files/patch-src-openssl-openssl11_wrapper.h
deleted file mode 100644
index d0c2d9cfb503..000000000000
--- a/security/xmlsec1/files/patch-src-openssl-openssl11_wrapper.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/openssl/openssl11_wrapper.h.orig 2016-10-16 22:48:17.000000000 +0000
-+++ src/openssl/openssl11_wrapper.h 2017-01-16 14:02:41.553210002 +0000
-@@ -9,7 +9,7 @@
- * same syntax. This file won't be required once OpenSSL 1.1.0 is the minimum
- * suported version.
- */
--#if (OPENSSL_VERSION_NUMBER < 0x10100000)
-+#if (OPENSSL_VERSION_NUMBER < 0x10100000 || defined(LIBRESSL_VERSION_NUMBER))
-
- #define EVP_PKEY_up_ref(pKey) CRYPTO_add(&((pKey)->references), 1, CRYPTO_LOCK_EVP_PKEY)
-
diff --git a/security/xmlsec1/files/patch-src_openssl_signatures.c b/security/xmlsec1/files/patch-src_openssl_signatures.c
deleted file mode 100644
index 6b79e95fd58f..000000000000
--- a/security/xmlsec1/files/patch-src_openssl_signatures.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/openssl/signatures.c.orig 2016-04-20 16:26:22 UTC
-+++ src/openssl/signatures.c
-@@ -10,6 +10,7 @@
-
- #include <string.h>
-
-+#include <openssl/ecdsa.h> // ECDSA_SIG
- #include <openssl/evp.h>
- #include <openssl/rand.h>
- #include <openssl/sha.h>
diff --git a/security/xmlsec1/pkg-plist b/security/xmlsec1/pkg-plist
index d105159dd4cb..df3b95b9cb46 100644
--- a/security/xmlsec1/pkg-plist
+++ b/security/xmlsec1/pkg-plist
@@ -56,20 +56,20 @@ lib/libxmlsec1-gcrypt.so.1
%%GNUTLS%%lib/libxmlsec1-gnutls.a
%%GNUTLS%%lib/libxmlsec1-gnutls.so
%%GNUTLS%%lib/libxmlsec1-gnutls.so.1
-%%GNUTLS%%lib/libxmlsec1-gnutls.so.1.2.23
+%%GNUTLS%%lib/libxmlsec1-gnutls.so.1.2.25
%%NSS%%lib/libxmlsec1-nss.a
%%NSS%%lib/libxmlsec1-nss.so
%%NSS%%lib/libxmlsec1-nss.so.1
-%%NSS%%lib/libxmlsec1-nss.so.1.2.23
-lib/libxmlsec1-gcrypt.so.1.2.23
+%%NSS%%lib/libxmlsec1-nss.so.1.2.25
+lib/libxmlsec1-gcrypt.so.1.2.25
lib/libxmlsec1-openssl.a
lib/libxmlsec1-openssl.so
lib/libxmlsec1-openssl.so.1
-lib/libxmlsec1-openssl.so.1.2.23
+lib/libxmlsec1-openssl.so.1.2.25
lib/libxmlsec1.a
lib/libxmlsec1.so
lib/libxmlsec1.so.1
-lib/libxmlsec1.so.1.2.23
+lib/libxmlsec1.so.1.2.25
libdata/pkgconfig/xmlsec1-gcrypt.pc
%%GNUTLS%%libdata/pkgconfig/xmlsec1-gnutls.pc
%%NSS%%libdata/pkgconfig/xmlsec1-nss.pc