aboutsummaryrefslogtreecommitdiff
path: root/security/yapet/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-05-17 13:01:46 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-05-17 13:01:46 +0000
commit3a00a8ffdf9aa53b67aa9a81cb97b11d90e09134 (patch)
treefb780d69f984633d63a21296fe46b624ffaef7c6 /security/yapet/Makefile
parent1fb0bacb5a2c07dbf47904d0613cbeb2970c2690 (diff)
downloadports-3a00a8ffdf9aa53b67aa9a81cb97b11d90e09134.tar.gz
ports-3a00a8ffdf9aa53b67aa9a81cb97b11d90e09134.zip
Notes
Diffstat (limited to 'security/yapet/Makefile')
-rw-r--r--security/yapet/Makefile32
1 files changed, 23 insertions, 9 deletions
diff --git a/security/yapet/Makefile b/security/yapet/Makefile
index f5d98787df34..650ce75f7e9e 100644
--- a/security/yapet/Makefile
+++ b/security/yapet/Makefile
@@ -6,14 +6,9 @@
#
PORTNAME= yapet
-PORTVERSION= 0.2
-PORTREVISION= 1
+PORTVERSION= 0.3
CATEGORIES= security
-MASTER_SITES= http://www.guengel.ch/myapps/yapet/downloads/
-
-PATCH_SITES= http://www.guengel.ch/myapps/yapet/downloads/patches/
-PATCHFILES= yapet_gcc43-0.2.diff yapet_crs_bs-0.2.diff
-PATCH_DIST_STRIP=-p1
+MASTER_SITES= http://www.guengel.ch/myapps/yapet/downloads/ http://homepage.hispeed.ch/rostertag/yapet/
MAINTAINER= rafi@guengel.ch
COMMENT= A curses based password manager
@@ -21,8 +16,27 @@ COMMENT= A curses based password manager
MAN1= yapet.1
MANCOMPRESSED= no
+USE_OPENSSL= yes
GNU_CONFIGURE= yes
-USE_OPENSSL= yes
+OPTIONS= TTITLE "Enable Terminal Title" ON
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_TTITLE)
+CONFIGURE_ARGS+= --enable-terminal-title
+.endif
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+PLIST_SUB+= NLS=""
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>