aboutsummaryrefslogtreecommitdiff
path: root/security/yapet/Makefile
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2014-03-09 14:37:40 +0000
committerJason E. Hale <jhale@FreeBSD.org>2014-03-09 14:37:40 +0000
commit3ddc6b69d45ea83fbd43dbc0820532dff8a4f1a1 (patch)
tree4ec79c559a413960212e22a46f6cd41f21d58cfb /security/yapet/Makefile
parent8a488b68a28158e4ed8f7122e6c5fbcc546eabfd (diff)
downloadports-3ddc6b69d45ea83fbd43dbc0820532dff8a4f1a1.tar.gz
ports-3ddc6b69d45ea83fbd43dbc0820532dff8a4f1a1.zip
Notes
Diffstat (limited to 'security/yapet/Makefile')
-rw-r--r--security/yapet/Makefile78
1 files changed, 14 insertions, 64 deletions
diff --git a/security/yapet/Makefile b/security/yapet/Makefile
index a6d2d0b3fb94..a4c1f2615d53 100644
--- a/security/yapet/Makefile
+++ b/security/yapet/Makefile
@@ -1,81 +1,31 @@
-# Created by: Rafael Ostertag <rafi@guengel.ch>
# $FreeBSD$
PORTNAME= yapet
-PORTVERSION= 0.7
+PORTVERSION= 1.0
CATEGORIES= security
-MASTER_SITES= http://www.guengel.ch/myapps/yapet/downloads/ http://homepage.hispeed.ch/rostertag/yapet/
+MASTER_SITES= http://www.guengel.ch/myapps/yapet/downloads/
MAINTAINER= rafi@guengel.ch
COMMENT= Curses based password manager
-MAN1= yapet.1
-MANCOMPRESSED= no
+LICENSE= GPLv3
+USES= gmake
USE_OPENSSL= yes
GNU_CONFIGURE= yes
-OPTIONS_DEFINE= TTITLE PWGEN CSV2YAPET DOCS
-OPTIONS_DEFAULT= TTITLE PWGEN CSV2YAPET
-TTITLE_DESC= Enable Terminal Title
-PWGEN_DESC= Enable Password Generator
-CSV2YAPET_DESC= Build csv2yapet
+CONFIGURE_ARGS= --enable-silent-rules
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= CONVERTERS DOCS NLS
+OPTIONS_DEFAULT= CONVERTERS
+OPTIONS_SUB= yes
-# --enable-silent-rules: will make the build quiet
-# --disable-install-doc: I take care of installing docs
-CONFIGURE_ARGS+= --enable-silent-rules --disable-install-doc
+CONVERTERS_DESC= Utilities for importing/exporting CSV files
+CONVERTERS_CONFIGURE_ENABLE= converters
-.if ${PORT_OPTIONS:MTTITLE}
-CONFIGURE_ARGS+= --enable-terminal-title
-.else
-CONFIGURE_ARGS+= --disable-terminal-title
-.endif
-
-.if ${PORT_OPTIONS:MPWGEN}
-CONFIGURE_ARGS+= --enable-pwgen
-.else
-CONFIGURE_ARGS+= --disable-pwgen
-.endif
-
-.if ${PORT_OPTIONS:MCSV2YAPET}
-CONFIGURE_ARGS+= --enable-csv2yapet
-MAN1+= csv2yapet.1
-PLIST_SUB+= CSV2YAPET=""
-.else
-CONFIGURE_ARGS+= --disable-csv2yapet
-PLIST_SUB+= CSV2YAPET="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-CONFIGURE_ARGS+= --enable-nls
-PLIST_SUB+= NLS=""
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-.else
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MDOCS}
-PLIST_SUB+= NOPORTDOCS=""
-.else
-PLIST_SUB+= NOPORTDOCS="@comment "
-.endif
-
-# Taking care of installing docs due to --disable-install-doc
-# configure switch.
-post-install:
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/AUTHORS ${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/DESIGN ${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/LICENSE ${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/THANKS ${DOCSDIR}
-.endif
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
+NLS_CPPFLAGS= -I${LOCALBASE}/include
+NLS_LDFLAGS= -L${LOCALBASE}/lib
.include <bsd.port.mk>