aboutsummaryrefslogtreecommitdiff
path: root/security/yassl/Makefile
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2013-04-29 22:30:01 +0000
committerJohan van Selst <johans@FreeBSD.org>2013-04-29 22:30:01 +0000
commit341aabf49fccb8893b7c28e903b69fd73093d650 (patch)
treed0ed592c9b368a0d58c7407ac38acf50fe7465d6 /security/yassl/Makefile
parent9ff06b3cbf038359059e40e0db31ba0cbe996d0f (diff)
downloadports-341aabf49fccb8893b7c28e903b69fd73093d650.tar.gz
ports-341aabf49fccb8893b7c28e903b69fd73093d650.zip
Notes
Diffstat (limited to 'security/yassl/Makefile')
-rw-r--r--security/yassl/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/security/yassl/Makefile b/security/yassl/Makefile
index 86052b75d967..05bc7600f92e 100644
--- a/security/yassl/Makefile
+++ b/security/yassl/Makefile
@@ -1,12 +1,12 @@
# $FreeBSD$
PORTNAME= cyassl
-PORTVERSION= 2.5.0
+PORTVERSION= 2.6.0
CATEGORIES= security devel
MASTER_SITES= http://www.yassl.com/
MAINTAINER= johans@FreeBSD.org
-COMMENT= A embedded SSL C-Library
+COMMENT= Embedded SSL C-Library
LICENSE= GPLv2
@@ -15,14 +15,18 @@ USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-dependency-tracking \
--enable-shared --enable-static \
- --enable-dtls --enable-opensslExtra --enable-ipv6
+ --enable-dtls --enable-opensslextra --enable-ipv6 \
+ --enable-dsa --enable-ecc
USE_LDCONFIG= yes
PORTDOCS= *
post-configure:
- ${REINPLACE_CMD} \
+ @${REINPLACE_CMD} \
-e 's|$${prefix}/cyassl/include|$${prefix}/include/cyassl|' \
-e 's|$${prefix}/cyassl/lib|$${prefix}/lib/cyassl|' \
${WRKSRC}/Makefile
+ # i386 assembly is broken: do not use
+ @${REINPLACE_CMD} -e 's/(TFM_X86)/(TFM_X86_BROKEN)/' \
+ ${WRKSRC}/ctaocrypt/src/asm.c
.include <bsd.port.mk>