aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2019-04-15 06:02:46 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2019-04-15 06:02:46 +0000
commit02c15c525fd70c23ef6d7b782be69ad11f8d0bdc (patch)
tree402f898c760ccbc4d9aac3817597ccbd6c2c785f /security
parent2f2a2d286084edc8fd707c5297a6d6edebb98f4c (diff)
downloadports-02c15c525fd70c23ef6d7b782be69ad11f8d0bdc.tar.gz
ports-02c15c525fd70c23ef6d7b782be69ad11f8d0bdc.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/py-pywinrm/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/security/py-pywinrm/Makefile b/security/py-pywinrm/Makefile
index 01e1fd8b0695..c2ba77204391 100644
--- a/security/py-pywinrm/Makefile
+++ b/security/py-pywinrm/Makefile
@@ -2,6 +2,7 @@
PORTNAME= pywinrm
PORTVERSION= 0.3.0
+PORTREVISION= 1
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -18,8 +19,16 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}xmltodict>0:devel/py-xmltodict@${PY_FLAVOR}
${PYTHON_PKGNAMEPREFIX}requests-kerberos>=0.10.0:security/py-requests-kerberos@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests-credssp>=0.0.1:security/py-requests-credssp@${PY_FLAVOR}
-NO_ARCH= yes
-USES= python:2.7
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock@${PY_FLAVOR}
+
+# Actually 2.6-2.7,3.3-3.6
+USES= python
USE_PYTHON= autoplist distutils
+NO_ARCH= yes
+
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} -m pytest -v winrm/tests/
+
.include <bsd.port.mk>