aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-04-05 23:59:58 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-04-05 23:59:58 +0000
commit0368b764f2c45250550f062f9e5218d63072c06f (patch)
tree5e3e9df7acc6be3b1a274d9bec7070acd6f09f48 /security
parent2e91f09072ae8696c34318862988695b8c2e2027 (diff)
downloadports-0368b764f2c45250550f062f9e5218d63072c06f.tar.gz
ports-0368b764f2c45250550f062f9e5218d63072c06f.zip
Diffstat (limited to 'security')
-rw-r--r--security/py-certbot-nginx/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/security/py-certbot-nginx/Makefile b/security/py-certbot-nginx/Makefile
index 4c2979edf354..5cabe11da131 100644
--- a/security/py-certbot-nginx/Makefile
+++ b/security/py-certbot-nginx/Makefile
@@ -1,5 +1,6 @@
PORTNAME= certbot-nginx
PORTVERSION= ${ACME_VERSION}
+PORTREVISION= 1
CATEGORIES= security python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,6 +14,8 @@ WWW= https://certbot.eff.org/ \
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}acme>=${ACME_VERSION},1:security/py-acme@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}certbot>=${ACME_VERSION},1:security/py-certbot@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}openssl>=17.5.0,1:security/py-openssl@${PY_FLAVOR} \
@@ -20,7 +23,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}acme>=${ACME_VERSION},1:security/py-acme@${P
${PYTHON_PKGNAMEPREFIX}setuptools>=41.6.0:devel/py-setuptools@${PY_FLAVOR}
USES= python
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes