aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorGabor Kovesdan <gabor@FreeBSD.org>2011-08-08 11:19:48 +0000
committerGabor Kovesdan <gabor@FreeBSD.org>2011-08-08 11:19:48 +0000
commit34b256f43816efd8696a547b5a16b270aba43f0b (patch)
treed27b5e371579c930aa5ea8021e47ef6cb994f6da /security
parent9cb10ef02e23626b0f99195be36278a162449228 (diff)
downloadports-34b256f43816efd8696a547b5a16b270aba43f0b.tar.gz
ports-34b256f43816efd8696a547b5a16b270aba43f0b.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/amavisd-new/Makefile104
-rw-r--r--security/amavisd-new/distinfo4
-rw-r--r--security/amavisd-new/files/patch-configure12
-rw-r--r--security/amavisd-new/pkg-plist3
4 files changed, 36 insertions, 87 deletions
diff --git a/security/amavisd-new/Makefile b/security/amavisd-new/Makefile
index d4face39f755..f44d46e48d5f 100644
--- a/security/amavisd-new/Makefile
+++ b/security/amavisd-new/Makefile
@@ -7,7 +7,7 @@
# Based on amavisd ports makefile.
PORTNAME= amavisd-new
-PORTVERSION= 2.6.6
+PORTVERSION= 2.7.0
PORTEPOCH= 1
CATEGORIES= security
MASTER_SITES= http://www.ijs.si/software/amavisd/ \
@@ -28,12 +28,10 @@ RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Unix/Syslog.pm:${PORTSDIR}/sysutils/p5-Un
p5-Mail-DKIM>=0.33:${PORTSDIR}/mail/p5-Mail-DKIM
USE_PERL5_RUN= 5.8.2+
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-user=${AMAVISUSER} --with-runtime-dir=${AMAVISDIR}
-CONFIGURE_WRKSRC= ${WRKSRC}/helper-progs
-BUILD_WRKSRC= ${WRKSRC}/helper-progs
-DOCS= AAAREADME.first AMAVIS-MIB.txt INSTALL LDAP.schema LICENSE \
+NO_BUILD= yes
+
+DOCS= AAAREADME.first AMAVIS-MIB.txt INSTALL LDAP.schema LICENSE \
RELEASE_NOTES README_FILES/README.* README_FILES/screen.css \
README_FILES/amavisd-new-docs.html
@@ -43,35 +41,34 @@ AMAVISDIR?= /var/amavis
AMAVISQUARANTINE?= /var/virusmails
DAEMON?= /usr/sbin/daemon -p
-OPTIONS= IPV6 "Support IPv6" on \
- BDB "Use BerkeleyDB for nanny/cache/snmp" on \
- SNMP "Install amavisd snmp subagent" off \
- SQLITE "Use SQLite for lookups" off \
- MYSQL "Use MySQL for lookups/logging/quarantine" off \
- PGSQL "Use PgSQL for lookups/logging/quarantine" off \
- LDAP "Use LDAP for lookups" off \
- SASL "Use SASL authentication" off \
- MILTER "Sendmail milter support" on \
- SPAMASSASSIN "Use mail/p5-Mail-SpamAssassin" on \
- P0F "Passive operating system fingerprinting" off \
+OPTIONS= IPV6 "Support IPv6" on \
+ BDB "Use BerkeleyDB for nanny/cache/snmp" on \
+ SNMP "Install amavisd snmp subagent" off \
+ SQLITE "Use SQLite for lookups" off \
+ MYSQL "Use MySQL for lookups/logging/quarantine" off \
+ PGSQL "Use PgSQL for lookups/logging/quarantine" off \
+ LDAP "Use LDAP for lookups" off \
+ SASL "Use SASL authentication" off \
+ SPAMASSASSIN "Use mail/p5-Mail-SpamAssassin" on \
+ P0F "Passive operating system fingerprinting" off \
ALTERMIME "Use AlterMime for defanging/disclaimers" off \
- FILE "Use newer file(1) utility from ports" on \
- RAR "RAR support with archivers/rar" off \
- UNRAR "RAR support with archivers/unrar" on \
- ARJ "ARJ support with archivers/arj" on \
- UNARJ "ARJ support with archivers/unarj" off \
- LHA "LHA support with archivers/lha" on \
- ARC "ARC support with archivers/arc" on \
- NOMARCH "ARC support with archivers/nomarch" off \
- CAB "CAB support with archivers/cabextract" on \
- RPM "RPM support with archivers/rpm2cpio" on \
- ZOO "ZOO support with archivers/zoo" on \
- UNZOO "ZOO support with archivers/unzoo" off \
- LZOP "LZOP support with archivers/lzop" on \
- FREEZE "FREEZE support with archivers/freeze" on \
- P7ZIP "P7ZIP support with archivers/p7zip" on \
- MSWORD "Ms Word support with textproc/ripole" on \
- TNEF "Add external tnef decoder converters/tnef" off
+ FILE "Use newer file(1) utility from ports" on \
+ RAR "RAR support with archivers/rar" off \
+ UNRAR "RAR support with archivers/unrar" on \
+ ARJ "ARJ support with archivers/arj" on \
+ UNARJ "ARJ support with archivers/unarj" off \
+ LHA "LHA support with archivers/lha" on \
+ ARC "ARC support with archivers/arc" on \
+ NOMARCH "ARC support with archivers/nomarch" off \
+ CAB "CAB support with archivers/cabextract" on \
+ RPM "RPM support with archivers/rpm2cpio" on \
+ ZOO "ZOO support with archivers/zoo" on \
+ UNZOO "ZOO support with archivers/unzoo" off \
+ LZOP "LZOP support with archivers/lzop" on \
+ FREEZE "FREEZE support with archivers/freeze" on \
+ P7ZIP "P7ZIP support with archivers/p7zip" on \
+ MSWORD "Ms Word support with textproc/ripole" on \
+ TNEF "Add external tnef decoder converters/tnef" off
SUB_FILES= pkg-install pkg-deinstall pkg-message
@@ -82,9 +79,7 @@ SUB_LIST+= AMAVISUSER=${AMAVISUSER} \
DAEMON="${DAEMON}" \
PERL=${PERL}
-PLIST_SUB+= AMAVIS_NOAMAVIS=${AMAVIS_NOAMAVIS} \
- AMAVIS_NOMILTER=${AMAVIS_NOMILTER} \
- AMAVIS_NOP0F=${AMAVIS_NOP0F}
+PLIST_SUB+= AMAVIS_NOP0F=${AMAVIS_NOP0F}
.include <bsd.port.options.mk>
@@ -99,16 +94,6 @@ USE_RC_SUBR+= amavisd-snmp.sh
RUN_DEPENDS+= ${SITE_PERL}/Net/SNMP.pm:${PORTSDIR}/net-mgmt/p5-Net-SNMP
.endif
-.if !defined(WITH_MILTER) || (!exists(/usr/lib/libmilter.a) && !exists(${PREFIX}/lib/libmilter.a))
-AMAVIS_NOAMAVIS="@comment "
-.endif
-
-.if defined(WITH_MILTER) && !defined(AMAVIS_NOAMAVIS)
-USE_RC_SUBR+= amavis-milter.sh
-.else
-AMAVIS_NOMILTER="@comment "
-.endif
-
.if defined(WITH_BDB)
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/BerkeleyDB.pm:${PORTSDIR}/databases/p5-BerkeleyDB
.endif
@@ -236,57 +221,37 @@ RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
pre-fetch:
@${ECHO} ""
@${ECHO} " **** UPGRADE WARNING: SQL SCHEMA CHANGED ****"
- @${ECHO} " If you are upgrading from version prior to 2.6.0"
+ @${ECHO} " If you are upgrading from version prior to 2.6.6"
@${ECHO} " Hit ^c now and read /usr/ports/UPDATING section or"
@${ECHO} " /usr/local/share/doc/amavisd-new/RELEASE_NOTES"
@read -p "Hit ^c now to stop, any key to continue: " -t 5 a || true
@${ECHO} ""
post-patch:
-.for f in amavisd.conf amavisd.conf-sample amavisd amavisd-agent amavisd-nanny amavisd-release
- @${REINPLACE_CMD} "s@'zoo'\]@['zoo','unzoo'] ]@" ${WRKSRC}/${f}
-.endfor
-.for i in amavisd.conf amavisd.conf-sample
@${REINPLACE_CMD} -e "s|$daemon_user = \'vscan\';|$daemon_user = \'${AMAVISUSER}\';|" \
-e "s|$daemon_group = \'vscan\';|$daemon_group = \'${AMAVISGROUP}\';|" \
-e "s|/var/amavis|${AMAVISDIR}|" \
-e "s|/var/lib/amavis|${AMAVISDIR}|" \
- -e 's|$$log_level = 2;|$$log_level = 0;|' \
-e "s|/var/virusmails|${AMAVISQUARANTINE}|" \
-e 's|$$localhost_name = .localhost.;|$$localhost_name = $$myhostname;|' \
-e 's|/var/run/clamav/clamd|/var/run/clamav/clamd.sock|g' \
- ${WRKSRC}/${i}
-.endfor
+ ${WRKSRC}/amavisd.conf
@${REINPLACE_CMD} "s|/var/amavis/db|${AMAVISDIR}/db|" ${WRKSRC}/amavisd-agent
@${REINPLACE_CMD} "s|/var/amavis/db|${AMAVISDIR}/db|" ${WRKSRC}/amavisd-nanny
@${REINPLACE_CMD} -e "s|/var/amavis/db|${AMAVISDIR}/db|" \
-e "s|/usr/bin/perl|${PERL}|" ${WRKSRC}/amavisd-snmp-subagent
@${REINPLACE_CMD} "s|/var/amavis/amavisd.sock|${AMAVISDIR}/amavisd.sock|" \
${WRKSRC}/amavisd-release
- @${REINPLACE_CMD} "s|#define HAVE_MKTEMP|#undef HAVE_MKTEMP|" \
- ${WRKSRC}/helper-progs/config.h.in
@${REINPLACE_CMD} -e "s|/etc/amavisd.conf|${PREFIX}/etc/amavisd.conf|" \
-e "s|/usr/bin/perl|${PERL}|" \
-e "s|/var/amavis|${AMAVISDIR}|g" \
-e 's|$$localhost_name = .localhost.;|$$localhost_name = $$myhostname;|' \
${WRKSRC}/amavisd
-.if defined(AMAVIS_NOAMAVIS)
-do-configure:
-do-build:
- @${ECHO} libmilter not available, not building amavis-milter and amavis
-.endif
-
pre-install:
@${SH} ${PKGINSTALL} ${DISTNAME} PRE-INSTALL
do-install:
-.if !defined(AMAVIS_NOAMAVIS)
- ${INSTALL_PROGRAM} ${WRKSRC}/helper-progs/amavis ${PREFIX}/sbin
-.endif
-.if !defined(AMAVIS_NOMILTER)
- ${INSTALL_PROGRAM} ${WRKSRC}/helper-progs/amavis-milter ${PREFIX}/sbin
-.endif
.if defined(WITH_P0F)
${INSTALL_SCRIPT} ${WRKSRC}/p0f-analyzer.pl ${PREFIX}/sbin
.endif
@@ -294,7 +259,6 @@ do-install:
${INSTALL_SCRIPT} ${WRKSRC}/${i} ${PREFIX}/sbin
.endfor
${INSTALL_SCRIPT} ${WRKSRC}/amavisd.conf ${PREFIX}/etc/amavisd.conf-dist
- ${INSTALL_SCRIPT} ${WRKSRC}/amavisd.conf-sample ${PREFIX}/etc/amavisd.conf-sample
${INSTALL_SCRIPT} ${WRKSRC}/amavisd.conf-default ${PREFIX}/etc/amavisd.conf-default
${INSTALL_SCRIPT} ${WRKSRC}/amavisd-custom.conf ${PREFIX}/etc/amavisd-custom.conf-dist
.if !exists(${PREFIX}/etc/amavisd.conf)
diff --git a/security/amavisd-new/distinfo b/security/amavisd-new/distinfo
index 3badf8f6dde3..ac7d270296b9 100644
--- a/security/amavisd-new/distinfo
+++ b/security/amavisd-new/distinfo
@@ -1,2 +1,2 @@
-SHA256 (amavisd-new-2.6.6.tar.gz) = 4d3ce005f63dce8ce474e07bec001dac545871e2bf5641c1ffebff6b979e33d5
-SIZE (amavisd-new-2.6.6.tar.gz) = 952177
+SHA256 (amavisd-new-2.7.0.tar.gz) = 534b3d91c31e0e87a73602c84dfeb4b30b4ea64dee99fcceabd59b1bc0082b0b
+SIZE (amavisd-new-2.7.0.tar.gz) = 941811
diff --git a/security/amavisd-new/files/patch-configure b/security/amavisd-new/files/patch-configure
deleted file mode 100644
index f75f7a81e940..000000000000
--- a/security/amavisd-new/files/patch-configure
+++ /dev/null
@@ -1,12 +0,0 @@
---- helper-progs/configure.orig Thu Mar 4 18:45:55 2004
-+++ helper-progs/configure Fri Mar 12 08:53:15 2004
-@@ -2041,9 +2041,3 @@
-
-
-
--if test "$SENDMAILPROG" != "no" ; then
-- sendmailversion=`$SENDMAILPROG -bv -d0.1 | $AWK '/Version/ {print $2}'`
-- echo ""
-- echo "Info: sendmail version $sendmailversion detected"
-- echo ""
--fi
diff --git a/security/amavisd-new/pkg-plist b/security/amavisd-new/pkg-plist
index c9468ec5feec..405efc446152 100644
--- a/security/amavisd-new/pkg-plist
+++ b/security/amavisd-new/pkg-plist
@@ -71,9 +71,6 @@ etc/amavisd.conf-default
@unexec if cmp -s %D/etc/amavisd.conf %D/etc/amavisd.conf-dist; then rm -f %D/etc/amavisd.conf; fi
etc/amavisd.conf-dist
@exec [ ! -f %B/amavisd.conf ] && cp %B/%f %B/amavisd.conf
-etc/amavisd.conf-sample
-%%AMAVIS_NOAMAVIS%%sbin/amavis
-%%AMAVIS_NOMILTER%%sbin/amavis-milter
%%AMAVIS_NOP0F%%sbin/p0f-analyzer.pl
sbin/amavisd
sbin/amavisd-agent