aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2012-01-07 20:35:20 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2012-01-07 20:35:20 +0000
commit3a20d5f24fac2b42d70010da776fedd45975988e (patch)
treed819c4c026197c88b196fc4d78f8672c55c67525 /security
parent6103f7e5b7e04f1978945b4d6a73efe12e912a36 (diff)
downloadports-3a20d5f24fac2b42d70010da776fedd45975988e.tar.gz
ports-3a20d5f24fac2b42d70010da776fedd45975988e.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/nmapsi4/Makefile12
-rw-r--r--security/nmapsi4/distinfo4
-rw-r--r--security/nmapsi4/files/patch-nmapsi4-logr_CMakeLists.txt11
-rw-r--r--security/nmapsi4/files/patch-nmapsi4_CMakeLists.txt13
-rw-r--r--security/nmapsi4/pkg-plist4
5 files changed, 13 insertions, 31 deletions
diff --git a/security/nmapsi4/Makefile b/security/nmapsi4/Makefile
index 7e73e66a84b1..23046872eede 100644
--- a/security/nmapsi4/Makefile
+++ b/security/nmapsi4/Makefile
@@ -6,23 +6,29 @@
#
PORTNAME= nmapsi4
-PORTVERSION= 0.2.1
+PORTVERSION= 0.3
CATEGORIES= security
MASTER_SITES= GOOGLE_CODE
MAINTAINER= g.veniamin@googlemail.com
COMMENT= GUI frontend for the nmap scanning utility
-RUN_DEPENDS= ${LOCALBASE}/bin/nmap:${PORTSDIR}/security/nmap
-
LICENSE= GPLv2
+RUN_DEPENDS= ${LOCALBASE}/bin/nmap:${PORTSDIR}/security/nmap
+
USE_CMAKE= yes
+USE_BZIP2= yes
INSTALLS_ICONS= yes
USE_QT_VER= 4
QT_COMPONENTS= gui xml qmake_build uic_build moc_build rcc_build network \
linguist webkit
+pre-configure:
+ ${REINPLACE_CMD} -e 's#share/applications/kde4/#share/applications/#g' \
+ ${WRKSRC}/${PORTNAME}/CMakeLists.txt \
+ ${WRKSRC}/${PORTNAME}-logr/CMakeLists.txt
+
post-install:
${CHMOD} 755 ${PREFIX}/bin/${PORTNAME}
${CHMOD} 755 ${PREFIX}/bin/${PORTNAME}-logr
diff --git a/security/nmapsi4/distinfo b/security/nmapsi4/distinfo
index 3f797a244c28..5ef040044cd8 100644
--- a/security/nmapsi4/distinfo
+++ b/security/nmapsi4/distinfo
@@ -1,2 +1,2 @@
-SHA256 (nmapsi4-0.2.1.tar.gz) = 4e7589b920473c0efa3aee3e818bd491ff271664fd1695c549b38dbcb5251c2e
-SIZE (nmapsi4-0.2.1.tar.gz) = 300265
+SHA256 (nmapsi4-0.3.tar.bz2) = 51aa7e5e16577c318478b10ab3d533a15ea9e4d8cb7b7fb19a52e9b47f8b201d
+SIZE (nmapsi4-0.3.tar.bz2) = 3398283
diff --git a/security/nmapsi4/files/patch-nmapsi4-logr_CMakeLists.txt b/security/nmapsi4/files/patch-nmapsi4-logr_CMakeLists.txt
deleted file mode 100644
index f508fb033e63..000000000000
--- a/security/nmapsi4/files/patch-nmapsi4-logr_CMakeLists.txt
+++ /dev/null
@@ -1,11 +0,0 @@
---- nmapsi4-logr/CMakeLists.txt.orig 2009-12-29 14:35:41.000000000 +0700
-+++ nmapsi4-logr/CMakeLists.txt 2009-12-29 14:36:02.000000000 +0700
-@@ -67,7 +67,7 @@ endif (WIN32)
- if (Q_WS_X11)
- install(FILES ${qms} DESTINATION ${CMAKE_INSTALL_PREFIX}/share/nmapsi4/locale)
- install(FILES "${CMAKE_CURRENT_BINARY_DIR}/nmapsi4-logr" DESTINATION ${CMAKE_INSTALL_PREFIX}/bin)
-- install(FILES "src/nmapsi4-logr.desktop" DESTINATION ${CMAKE_INSTALL_PREFIX}/share/applications/kde/)
-+ install(FILES "src/nmapsi4-logr.desktop" DESTINATION ${CMAKE_INSTALL_PREFIX}/share/applications/)
- # install(FILES "src/kde/nmapsi4-admin.desktop" DESTINATION ${CMAKE_INSTALL_PREFIX}/share/applications/kde/)
- # install(FILES "icons/16x16/nmapsi4.png" DESTINATION ${CMAKE_INSTALL_PREFIX}/share/icons/hicolor/16x16/apps/)
- # install(FILES "icons/32x32/nmapsi4.png" DESTINATION ${CMAKE_INSTALL_PREFIX}/share/icons/hicolor/32x32/apps/)
diff --git a/security/nmapsi4/files/patch-nmapsi4_CMakeLists.txt b/security/nmapsi4/files/patch-nmapsi4_CMakeLists.txt
deleted file mode 100644
index 6ccf2fd50eb9..000000000000
--- a/security/nmapsi4/files/patch-nmapsi4_CMakeLists.txt
+++ /dev/null
@@ -1,13 +0,0 @@
---- nmapsi4/CMakeLists.txt.orig 2009-12-29 14:34:58.000000000 +0700
-+++ nmapsi4/CMakeLists.txt 2009-12-29 14:35:22.000000000 +0700
-@@ -106,8 +106,8 @@ endif (NOT WIN32)
- if (Q_WS_X11)
- install(FILES ${qms} DESTINATION ${CMAKE_INSTALL_PREFIX}/share/nmapsi4/locale)
- install(FILES "${CMAKE_CURRENT_BINARY_DIR}/nmapsi4" DESTINATION ${CMAKE_INSTALL_PREFIX}/bin)
-- install(FILES "kde/nmapsi4.desktop" DESTINATION ${CMAKE_INSTALL_PREFIX}/share/applications/kde/)
-- install(FILES "kde/nmapsi4-admin.desktop" DESTINATION ${CMAKE_INSTALL_PREFIX}/share/applications/kde/)
-+ install(FILES "kde/nmapsi4.desktop" DESTINATION ${CMAKE_INSTALL_PREFIX}/share/applications/)
-+ install(FILES "kde/nmapsi4-admin.desktop" DESTINATION ${CMAKE_INSTALL_PREFIX}/share/applications/)
- install(FILES "../icons/16x16/nmapsi4.png" DESTINATION ${CMAKE_INSTALL_PREFIX}/share/icons/hicolor/16x16/apps/)
- install(FILES "../icons/32x32/nmapsi4.png" DESTINATION ${CMAKE_INSTALL_PREFIX}/share/icons/hicolor/32x32/apps/)
- install(FILES "../icons/64x64/nmapsi4.png" DESTINATION ${CMAKE_INSTALL_PREFIX}/share/icons/hicolor/64x64/apps/)
diff --git a/security/nmapsi4/pkg-plist b/security/nmapsi4/pkg-plist
index d824a415206b..b010830d6405 100644
--- a/security/nmapsi4/pkg-plist
+++ b/security/nmapsi4/pkg-plist
@@ -3,8 +3,8 @@ bin/nmapsi4-logr
share/applications/nmapsi4-admin.desktop
share/applications/nmapsi4-logr.desktop
share/applications/nmapsi4.desktop
+share/dbus-1/interfaces/org.nmapsi4.Nmapsi4.xml
share/icons/hicolor/128x128/apps/nmapsi4.png
-share/icons/hicolor/16x16/apps/nmapsi4.png
share/icons/hicolor/32x32/apps/nmapsi4.png
share/icons/hicolor/64x64/apps/nmapsi4.png
%%DATADIR%%/locale/nmapsi4-logr_cs.qm
@@ -20,6 +20,7 @@ share/icons/hicolor/64x64/apps/nmapsi4.png
%%DATADIR%%/locale/nmapsi4_it.qm
%%DATADIR%%/locale/nmapsi4_pl.qm
%%DATADIR%%/locale/nmapsi4_pt_BR.qm
+%%DATADIR%%/locale/nmapsi4_ru.qm
@dirrm %%DATADIR%%/locale
@dirrm %%DATADIR%%
@dirrmtry share/icons/hicolor/128x128/apps
@@ -29,7 +30,6 @@ share/icons/hicolor/64x64/apps/nmapsi4.png
@dirrmtry share/icons/hicolor/32x32/apps
@dirrmtry share/icons/hicolor/32x32
@dirrmtry share/icons/hicolor/16x16/apps
-@dirrmtry share/icons/hicolor/16x16
@dirrmtry share/icons/hicolor
@dirrmtry share/icons
@dirrmtry share/applications