aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorVinícius Zavam <egypcio@FreeBSD.org>2020-06-12 09:02:18 +0000
committerVinícius Zavam <egypcio@FreeBSD.org>2020-06-12 09:02:18 +0000
commit42cd57a9b4dc6eb2d6775774e96c2f4a44f2819f (patch)
tree14fdb047dbed363539b84299149b6f9b919ca88a /security
parent3a4022d157894d22007e10f5ff4b20c5e9158374 (diff)
downloadports-42cd57a9b4dc6eb2d6775774e96c2f4a44f2819f.tar.gz
ports-42cd57a9b4dc6eb2d6775774e96c2f4a44f2819f.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/yubikey-agent/Makefile30
-rw-r--r--security/yubikey-agent/distinfo13
-rw-r--r--security/yubikey-agent/pkg-descr13
4 files changed, 57 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index c0db87bda114..00627719a9ab 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -1287,6 +1287,7 @@
SUBDIR += ykpers
SUBDIR += ylva
SUBDIR += yubico-piv-tool
+ SUBDIR += yubikey-agent
SUBDIR += yubikey-manager-qt
SUBDIR += yubikey-personalization-gui
SUBDIR += yubioath-desktop
diff --git a/security/yubikey-agent/Makefile b/security/yubikey-agent/Makefile
new file mode 100644
index 000000000000..1dd0d1931781
--- /dev/null
+++ b/security/yubikey-agent/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= yubikey-agent
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.1.1
+CATEGORIES= security sysutils
+
+MAINTAINER= egypcio@FreeBSD.org
+COMMENT= Seamless ssh-agent for YubiKeys
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libpcsclite.so:devel/pcsc-lite
+RUN_DEPENDS= RSA_SecurID_getpasswd:devel/libccid
+
+USES= go:modules
+USE_GITHUB= yes
+
+GH_ACCOUNT= FiloSottile
+ # github.com/go-piv/piv-go/commit/a3e5767 (Add FreeBSD Support)
+GH_TUPLE= go-piv:piv-go:a3e5767:go_piv_piv_go/vendor/github.com/go-piv/piv-go \
+ golang:crypto:4b2356b1ed79:golang_crypto/vendor/golang.org/x/crypto \
+ golang:sys:1957bb5e6d1f:golang_sys/vendor/golang.org/x/sys \
+ gopasspw:gopass:v1.9.1:gopasspw_gopass/vendor/github.com/gopasspw/gopass \
+ pkg:errors:v0.9.1:pkg_errors/vendor/github.com/pkg/errors
+
+PLIST_FILES= bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/security/yubikey-agent/distinfo b/security/yubikey-agent/distinfo
new file mode 100644
index 000000000000..c442bdc73b20
--- /dev/null
+++ b/security/yubikey-agent/distinfo
@@ -0,0 +1,13 @@
+TIMESTAMP = 1591950693
+SHA256 (FiloSottile-yubikey-agent-v0.1.1_GH0.tar.gz) = ba105395ec8321512742f69ce9cf7fc2fe4e107cf667c2b48d13749efff23d5c
+SIZE (FiloSottile-yubikey-agent-v0.1.1_GH0.tar.gz) = 15541
+SHA256 (go-piv-piv-go-a3e5767_GH0.tar.gz) = a9744ed1332e892656baede675f9a1757f466e15a0e2bab07e6b6999fa2ccc55
+SIZE (go-piv-piv-go-a3e5767_GH0.tar.gz) = 33795
+SHA256 (golang-crypto-4b2356b1ed79_GH0.tar.gz) = c881b4149829d6e249674bed9ff03d61811aeaf7c66708b36599f595a5a31d08
+SIZE (golang-crypto-4b2356b1ed79_GH0.tar.gz) = 1728742
+SHA256 (golang-sys-1957bb5e6d1f_GH0.tar.gz) = 8a20dc325d45d1226aac2ead52786de8d365af90e74ec1cb031f4292ff856643
+SIZE (golang-sys-1957bb5e6d1f_GH0.tar.gz) = 1050651
+SHA256 (gopasspw-gopass-v1.9.1_GH0.tar.gz) = ea9820dbb69d5a510c1c1f8ae561e8e1928f792d764a24cd7eca307e38e2a756
+SIZE (gopasspw-gopass-v1.9.1_GH0.tar.gz) = 418562
+SHA256 (pkg-errors-v0.9.1_GH0.tar.gz) = 56bfd893023daa498508bfe161de1be83299fcf15376035e7df79cbd7d6fa608
+SIZE (pkg-errors-v0.9.1_GH0.tar.gz) = 13415
diff --git a/security/yubikey-agent/pkg-descr b/security/yubikey-agent/pkg-descr
new file mode 100644
index 000000000000..cb8851a77589
--- /dev/null
+++ b/security/yubikey-agent/pkg-descr
@@ -0,0 +1,13 @@
+yubikey-agent is a seamless ssh-agent for YubiKeys.
+
+ (*) Easy to use. A one-command setup, one environment variable,
+and it just runs in the background.
+ (*) Indestructible. Tolerates unplugging, sleep, and suspend.
+Never needs restarting.
+ (*) Compatible. Provides a public key that works with all services
+and servers.
+ (*) Secure. The key is generated on the YubiKey and can't be
+extracted. Every session requires the PIN, every login requires a
+touch. Setup takes care of PUK and management key.
+
+WWW: https://filippo.io/yubikey-agent