aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2010-05-10 21:19:08 +0000
committerKoop Mast <kwm@FreeBSD.org>2010-05-10 21:19:08 +0000
commit48e62d9a379cd45a15f6ae89d564f81b3c13d16e (patch)
treeb627baa77f19bb1eab2fa4dee08aab1908131cd0 /security
parentfbdf96410f8e803568c33397323dd9d8d3af995f (diff)
downloadports-48e62d9a379cd45a15f6ae89d564f81b3c13d16e.tar.gz
ports-48e62d9a379cd45a15f6ae89d564f81b3c13d16e.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/gnome-keyring/Makefile8
-rw-r--r--security/gnome-keyring/distinfo6
-rw-r--r--security/gnome-keyring/files/patch-daemon_control_gkd-control-client.c11
-rw-r--r--security/gnome-keyring/files/patch-daemon_keyrings_gkr-keyrings.c10
-rw-r--r--security/gnome-keyring/files/patch-daemon_prompt_gkd-prompt.c11
-rw-r--r--security/gnome-keyring/files/patch-egg_egg-unix-credentials.c44
-rw-r--r--security/gnome-keyring/pkg-plist90
-rw-r--r--security/libgnome-keyring/Makefile28
-rw-r--r--security/libgnome-keyring/distinfo3
-rw-r--r--security/libgnome-keyring/pkg-descr3
-rw-r--r--security/libgnome-keyring/pkg-plist88
-rw-r--r--security/seahorse-plugins/Makefile28
-rw-r--r--security/seahorse-plugins/distinfo6
-rw-r--r--security/seahorse-plugins/pkg-plist21
-rw-r--r--security/seahorse/Makefile8
-rw-r--r--security/seahorse/distinfo6
-rw-r--r--security/seahorse/files/patch-daemon_seahorse-hkp-server.c13
-rw-r--r--security/seahorse/files/patch-pgp_seahorse-gpgme-source.c10
-rw-r--r--security/seahorse/files/patch-ssh_seahorse-ssh-operation.c19
-rw-r--r--security/seahorse/pkg-plist9
-rw-r--r--security/tuntun/Makefile5
22 files changed, 284 insertions, 144 deletions
diff --git a/security/Makefile b/security/Makefile
index 600f3b03a5b0..6e370479f39d 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -249,6 +249,7 @@
SUBDIR += libfwbuilder
SUBDIR += libfwbuilder-devel
SUBDIR += libgcrypt
+ SUBDIR += libgnome-keyring
SUBDIR += libgnomesu
SUBDIR += libgpg-error
SUBDIR += libgringotts
diff --git a/security/gnome-keyring/Makefile b/security/gnome-keyring/Makefile
index 7fbf00b8f570..12995c21b88e 100644
--- a/security/gnome-keyring/Makefile
+++ b/security/gnome-keyring/Makefile
@@ -3,12 +3,11 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/security/gnome-keyring/Makefile,v 1.85 2009/10/18 13:46:28 avl Exp $
+# $MCom: ports/security/gnome-keyring/Makefile,v 1.92 2010/04/27 16:51:29 kwm Exp $
#
PORTNAME= gnome-keyring
-PORTVERSION= 2.28.2
-PORTREVISION= 2
+PORTVERSION= 2.30.1
CATEGORIES= security gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -16,8 +15,7 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= A program that keeps passwords and other secrets
-LIB_DEPENDS= tasn1.4:${PORTSDIR}/security/libtasn1 \
- gcrypt.16:${PORTSDIR}/security/libgcrypt
+LIB_DEPENDS= gnome-keyring.0:${PORTSDIR}/security/libgnome-keyring
USE_BZIP2= yes
USE_GNOME= gnomehack gnomeprefix gtk20 ltverhack intlhack gconf2
diff --git a/security/gnome-keyring/distinfo b/security/gnome-keyring/distinfo
index 3a115b6dbf63..0773b83ba4f8 100644
--- a/security/gnome-keyring/distinfo
+++ b/security/gnome-keyring/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gnome-keyring-2.28.2.tar.bz2) = 97ea6823e88b39284187764c1ca95a59
-SHA256 (gnome2/gnome-keyring-2.28.2.tar.bz2) = d2d686fb2528ee045bbcd9f18d0d452e0eb88c2265a1947f639152b61a5987f6
-SIZE (gnome2/gnome-keyring-2.28.2.tar.bz2) = 3009480
+MD5 (gnome2/gnome-keyring-2.30.1.tar.bz2) = 41f4d9323c4ad7c58d88348979f7daba
+SHA256 (gnome2/gnome-keyring-2.30.1.tar.bz2) = a76e7e06c3daa44340f8a3a0f3ef4b784973cdddff2d854cb30a3e7950796e5a
+SIZE (gnome2/gnome-keyring-2.30.1.tar.bz2) = 1593050
diff --git a/security/gnome-keyring/files/patch-daemon_control_gkd-control-client.c b/security/gnome-keyring/files/patch-daemon_control_gkd-control-client.c
new file mode 100644
index 000000000000..6cdb0ca6a213
--- /dev/null
+++ b/security/gnome-keyring/files/patch-daemon_control_gkd-control-client.c
@@ -0,0 +1,11 @@
+--- daemon/control/gkd-control-client.c.orig 2009-12-21 18:43:16.000000000 -0500
++++ daemon/control/gkd-control-client.c 2009-12-21 18:44:17.000000000 -0500
+@@ -31,6 +31,8 @@
+ #include <errno.h>
+ #include <fcntl.h>
+
++#include <string.h>
++#include <sys/stat.h>
+ #include <sys/socket.h>
+ #include <sys/types.h>
+ #include <sys/un.h>
diff --git a/security/gnome-keyring/files/patch-daemon_keyrings_gkr-keyrings.c b/security/gnome-keyring/files/patch-daemon_keyrings_gkr-keyrings.c
deleted file mode 100644
index fd4ca0d28a34..000000000000
--- a/security/gnome-keyring/files/patch-daemon_keyrings_gkr-keyrings.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- daemon/keyrings/gkr-keyrings.c.orig 2009-12-16 23:41:18.000000000 -0500
-+++ daemon/keyrings/gkr-keyrings.c 2009-12-16 23:41:38.000000000 -0500
-@@ -38,6 +38,7 @@
- #include <errno.h>
- #include <stdlib.h>
- #include <stdio.h>
-+#include <string.h>
- #include <sys/types.h>
- #include <sys/socket.h>
- #include <sys/un.h>
diff --git a/security/gnome-keyring/files/patch-daemon_prompt_gkd-prompt.c b/security/gnome-keyring/files/patch-daemon_prompt_gkd-prompt.c
new file mode 100644
index 000000000000..1c4cb9ae4a1b
--- /dev/null
+++ b/security/gnome-keyring/files/patch-daemon_prompt_gkd-prompt.c
@@ -0,0 +1,11 @@
+--- daemon/prompt/gkd-prompt.c.orig 2009-12-21 19:17:13.000000000 -0500
++++ daemon/prompt/gkd-prompt.c 2009-12-21 19:17:23.000000000 -0500
+@@ -21,6 +21,8 @@
+
+ #include "config.h"
+
++#include <sys/wait.h>
++
+ #include "gkd-prompt.h"
+ #include "gkd-prompt-marshal.h"
+ #include "gkd-prompt-util.h"
diff --git a/security/gnome-keyring/files/patch-egg_egg-unix-credentials.c b/security/gnome-keyring/files/patch-egg_egg-unix-credentials.c
new file mode 100644
index 000000000000..5ae53f8b02cc
--- /dev/null
+++ b/security/gnome-keyring/files/patch-egg_egg-unix-credentials.c
@@ -0,0 +1,44 @@
+--- egg/egg-unix-credentials.c.orig 2010-01-13 00:21:23.000000000 -0500
++++ egg/egg-unix-credentials.c 2010-01-13 00:25:46.000000000 -0500
+@@ -27,6 +27,7 @@
+
+ #include <sys/types.h>
+ #include <sys/socket.h>
++#include <sys/param.h>
+ #include <sys/uio.h>
+ #include <sys/un.h>
+ #include <errno.h>
+@@ -37,6 +38,33 @@
+ #include <ucred.h>
+ #endif
+
++#if __FreeBSD_version < 701101
++static char *
++strndup (const char *s, size_t n)
++{
++ size_t nAvail;
++ char *p;
++
++ if (s == NULL)
++ return NULL;
++
++ if (memchr (s, '\0', n) != NULL) {
++ nAvail = strlen(s);
++ if (nAvail > n)
++ nAvail = n;
++ } else{
++ nAvail = n;
++ }
++ p = malloc (nAvail + 1);
++ if (p == NULL)
++ return NULL;
++ memcpy (p, s, nAvail);
++ p[nAvail] = '\0';
++
++ return p;
++}
++#endif
++
+ int
+ egg_unix_credentials_read (int sock, pid_t *pid, uid_t *uid)
+ {
diff --git a/security/gnome-keyring/pkg-plist b/security/gnome-keyring/pkg-plist
index 9c579006e301..ab1d77448aec 100644
--- a/security/gnome-keyring/pkg-plist
+++ b/security/gnome-keyring/pkg-plist
@@ -1,16 +1,16 @@
bin/gnome-keyring
bin/gnome-keyring-daemon
-etc/xdg/autostart/gnome-keyring-daemon.desktop
+etc/xdg/autostart/gnome-keyring-pkcs11.desktop
+etc/xdg/autostart/gnome-keyring-secrets.desktop
+etc/xdg/autostart/gnome-keyring-ssh.desktop
include/gcr/gcr-certificate-basics-widget.h
include/gcr/gcr-certificate-details-widget.h
include/gcr/gcr-certificate.h
include/gcr/gcr-importer.h
include/gcr/gcr-parser.h
include/gcr/gcr-types.h
+include/gcr/gcr-unlock-options-widget.h
include/gcr/gcr.h
-include/gnome-keyring-1/gnome-keyring-memory.h
-include/gnome-keyring-1/gnome-keyring-result.h
-include/gnome-keyring-1/gnome-keyring.h
include/gp11/gp11.h
include/gp11/pkcs11.h
include/gp11/pkcs11g.h
@@ -27,14 +27,13 @@ lib/gnome-keyring/gnome-keyring-pkcs11.so
lib/gnome-keyring/standalone/gck-roots-store-standalone.a
lib/gnome-keyring/standalone/gck-roots-store-standalone.la
lib/gnome-keyring/standalone/gck-roots-store-standalone.so
+lib/gnome-keyring/standalone/gck-secret-store-standalone.a
+lib/gnome-keyring/standalone/gck-secret-store-standalone.la
+lib/gnome-keyring/standalone/gck-secret-store-standalone.so
lib/libgcr.a
lib/libgcr.la
lib/libgcr.so
lib/libgcr.so.0
-lib/libgnome-keyring.a
-lib/libgnome-keyring.la
-lib/libgnome-keyring.so
-lib/libgnome-keyring.so.0
lib/libgp11.a
lib/libgp11.la
lib/libgp11.so
@@ -43,21 +42,20 @@ lib/pam_gnome_keyring.a
lib/pam_gnome_keyring.la
lib/pam_gnome_keyring.so
libdata/pkgconfig/gcr-0.pc
-libdata/pkgconfig/gnome-keyring-1.pc
libdata/pkgconfig/gp11-0.pc
-libexec/gnome-keyring-ask
+libexec/gnome-keyring-prompt
share/dbus-1/services/org.gnome.keyring.service
-share/doc/gcr/GcrCertificateBasicsWidget.html
-share/doc/gcr/GcrCertificateDetailsWidget.html
-share/doc/gcr/GcrImporter.html
-share/doc/gcr/GcrParser.html
-share/doc/gcr/GcrSimpleCertificate.html
share/doc/gcr/ch01.html
-share/doc/gcr/gcr-GcrImportDialog.html
-share/doc/gcr/gcr-GcrTokenManager.html
-share/doc/gcr/gcr-GcrXxx.html
-share/doc/gcr/gcr-gcr-certificate.html
+share/doc/gcr/gcr-GcrCertificate.html
+share/doc/gcr/gcr-gcr-certificate-basics-widget.html
+share/doc/gcr/gcr-gcr-certificate-details-widget.html
+share/doc/gcr/gcr-gcr-import-dialog.html
+share/doc/gcr/gcr-gcr-importer.html
+share/doc/gcr/gcr-gcr-initializer.html
+share/doc/gcr/gcr-gcr-parser.html
+share/doc/gcr/gcr-gcr-simple-certificate.html
share/doc/gcr/gcr-gcr-types.html
+share/doc/gcr/gcr-gcr-xxx.html
share/doc/gcr/gcr.devhelp
share/doc/gcr/gcr.devhelp2
share/doc/gcr/home.png
@@ -67,37 +65,15 @@ share/doc/gcr/left.png
share/doc/gcr/right.png
share/doc/gcr/style.css
share/doc/gcr/up.png
-%%DOCSDIR%%/ch01.html
-%%DOCSDIR%%/gnome-keyring-gnome-keyring-acl.html
-%%DOCSDIR%%/gnome-keyring-gnome-keyring-attributes.html
-%%DOCSDIR%%/gnome-keyring-gnome-keyring-daemon.html
-%%DOCSDIR%%/gnome-keyring-gnome-keyring-find.html
-%%DOCSDIR%%/gnome-keyring-gnome-keyring-item-info.html
-%%DOCSDIR%%/gnome-keyring-gnome-keyring-items.html
-%%DOCSDIR%%/gnome-keyring-gnome-keyring-keyrings.html
-%%DOCSDIR%%/gnome-keyring-gnome-keyring-memory.html
-%%DOCSDIR%%/gnome-keyring-gnome-keyring-misc.html
-%%DOCSDIR%%/gnome-keyring-gnome-keyring-network.html
-%%DOCSDIR%%/gnome-keyring-gnome-keyring-password.html
-%%DOCSDIR%%/gnome-keyring-gnome-keyring-result.html
-%%DOCSDIR%%/gnome-keyring.devhelp
-%%DOCSDIR%%/gnome-keyring.devhelp2
-%%DOCSDIR%%/home.png
-%%DOCSDIR%%/index.html
-%%DOCSDIR%%/index.sgml
-%%DOCSDIR%%/left.png
-%%DOCSDIR%%/right.png
-%%DOCSDIR%%/style.css
-%%DOCSDIR%%/up.png
+share/doc/gp11/GP11Module.html
+share/doc/gp11/GP11Object.html
+share/doc/gp11/GP11Session.html
+share/doc/gp11/GP11Slot.html
share/doc/gp11/ch01.html
-share/doc/gp11/gp11-gp11-attribute.html
-share/doc/gp11/gp11-gp11-attributes.html
-share/doc/gp11/gp11-gp11-error.html
-share/doc/gp11/gp11-gp11-misc.html
-share/doc/gp11/gp11-gp11-module.html
-share/doc/gp11/gp11-gp11-object.html
-share/doc/gp11/gp11-gp11-session.html
-share/doc/gp11/gp11-gp11-slot.html
+share/doc/gp11/gp11-Errors.html
+share/doc/gp11/gp11-GP11Attribute.html
+share/doc/gp11/gp11-GP11Attributes.html
+share/doc/gp11/gp11-Miscellaneous-Functions.html
share/doc/gp11/gp11.devhelp
share/doc/gp11/gp11.devhelp2
share/doc/gp11/home.png
@@ -109,6 +85,13 @@ share/doc/gp11/style.css
share/doc/gp11/up.png
share/gcr/ui/gcr-certificate-basics-widget.ui
share/gcr/ui/gcr-import-dialog.ui
+share/gcr/ui/gcr-unlock-options-widget.ui
+%%DATADIR%%/introspect/introspect-collection.xml
+%%DATADIR%%/introspect/introspect-item.xml
+%%DATADIR%%/introspect/introspect-prompt.xml
+%%DATADIR%%/introspect/introspect-service.xml
+%%DATADIR%%/introspect/introspect-session.xml
+%%DATADIR%%/ui/gkd-prompt.ui
share/locale/ar/LC_MESSAGES/gnome-keyring.mo
share/locale/as/LC_MESSAGES/gnome-keyring.mo
share/locale/ast/LC_MESSAGES/gnome-keyring.mo
@@ -189,17 +172,18 @@ share/locale/xh/LC_MESSAGES/gnome-keyring.mo
share/locale/zh_CN/LC_MESSAGES/gnome-keyring.mo
share/locale/zh_HK/LC_MESSAGES/gnome-keyring.mo
share/locale/zh_TW/LC_MESSAGES/gnome-keyring.mo
+@dirrm %%DATADIR%%/ui
+@dirrm %%DATADIR%%/introspect
+@dirrm %%DATADIR%%
+@dirrm share/gcr/ui
+@dirrm share/gcr
@dirrm share/doc/gp11
-@dirrm %%DOCSDIR%%
@dirrm share/doc/gcr
@dirrm lib/gnome-keyring/standalone
@dirrm lib/gnome-keyring/devel
@dirrm lib/gnome-keyring
@dirrm include/gp11
-@dirrm include/gnome-keyring-1
@dirrm include/gcr
-@dirrm share/gcr/ui
-@dirrm share/gcr
@dirrmtry share/locale/zh_HK/LC_MESSAGES
@dirrmtry share/locale/zh_HK
@dirrmtry share/locale/xh/LC_MESSAGES
diff --git a/security/libgnome-keyring/Makefile b/security/libgnome-keyring/Makefile
new file mode 100644
index 000000000000..83f2831f3fc4
--- /dev/null
+++ b/security/libgnome-keyring/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: libgnome-keyring
+# Date created: 2009-12-21
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/security/libgnome-keyring/Makefile,v 1.3 2010/04/27 16:37:52 kwm Exp $
+
+PORTNAME= libgnome-keyring
+PORTVERSION= 2.30.1
+CATEGORIES= security gnome
+MASTER_SITES= GNOME
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= A program that keeps passwords and other secrets
+
+LIB_DEPENDS= tasn1.4:${PORTSDIR}/security/libtasn1 \
+ gcrypt.16:${PORTSDIR}/security/libgcrypt
+
+USE_BZIP2= yes
+USE_GNOME= gnomehack gnomeprefix ltverhack intlhack gconf2
+USE_GMAKE= yes
+USE_GETTEXT= yes
+USE_AUTOTOOLS= libtool:22
+USE_LDCONFIG= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/security/libgnome-keyring/distinfo b/security/libgnome-keyring/distinfo
new file mode 100644
index 000000000000..b0afae706eca
--- /dev/null
+++ b/security/libgnome-keyring/distinfo
@@ -0,0 +1,3 @@
+MD5 (libgnome-keyring-2.30.1.tar.bz2) = 11ce9e5ca66cf934e243ddd68f52adc9
+SHA256 (libgnome-keyring-2.30.1.tar.bz2) = a9227da7d3eee930b75ad7858875344b713d1bf73e6af54870a2691643d5dae4
+SIZE (libgnome-keyring-2.30.1.tar.bz2) = 812131
diff --git a/security/libgnome-keyring/pkg-descr b/security/libgnome-keyring/pkg-descr
new file mode 100644
index 000000000000..90cedeaf7541
--- /dev/null
+++ b/security/libgnome-keyring/pkg-descr
@@ -0,0 +1,3 @@
+Gnome-keyring is a program that keep password and other secrets for
+users. The library libgnome-keyring is used by applications to integrate
+with the gnome keyring system.
diff --git a/security/libgnome-keyring/pkg-plist b/security/libgnome-keyring/pkg-plist
new file mode 100644
index 000000000000..7a0f7b41f1db
--- /dev/null
+++ b/security/libgnome-keyring/pkg-plist
@@ -0,0 +1,88 @@
+include/gnome-keyring-1/gnome-keyring-memory.h
+include/gnome-keyring-1/gnome-keyring-result.h
+include/gnome-keyring-1/gnome-keyring.h
+lib/libgnome-keyring.a
+lib/libgnome-keyring.la
+lib/libgnome-keyring.so
+lib/libgnome-keyring.so.0
+libdata/pkgconfig/gnome-keyring-1.pc
+share/doc/gnome-keyring/ch01.html
+share/doc/gnome-keyring/gnome-keyring-Callbacks.html
+share/doc/gnome-keyring/gnome-keyring-Item-ACLs.html
+share/doc/gnome-keyring/gnome-keyring-Item-Attributes.html
+share/doc/gnome-keyring/gnome-keyring-Item-Information.html
+share/doc/gnome-keyring/gnome-keyring-Keyring-Info.html
+share/doc/gnome-keyring/gnome-keyring-Keyring-Items.html
+share/doc/gnome-keyring/gnome-keyring-Keyrings.html
+share/doc/gnome-keyring/gnome-keyring-Network-Passwords.html
+share/doc/gnome-keyring/gnome-keyring-Non-pageable-Memory.html
+share/doc/gnome-keyring/gnome-keyring-Result-Codes.html
+share/doc/gnome-keyring/gnome-keyring-Search-Functionality.html
+share/doc/gnome-keyring/gnome-keyring.devhelp
+share/doc/gnome-keyring/gnome-keyring.devhelp2
+share/doc/gnome-keyring/home.png
+share/doc/gnome-keyring/index.html
+share/doc/gnome-keyring/index.sgml
+share/doc/gnome-keyring/left.png
+share/doc/gnome-keyring/right.png
+share/doc/gnome-keyring/style.css
+share/doc/gnome-keyring/up.png
+share/locale/ar/LC_MESSAGES/libgnome-keyring.mo
+share/locale/ast/LC_MESSAGES/libgnome-keyring.mo
+share/locale/bg/LC_MESSAGES/libgnome-keyring.mo
+share/locale/bn/LC_MESSAGES/libgnome-keyring.mo
+share/locale/ca/LC_MESSAGES/libgnome-keyring.mo
+share/locale/ca@valencia/LC_MESSAGES/libgnome-keyring.mo
+share/locale/cs/LC_MESSAGES/libgnome-keyring.mo
+share/locale/da/LC_MESSAGES/libgnome-keyring.mo
+share/locale/de/LC_MESSAGES/libgnome-keyring.mo
+share/locale/el/LC_MESSAGES/libgnome-keyring.mo
+share/locale/en_GB/LC_MESSAGES/libgnome-keyring.mo
+share/locale/es/LC_MESSAGES/libgnome-keyring.mo
+share/locale/et/LC_MESSAGES/libgnome-keyring.mo
+share/locale/eu/LC_MESSAGES/libgnome-keyring.mo
+share/locale/fi/LC_MESSAGES/libgnome-keyring.mo
+share/locale/fr/LC_MESSAGES/libgnome-keyring.mo
+share/locale/gl/LC_MESSAGES/libgnome-keyring.mo
+share/locale/hu/LC_MESSAGES/libgnome-keyring.mo
+share/locale/id/LC_MESSAGES/libgnome-keyring.mo
+share/locale/it/LC_MESSAGES/libgnome-keyring.mo
+share/locale/ja/LC_MESSAGES/libgnome-keyring.mo
+share/locale/ko/LC_MESSAGES/libgnome-keyring.mo
+share/locale/lt/LC_MESSAGES/libgnome-keyring.mo
+share/locale/lv/LC_MESSAGES/libgnome-keyring.mo
+share/locale/ml/LC_MESSAGES/libgnome-keyring.mo
+share/locale/mn/LC_MESSAGES/libgnome-keyring.mo
+share/locale/nb/LC_MESSAGES/libgnome-keyring.mo
+share/locale/nds/LC_MESSAGES/libgnome-keyring.mo
+share/locale/nl/LC_MESSAGES/libgnome-keyring.mo
+share/locale/nn/LC_MESSAGES/libgnome-keyring.mo
+share/locale/pa/LC_MESSAGES/libgnome-keyring.mo
+share/locale/pl/LC_MESSAGES/libgnome-keyring.mo
+share/locale/pt/LC_MESSAGES/libgnome-keyring.mo
+share/locale/pt_BR/LC_MESSAGES/libgnome-keyring.mo
+share/locale/ro/LC_MESSAGES/libgnome-keyring.mo
+share/locale/ru/LC_MESSAGES/libgnome-keyring.mo
+share/locale/sk/LC_MESSAGES/libgnome-keyring.mo
+share/locale/sl/LC_MESSAGES/libgnome-keyring.mo
+share/locale/sr/LC_MESSAGES/libgnome-keyring.mo
+share/locale/sr@latin/LC_MESSAGES/libgnome-keyring.mo
+share/locale/sv/LC_MESSAGES/libgnome-keyring.mo
+share/locale/ta/LC_MESSAGES/libgnome-keyring.mo
+share/locale/th/LC_MESSAGES/libgnome-keyring.mo
+share/locale/uk/LC_MESSAGES/libgnome-keyring.mo
+share/locale/zh_CN/LC_MESSAGES/libgnome-keyring.mo
+share/locale/zh_HK/LC_MESSAGES/libgnome-keyring.mo
+share/locale/zh_TW/LC_MESSAGES/libgnome-keyring.mo
+@dirrmtry share/local/zh_HK/LC_MESSAGES
+@dirrmtry share/local/zh_HK
+@dirrmtry share/local/sr@latin/LC_MESSAGES
+@dirrmtry share/local/sr@latin
+@dirrmtry share/local/nds/LC_MESSAGES
+@dirrmtry share/local/nds
+@dirrmtry share/local/ca@valencia/LC_MESSAGES
+@dirrmtry share/local/ca@valencia
+@dirrmtry share/local/ast/LC_MESSAGES
+@dirrmtry share/local/ast
+@dirrm share/doc/gnome-keyring
+@dirrm include/gnome-keyring-1
diff --git a/security/seahorse-plugins/Makefile b/security/seahorse-plugins/Makefile
index 56d6e4941ae8..f080ed5b73cf 100644
--- a/security/seahorse-plugins/Makefile
+++ b/security/seahorse-plugins/Makefile
@@ -3,12 +3,11 @@
# Whom: Dave McKay <dave@mu.org>
#
# $FreeBSD$
-# $MCom: ports/security/seahorse-plugins/Makefile,v 1.18 2009/10/19 10:24:17 kwm Exp $
+# $MCom: ports/security/seahorse-plugins/Makefile,v 1.25 2010/04/27 22:22:07 kwm Exp $
#
PORTNAME= seahorse-plugins
-PORTVERSION= 2.28.1
-PORTREVISION= 2
+PORTVERSION= 2.30.1
CATEGORIES= security gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -21,8 +20,8 @@ LIB_DEPENDS= cryptui.0:${PORTSDIR}/security/seahorse
USE_BZIP2= yes
USE_GETTEXT= yes
USE_GMAKE= yes
-USE_GECKO= libxul
-USE_GNOME= gnomehack intlhack gnomeprefix libglade2 gconf2 gnomedocutils
+#USE_GECKO= libxul
+USE_GNOME= gnomehack intlhack gnomeprefix gconf2 gnomedocutils
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
INSTALLS_OMF= yes
@@ -31,7 +30,8 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
OPTIONS= NAUTILUS "Enable the Nautilus component" on \
GEDIT "Enable GEdit plug-in support" on \
- APPLET "Enable clipboard encryption applet" on
+ APPLET "Enable clipboard encryption applet" on \
+ NOTIFY "Enable libnotify support" on
#EPIPHANY "Enable Epiphany plug-in support" on
GCONF_SCHEMAS= seahorse-plugins.schemas
@@ -39,11 +39,11 @@ MAN1= seahorse-agent.1 seahorse-tool.1
.include <bsd.port.pre.mk>
-.if ${GECKO}=="libxul"
-CONFIGURE_ARGS+=--with-gecko=libxul-unstable
-.else
-CONFIGURE_ARGS+=--with-gecko=${GECKO}
-.endif
+#.if ${GECKO}=="libxul"
+#CONFIGURE_ARGS+=--with-gecko=libxul-unstable
+#.else
+#CONFIGURE_ARGS+=--with-gecko=${GECKO}
+#.endif
.if !defined(WITHOUT_GEDIT)
BUILD_DEPENDS+= gedit:${PORTSDIR}/editors/gedit
@@ -80,6 +80,12 @@ CONFIGURE_ARGS+=--disable-applet
PLIST_SUB+= APPLET="@comment "
.endif
+.if !defined(WITHOUT_NOTIFY)
+LIB_DEPENDS+= notify.1:${PORTSDIR}/devel/libnotify
+.else
+CONFIGURE_ARGS+=--disable-libnotify
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|" == "|" = "|g' \
-e 's|epiphany-2.24|epiphany-2.26|g' \
diff --git a/security/seahorse-plugins/distinfo b/security/seahorse-plugins/distinfo
index f8ddd7b776cb..be6b571529b2 100644
--- a/security/seahorse-plugins/distinfo
+++ b/security/seahorse-plugins/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/seahorse-plugins-2.28.1.tar.bz2) = cec5ef8b94c16798f53a5876d3718b91
-SHA256 (gnome2/seahorse-plugins-2.28.1.tar.bz2) = e04f9bba2d0527951cb15367e285d0f75de6392b140ca4183a70cec3fef7e97e
-SIZE (gnome2/seahorse-plugins-2.28.1.tar.bz2) = 1315429
+MD5 (gnome2/seahorse-plugins-2.30.1.tar.bz2) = cb8a86a1039054b621f6419ac2219695
+SHA256 (gnome2/seahorse-plugins-2.30.1.tar.bz2) = 1fdfed1aef2c22a29a9abc00eae67752854e466a66cee2a8c1c278277e832d66
+SIZE (gnome2/seahorse-plugins-2.30.1.tar.bz2) = 1304864
diff --git a/security/seahorse-plugins/pkg-plist b/security/seahorse-plugins/pkg-plist
index ece59b733c39..3efe45464379 100644
--- a/security/seahorse-plugins/pkg-plist
+++ b/security/seahorse-plugins/pkg-plist
@@ -46,6 +46,7 @@ share/icons/hicolor/48x48/apps/seahorse-applet.png
share/icons/hicolor/scalable/apps/seahorse-applet.svg
share/locale/ar/LC_MESSAGES/seahorse-plugins.mo
share/locale/as/LC_MESSAGES/seahorse-plugins.mo
+share/locale/ast/LC_MESSAGES/seahorse-plugins.mo
share/locale/az/LC_MESSAGES/seahorse-plugins.mo
share/locale/be@latin/LC_MESSAGES/seahorse-plugins.mo
share/locale/bg/LC_MESSAGES/seahorse-plugins.mo
@@ -59,6 +60,7 @@ share/locale/da/LC_MESSAGES/seahorse-plugins.mo
share/locale/de/LC_MESSAGES/seahorse-plugins.mo
share/locale/dz/LC_MESSAGES/seahorse-plugins.mo
share/locale/el/LC_MESSAGES/seahorse-plugins.mo
+share/locale/en@shaw/LC_MESSAGES/seahorse-plugins.mo
share/locale/en_CA/LC_MESSAGES/seahorse-plugins.mo
share/locale/en_GB/LC_MESSAGES/seahorse-plugins.mo
share/locale/es/LC_MESSAGES/seahorse-plugins.mo
@@ -95,6 +97,7 @@ share/locale/pa/LC_MESSAGES/seahorse-plugins.mo
share/locale/pl/LC_MESSAGES/seahorse-plugins.mo
share/locale/pt/LC_MESSAGES/seahorse-plugins.mo
share/locale/pt_BR/LC_MESSAGES/seahorse-plugins.mo
+share/locale/ro/LC_MESSAGES/seahorse-plugins.mo
share/locale/ru/LC_MESSAGES/seahorse-plugins.mo
share/locale/rw/LC_MESSAGES/seahorse-plugins.mo
share/locale/si/LC_MESSAGES/seahorse-plugins.mo
@@ -173,14 +176,14 @@ share/pixmaps/seahorse-plugins/scalable/seahorse-sign-bad.svg
share/pixmaps/seahorse-plugins/scalable/seahorse-sign-ok.svg
share/pixmaps/seahorse-plugins/scalable/seahorse-sign-unknown.svg
share/pixmaps/seahorse-plugins/scalable/seahorse-sign.svg
-%%DATADIR%%/glade/seahorse-agent-cache.glade
-%%DATADIR%%/glade/seahorse-applet-preferences.glade
-%%DATADIR%%/glade/seahorse-multi-encrypt.glade
-%%DATADIR%%/glade/seahorse-notify.glade
-%%DATADIR%%/glade/seahorse-prefs.glade
-%%DATADIR%%/glade/seahorse-progress.glade
+%%DATADIR%%/ui/seahorse-agent-cache.xml
+%%DATADIR%%/ui/seahorse-applet-preferences.xml
+%%DATADIR%%/ui/seahorse-multi-encrypt.xml
+%%DATADIR%%/ui/seahorse-notify.xml
+%%DATADIR%%/ui/seahorse-prefs.xml
+%%DATADIR%%/ui/seahorse-progress.xml
%%EPHY%%@dirrmtry lib/epiphany/%%EPHY_VERSION%%/extensions
-@dirrm %%DATADIR%%/glade
+@dirrm %%DATADIR%%/ui
@dirrm %%DATADIR%%
@dirrmtry share/pixmaps/seahorse-plugins/scalable
@dirrmtry share/pixmaps/seahorse-plugins/48x48
@@ -234,6 +237,8 @@ share/pixmaps/seahorse-plugins/scalable/seahorse-sign.svg
@dirrmtry share/locale/mai
@dirrmtry share/locale/ku/LC_MESSAGES
@dirrmtry share/locale/ku
+@dirrmtry share/locale/en@shaw/LC_MESSAGES
+@dirrmtry share/locale/en@shaw
@dirrmtry share/locale/dz/LC_MESSAGES
@dirrmtry share/locale/dz
@dirrmtry share/locale/ca@valencia/LC_MESSAGES
@@ -242,5 +247,7 @@ share/pixmaps/seahorse-plugins/scalable/seahorse-sign.svg
@dirrmtry share/locale/bn_IN
@dirrmtry share/locale/be@latin/LC_MESSAGES
@dirrmtry share/locale/be@latin
+@dirrmtry share/locale/ast/LC_MESSAGES
+@dirrmtry share/locale/ast
@dirrmtry share/locale/as/LC_MESSAGES
@dirrmtry share/locale/as
diff --git a/security/seahorse/Makefile b/security/seahorse/Makefile
index ff70b71e0baf..2f6731c5be56 100644
--- a/security/seahorse/Makefile
+++ b/security/seahorse/Makefile
@@ -3,12 +3,11 @@
# Whom: Dave McKay <dave@mu.org>
#
# $FreeBSD$
-# $MCom: ports/security/seahorse/Makefile,v 1.88 2009/10/18 02:38:21 avl Exp $
+# $MCom: ports/security/seahorse/Makefile,v 1.96 2010/04/27 22:04:55 kwm Exp $
#
PORTNAME= seahorse
-PORTVERSION= 2.28.1
-PORTREVISION= 2
+PORTVERSION= 2.30.1
CATEGORIES= security gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -34,9 +33,10 @@ INSTALLS_OMF= yes
INSTALLS_ICONS= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --enable-introspection=no
GCONF_SCHEMAS= seahorse.schemas
-MAN1= seahorse-daemon.1
+MAN1= seahorse.1 seahorse-daemon.1
OPTIONS= LDAP "Enable LDAP support" on \
NOTIFY "Enable libnotify support" on \
diff --git a/security/seahorse/distinfo b/security/seahorse/distinfo
index ee99c6c64910..8134344b0bb2 100644
--- a/security/seahorse/distinfo
+++ b/security/seahorse/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/seahorse-2.28.1.tar.bz2) = c49d4d9bcfe7620081df517ab939f67b
-SHA256 (gnome2/seahorse-2.28.1.tar.bz2) = 67a1ae5eaceca6306a6a740c8753c5a6c4b511cfbf8a8031a78ae61297ced0a0
-SIZE (gnome2/seahorse-2.28.1.tar.bz2) = 2397687
+MD5 (gnome2/seahorse-2.30.1.tar.bz2) = b332279b34acca952807e31534fec592
+SHA256 (gnome2/seahorse-2.30.1.tar.bz2) = 1b97064ee91f87494040313a0a2fe813473ec4dba15b5781245080e8fea8e7c3
+SIZE (gnome2/seahorse-2.30.1.tar.bz2) = 2422214
diff --git a/security/seahorse/files/patch-daemon_seahorse-hkp-server.c b/security/seahorse/files/patch-daemon_seahorse-hkp-server.c
deleted file mode 100644
index 1880aad325a3..000000000000
--- a/security/seahorse/files/patch-daemon_seahorse-hkp-server.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- daemon/seahorse-hkp-server.c.orig 2009-08-01 15:25:02.000000000 -0400
-+++ daemon/seahorse-hkp-server.c 2009-08-01 15:23:27.000000000 -0400
-@@ -467,7 +467,9 @@ seahorse_hkp_server_start(GError **err)
- /* Initialize GPGME context */
- if (gpgme_ctx == NULL) {
- gpgme_protocol_t proto = GPGME_PROTOCOL_OpenPGP;
-- gpgme_error_t err = gpgme_engine_check_version (proto);
-+ gpgme_error_t err;
-+ gpgme_check_version (NULL);
-+ err = gpgme_engine_check_version (proto);
- g_return_val_if_fail (GPG_IS_OK (err), FALSE);
-
- err = gpgme_new (&gpgme_ctx);
diff --git a/security/seahorse/files/patch-pgp_seahorse-gpgme-source.c b/security/seahorse/files/patch-pgp_seahorse-gpgme-source.c
deleted file mode 100644
index b036a81571df..000000000000
--- a/security/seahorse/files/patch-pgp_seahorse-gpgme-source.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- pgp/seahorse-gpgme-source.c.orig 2009-08-01 15:24:28.000000000 -0400
-+++ pgp/seahorse-gpgme-source.c 2009-08-01 15:23:24.000000000 -0400
-@@ -139,6 +139,7 @@ init_gpgme (gpgme_ctx_t *ctx)
- gpgme_protocol_t proto = GPGME_PROTOCOL_OpenPGP;
- gpgme_error_t err;
-
-+ gpgme_check_version (NULL);
- err = gpgme_engine_check_version (proto);
- g_return_val_if_fail (GPG_IS_OK (err), err);
-
diff --git a/security/seahorse/files/patch-ssh_seahorse-ssh-operation.c b/security/seahorse/files/patch-ssh_seahorse-ssh-operation.c
deleted file mode 100644
index 1c7acece0685..000000000000
--- a/security/seahorse/files/patch-ssh_seahorse-ssh-operation.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- ssh/seahorse-ssh-operation.c.orig 2009-04-12 10:29:33.000000000 -0400
-+++ ssh/seahorse-ssh-operation.c 2009-04-19 20:44:50.000000000 -0400
-@@ -281,11 +281,14 @@ askpass_handler (GIOChannel *source, GIO
- const gchar *result = NULL;
-
- if (condition & G_IO_IN) {
-+ GIOStatus status;
-
- /* Read 1 line from the io channel, including newline character */
-- g_io_channel_read_line (source, &string, &length, NULL, &err);
-+ status = g_io_channel_read_line (source, &string, &length, NULL, &err);
-
-- if (err != NULL) {
-+ if (status == G_IO_STATUS_EOF) {
-+ ret = FALSE;
-+ } else if (err != NULL) {
- g_critical ("couldn't read from seahorse-ssh-askpass: %s", err->message);
- g_clear_error (&err);
- ret = FALSE;
diff --git a/security/seahorse/pkg-plist b/security/seahorse/pkg-plist
index a15a34c04cc4..453aae477c26 100644
--- a/security/seahorse/pkg-plist
+++ b/security/seahorse/pkg-plist
@@ -1,6 +1,5 @@
bin/seahorse
bin/seahorse-daemon
-etc/xdg/autostart/seahorse-daemon.desktop
include/libcryptui/cryptui-key-chooser.h
include/libcryptui/cryptui-key-combo.h
include/libcryptui/cryptui-key-list.h
@@ -120,6 +119,7 @@ share/icons/hicolor/48x48/apps/seahorse-preferences.png
share/icons/hicolor/48x48/apps/seahorse.png
share/locale/ar/LC_MESSAGES/seahorse.mo
share/locale/as/LC_MESSAGES/seahorse.mo
+share/locale/ast/LC_MESSAGES/seahorse.mo
share/locale/az/LC_MESSAGES/seahorse.mo
share/locale/be@latin/LC_MESSAGES/seahorse.mo
share/locale/bg/LC_MESSAGES/seahorse.mo
@@ -136,6 +136,7 @@ share/locale/dz/LC_MESSAGES/seahorse.mo
share/locale/el/LC_MESSAGES/seahorse.mo
share/locale/en_CA/LC_MESSAGES/seahorse.mo
share/locale/en_GB/LC_MESSAGES/seahorse.mo
+share/locale/en@shaw/LC_MESSAGES/seahorse.mo
share/locale/es/LC_MESSAGES/seahorse.mo
share/locale/et/LC_MESSAGES/seahorse.mo
share/locale/eu/LC_MESSAGES/seahorse.mo
@@ -148,6 +149,7 @@ share/locale/he/LC_MESSAGES/seahorse.mo
share/locale/hi/LC_MESSAGES/seahorse.mo
share/locale/hr/LC_MESSAGES/seahorse.mo
share/locale/hu/LC_MESSAGES/seahorse.mo
+share/locale/id/LC_MESSAGES/seahorse.mo
share/locale/it/LC_MESSAGES/seahorse.mo
share/locale/ja/LC_MESSAGES/seahorse.mo
share/locale/kn/LC_MESSAGES/seahorse.mo
@@ -170,6 +172,7 @@ share/locale/pa/LC_MESSAGES/seahorse.mo
share/locale/pl/LC_MESSAGES/seahorse.mo
share/locale/pt/LC_MESSAGES/seahorse.mo
share/locale/pt_BR/LC_MESSAGES/seahorse.mo
+share/locale/ro/LC_MESSAGES/seahorse.mo
share/locale/ru/LC_MESSAGES/seahorse.mo
share/locale/rw/LC_MESSAGES/seahorse.mo
share/locale/si/LC_MESSAGES/seahorse.mo
@@ -315,6 +318,8 @@ share/pixmaps/seahorse/scalable/seahorse-sign.svg
@dirrmtry share/locale/mai
@dirrmtry share/locale/ku/LC_MESSAGES
@dirrmtry share/locale/ku
+@dirrmtry share/locale/en@shaw/LC_MESSAGES
+@dirrmtry share/locale/en@shaw
@dirrmtry share/locale/dz/LC_MESSAGES
@dirrmtry share/locale/dz
@dirrmtry share/locale/ca@valencia/LC_MESSAGES
@@ -323,5 +328,7 @@ share/pixmaps/seahorse/scalable/seahorse-sign.svg
@dirrmtry share/locale/bn_IN
@dirrmtry share/locale/be@latin/LC_MESSAGES
@dirrmtry share/locale/be@latin
+@dirrmtry share/locale/ast/LC_MESSAGES
+@dirrmtry share/locale/ast
@dirrmtry share/locale/as/LC_MESSAGES
@dirrmtry share/locale/as
diff --git a/security/tuntun/Makefile b/security/tuntun/Makefile
index 2637c7e28d6e..0f517482f7f8 100644
--- a/security/tuntun/Makefile
+++ b/security/tuntun/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tuntun
PORTVERSION= 0.4.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security gnome
MASTER_SITES= http://tuntun.googlecode.com/files/
@@ -20,6 +20,7 @@ CONFIGURE_ENV= CPPFLAGS="`pkg-config --cflags libgnomeui-2.0`" \
CONFIGURE_ARGS= --libdir=${PREFIX}/libdata/servers
USE_GMAKE= yes
-USE_GNOME= gnomehier intlhack gnomeprefix gnomehack gnomepanel glib20
+USE_GNOME= gnomehier intlhack gnomeprefix gnomehack gnomepanel glib20 \
+ libgnomeui
.include <bsd.port.mk>