aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorThomas Abthorpe <tabthorpe@FreeBSD.org>2013-10-19 13:24:59 +0000
committerThomas Abthorpe <tabthorpe@FreeBSD.org>2013-10-19 13:24:59 +0000
commit4965f0bc28eee47a8265c8aa06f3d17cf364d577 (patch)
treeecc5e7a7773fb6f22b2bcdde0c124ed977be5d86 /security
parent8ddbe179489874637701a5fa90730d2ad077737b (diff)
downloadports-4965f0bc28eee47a8265c8aa06f3d17cf364d577.tar.gz
ports-4965f0bc28eee47a8265c8aa06f3d17cf364d577.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/bro/Makefile2
-rw-r--r--security/bro/files/patch-CMakeLists.txt20
-rw-r--r--security/bro/files/patch-aux-broccoli-CMakeLists.txt14
3 files changed, 21 insertions, 15 deletions
diff --git a/security/bro/Makefile b/security/bro/Makefile
index cd46f490463f..0f3580270c4d 100644
--- a/security/bro/Makefile
+++ b/security/bro/Makefile
@@ -3,7 +3,7 @@
PORTNAME= bro
PORTVERSION= 2.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security
MASTER_SITES= http://www.bro-ids.org/downloads/release/
diff --git a/security/bro/files/patch-CMakeLists.txt b/security/bro/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..c244f21795dd
--- /dev/null
+++ b/security/bro/files/patch-CMakeLists.txt
@@ -0,0 +1,20 @@
+--- CMakeLists.txt.orig 2013-03-12 19:08:46.000000000 -0700
++++ CMakeLists.txt 2013-03-12 19:09:12.000000000 -0700
+@@ -187,7 +187,7 @@
+
+ CheckOptionalBuildSources(aux/broctl Broctl INSTALL_BROCTL)
+ CheckOptionalBuildSources(aux/bro-aux Bro-Aux INSTALL_AUX_TOOLS)
+-CheckOptionalBuildSources(aux/broccoli Broccoli INSTALL_BROCCOLI)
++#CheckOptionalBuildSources(aux/broccoli Broccoli INSTALL_BROCCOLI)
+
+ ########################################################################
+ ## Packaging Setup
+@@ -225,7 +225,7 @@
+ "\nCXXFLAGS: ${CMAKE_CXX_FLAGS} ${CMAKE_CXX_FLAGS_${BuildType}}"
+ "\nCPP: ${CMAKE_CXX_COMPILER}"
+ "\n"
+- "\nBroccoli: ${INSTALL_BROCCOLI}"
++# "\nBroccoli: ${INSTALL_BROCCOLI}"
+ "\nBroctl: ${INSTALL_BROCTL}"
+ "\nAux. Tools: ${INSTALL_AUX_TOOLS}"
+ "\n"
diff --git a/security/bro/files/patch-aux-broccoli-CMakeLists.txt b/security/bro/files/patch-aux-broccoli-CMakeLists.txt
deleted file mode 100644
index 80978b91225c..000000000000
--- a/security/bro/files/patch-aux-broccoli-CMakeLists.txt
+++ /dev/null
@@ -1,14 +0,0 @@
---- aux/broccoli/CMakeLists.txt.orig 2012-12-06 09:29:33.000000000 +0800
-+++ aux/broccoli/CMakeLists.txt 2012-12-06 09:29:58.000000000 +0800
-@@ -98,11 +98,6 @@
-
- include(InstallPackageConfigFile)
-
--InstallPackageConfigFile(
-- ${CMAKE_CURRENT_SOURCE_DIR}/broccoli.conf
-- ${BRO_SYSCONF_DIR}
-- broccoli.conf)
--
- install(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/broccoli-config DESTINATION bin)
-
- ########################################################################