aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-02-12 07:58:18 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-02-12 07:58:18 +0000
commit7c0ec45bc8a8b32f08a83c94d65f6b93c760fda9 (patch)
tree66312a7cd3f6ec2cab49b4a716660df51528d13a /security
parent57d3430b714f71231fc45546b6ee83a26986c2ac (diff)
downloadports-7c0ec45bc8a8b32f08a83c94d65f6b93c760fda9.tar.gz
ports-7c0ec45bc8a8b32f08a83c94d65f6b93c760fda9.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/stoken/Makefile31
-rw-r--r--security/stoken/distinfo6
-rw-r--r--security/stoken/pkg-descr2
-rw-r--r--security/stoken/pkg-plist3
4 files changed, 17 insertions, 25 deletions
diff --git a/security/stoken/Makefile b/security/stoken/Makefile
index 29a37b22cddd..2406f39eb414 100644
--- a/security/stoken/Makefile
+++ b/security/stoken/Makefile
@@ -2,39 +2,34 @@
# $FreeBSD$
PORTNAME= stoken
-PORTVERSION= 0.91
+DISTVERSION= 0.92
CATEGORIES= security
MASTER_SITES= SF/stoken
MAINTAINER= samm@os2.kiev.ua
COMMENT= Software Token for UNIX compatible with RSA SecurID
-LICENSE= GPLv2
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING.LIB
-LIB_DEPENDS= libtomcrypt.so:security/libtomcrypt
+LIB_DEPENDS= libtomcrypt.so:security/libtomcrypt # can alternatively use nettle, potentially port option can be created
+
+USES= libtool localbase pkgconfig
+GNU_CONFIGURE= yes
+USE_GNOME= libxml2
+USE_LDCONFIG= yes
+INSTALL_TARGET= install-strip
OPTIONS_DEFINE= X11
OPTIONS_SUB= yes
X11_CONFIGURE_WITH= gtk
X11_DESC= Build GUI token interface
-X11_USE= GNOME=gtk30
-
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --with-pkgconfigdir="${PREFIX}/libdata/pkgconfig"
-
-USE_LDCONFIG= yes
-USE_GNOME= libxml2
-USES= pkgconfig libtool
-
-CFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-
-INSTALL_TARGET= install-strip
+X11_USE= GNOME=gtk30,cairo,gdkpixbuf2
post-patch:
- ${REINPLACE_CMD} -e 's|/bin/bash|/bin/sh|g' ${WRKSRC}/Makefile.in
- ${REINPLACE_CMD} -e 's|LTC_LTC_PKCS_1_V1_5|LTC_PKCS_1_V1_5|g' \
+ @${REINPLACE_CMD} -e 's|/bin/bash|/bin/sh|g ; s|^dist_doc_DATA|#dist_doc_DATA|' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|LTC_LTC_PKCS_1_V1_5|LTC_PKCS_1_V1_5|g' \
${WRKSRC}/src/stc-tomcrypt.c
.include <bsd.port.mk>
diff --git a/security/stoken/distinfo b/security/stoken/distinfo
index d1b9fa5b32be..4ce82c190f3b 100644
--- a/security/stoken/distinfo
+++ b/security/stoken/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1484076907
-SHA256 (stoken-0.91.tar.gz) = 419ed84000bc455ef77c78e3ebfd4c6fd2d932384563989f864becbafd51bcf4
-SIZE (stoken-0.91.tar.gz) = 425328
+TIMESTAMP = 1518349781
+SHA256 (stoken-0.92.tar.gz) = aa2b481b058e4caf068f7e747a2dcf5772bcbf278a4f89bc9efcbf82bcc9ef5a
+SIZE (stoken-0.92.tar.gz) = 425835
diff --git a/security/stoken/pkg-descr b/security/stoken/pkg-descr
index c03edd03b381..36cc04a6fb6b 100644
--- a/security/stoken/pkg-descr
+++ b/security/stoken/pkg-descr
@@ -2,4 +2,4 @@ Stoken is an open source tokencode generator compatible with RSA SecurID 128-bit
(AES) tokens. It is a hobbyist project, not affiliated with or endorsed by RSA
Security.
-WWW: http://stoken.sourceforge.net
+WWW: https://sourceforge.net/p/stoken/wiki/Home/
diff --git a/security/stoken/pkg-plist b/security/stoken/pkg-plist
index 1e2fbc5d8c49..ac3fdb5e837d 100644
--- a/security/stoken/pkg-plist
+++ b/security/stoken/pkg-plist
@@ -13,8 +13,5 @@ man/man1/stoken.1.gz
%%X11%%%%DATADIR%%/pin-dialog.ui
%%X11%%%%DATADIR%%/tokencode-detail.ui
%%X11%%%%DATADIR%%/tokencode-small.ui
-%%PORTDOCS%%%%DOCSDIR%%/README.md
-%%PORTDOCS%%%%DOCSDIR%%/libstoken-test.c
-%%PORTDOCS%%%%DOCSDIR%%/sdtid-test.pl
%%X11%%share/pixmaps/stoken-gui.png
libdata/pkgconfig/stoken.pc