aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2012-06-03 22:23:00 +0000
committerGabor Pali <pgj@FreeBSD.org>2012-06-03 22:23:00 +0000
commit8daf56123ede7bc65572023e65a249938fea39ba (patch)
treef891917a0cd1d07bb56add56a1114cd78294cc88 /security
parentc6044ea7253bd36d7d3f501e945763974eaa730f (diff)
downloadports-8daf56123ede7bc65572023e65a249938fea39ba.tar.gz
ports-8daf56123ede7bc65572023e65a249938fea39ba.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/hs-RSA/Makefile5
-rw-r--r--security/hs-RSA/distinfo4
-rw-r--r--security/hs-RSA/pkg-descr9
3 files changed, 8 insertions, 10 deletions
diff --git a/security/hs-RSA/Makefile b/security/hs-RSA/Makefile
index 7206046dbfec..3ac87e7ca170 100644
--- a/security/hs-RSA/Makefile
+++ b/security/hs-RSA/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= RSA
-PORTVERSION= 1.0.6.2
+PORTVERSION= 1.2.1.0
CATEGORIES= security haskell
MAINTAINER= haskell@FreeBSD.org
@@ -15,7 +15,7 @@ COMMENT= Implementation of RSA, using the padding schemes of PKCS#1 v2.1
LICENSE= BSD
CABAL_SETUP= Setup.hs
-USE_CABAL= SHA
+USE_CABAL= crypto-api>=0.10 crypto-pubkey-types monadcryptorandom SHA
OPTIONS= MD5 "Include support for using MD5" on \
BINARY "Use the binary package for serialization" on
@@ -32,7 +32,6 @@ CONFIGURE_ARGS+= --flags="-IncludeMD5"
.if defined(WITH_BINARY)
CONFIGURE_ARGS+= --flags="UseBinary"
-USE_CABAL+= binary
.else
CONFIGURE_ARGS+= --flags="-UseBinary"
.endif
diff --git a/security/hs-RSA/distinfo b/security/hs-RSA/distinfo
index 6899a5e0314e..0a358bd288cd 100644
--- a/security/hs-RSA/distinfo
+++ b/security/hs-RSA/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/RSA-1.0.6.2.tar.gz) = 93c34f4fd4d99530b54205d93922dc280b83cbbc92a53e6ad9d63cf93edf4b69
-SIZE (cabal/RSA-1.0.6.2.tar.gz) = 11986
+SHA256 (cabal/RSA-1.2.1.0.tar.gz) = 8a053ddce835c5ec75e69147f7522a132c68c21235fb696c7c0d67e2651fa593
+SIZE (cabal/RSA-1.2.1.0.tar.gz) = 12187
diff --git a/security/hs-RSA/pkg-descr b/security/hs-RSA/pkg-descr
index 52c822236d15..275de8ba78e9 100644
--- a/security/hs-RSA/pkg-descr
+++ b/security/hs-RSA/pkg-descr
@@ -1,8 +1,7 @@
This library implements the RSA encryption and signature algorithms for
-arbitrarily-sized ByteStrings. While the implementations work, they are
-not necessarily the fastest ones on the planet. Particularly key
-generation. The algorithms included are based of RFC 3447, or the
-Public-Key Cryptography Standard for RSA, version 2.1 (a.k.a, PKCS#1
-v2.1).
+arbitrarily-sized ByteStrings. While the implementations work, they are
+not necessarily the fastest ones on the planet. Particularly key generation.
+The algorithms included are based of RFC 3447, or the Public-Key Cryptography
+Standard for RSA, version 2.1 (a.k.a, PKCS#1 v2.1).
WWW: http://hackage.haskell.org/package/RSA