aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorCraig Leres <leres@FreeBSD.org>2021-04-14 05:13:29 +0000
committerCraig Leres <leres@FreeBSD.org>2021-04-14 05:13:29 +0000
commit9c36d02b932e632613f6a3948afa2a65afbfdf6b (patch)
tree303bdc66088b8eda3c83e596c084b00302443fc7 /security
parent6092a286ddc1128cb8bd6f2e6508191c8dbac4d7 (diff)
downloadports-9c36d02b932e632613f6a3948afa2a65afbfdf6b.tar.gz
ports-9c36d02b932e632613f6a3948afa2a65afbfdf6b.zip
Diffstat (limited to 'security')
-rw-r--r--security/zeek/Makefile8
-rw-r--r--security/zeek/files/patch-src_CMakeLists.txt10
-rw-r--r--security/zeek/pkg-plist1
3 files changed, 12 insertions, 7 deletions
diff --git a/security/zeek/Makefile b/security/zeek/Makefile
index fe674ffe2aec..53c8a38718c8 100644
--- a/security/zeek/Makefile
+++ b/security/zeek/Makefile
@@ -97,11 +97,6 @@ USE_RC_SUBR= zeek
post-patch:
${REINPLACE_CMD} -e '\|/usr/local/|s|$$| ${STAGEDIR}${PREFIX}/|' \
${WRKSRC_zeek_netmap}/cmake/FindNetmap.cmake
-
-
-# # Silence the "use ZeekControl.plugin instead of BroControl.plugin" nag
-# @${REINPLACE_CMD} -e 's/^print/#&/' \
-# ${WRKSRC}/auxil/zeekctl/BroControl/__init__.py
post-install-ZEEKCTL-on:
${MKDIR} ${STAGEDIR}${PREFIX}/logs
@@ -128,12 +123,11 @@ post-install-NETMAP-on:
${REINPLACE_CMD} -e 's|=/usr/local|=${STAGEDIR}${PREFIX}|' \
-e '/^include_dir=/s|:/usr/local|:${STAGEDIR}${PREFIX}|' \
${WRKDIR}/zeek-bin/zeek-config
- cd ${WRKSRC_zeek_netmap} && env PATH=${WRKDIR}/zeek-bin:${PATH} \
+ cd ${WRKSRC_zeek_netmap} && ${SETENV} PATH=${WRKDIR}/zeek-bin:${PATH} \
./configure --with-netmap=/usr \
--install-root=${STAGEDIR}${PREFIX}/lib/zeek/plugins
cd ${WRKSRC_zeek_netmap}/build && make && make install
-
.include <bsd.port.pre.mk>
UNAME_M!= ${UNAME} -m
diff --git a/security/zeek/files/patch-src_CMakeLists.txt b/security/zeek/files/patch-src_CMakeLists.txt
new file mode 100644
index 000000000000..de12b5954a97
--- /dev/null
+++ b/security/zeek/files/patch-src_CMakeLists.txt
@@ -0,0 +1,10 @@
+--- src/CMakeLists.txt.orig 2021-04-09 11:46:37 UTC
++++ src/CMakeLists.txt
+@@ -344,6 +344,7 @@ set(HH_SRCS
+ )
+
+ if (${COMPILER_ARCHITECTURE} STREQUAL "arm")
++ list(APPEND HH_SRCS ../auxil/highwayhash/highwayhash/hh_neon.cc)
+ set_source_files_properties(${HH_SRCS} PROPERTIES COMPILE_FLAGS
+ -mfloat-abi=hard -march=armv7-a -mfpu=neon)
+ elseif (${COMPILER_ARCHITECTURE} STREQUAL "aarch64")
diff --git a/security/zeek/pkg-plist b/security/zeek/pkg-plist
index b453a77562ae..bfc6e3eed514 100644
--- a/security/zeek/pkg-plist
+++ b/security/zeek/pkg-plist
@@ -1985,6 +1985,7 @@ man/man8/zeek.8.gz
%%ZEEKCTL%%@preunexec rm -f %D/spool/installed-scripts-do-not-touch/site/local-proxy.zeek
%%ZEEKCTL%%@preunexec rm -f %D/spool/installed-scripts-do-not-touch/site/local-worker.zeek
%%ZEEKCTL%%@preunexec rm -f %D/spool/installed-scripts-do-not-touch/site/local.zeek
+%%ZEEKCTL%%@preunexec rm -f %D/spool/installed-scripts-do-not-touch/site/local.zeek.sample
%%ZEEKCTL%%@preunexec rm -f %D/spool/state.db
%%ZEEKCTL%%@dir spool/tmp
%%ZEEKCTL%%@dir spool/installed-scripts-do-not-touch/site