aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2001-10-03 21:23:48 +0000
committerAnton Berezin <tobez@FreeBSD.org>2001-10-03 21:23:48 +0000
commitb0853c5b6a9874b5a7f7b1ae9575101ec4b71892 (patch)
treebd11ef47f5b6cbf723b776ac0721da2afaa35101 /security
parent698ea398cf9e9c909495ba11af4ad0b87e38c7dd (diff)
downloadports-b0853c5b6a9874b5a7f7b1ae9575101ec4b71892.tar.gz
ports-b0853c5b6a9874b5a7f7b1ae9575101ec4b71892.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/p5-Net-SSLeay/Makefile18
-rw-r--r--security/p5-Net-SSLeay/distinfo2
-rw-r--r--security/p5-Net-SSLeay/pkg-plist55
3 files changed, 56 insertions, 19 deletions
diff --git a/security/p5-Net-SSLeay/Makefile b/security/p5-Net-SSLeay/Makefile
index 602fd45908a0..6f770b2b18c9 100644
--- a/security/p5-Net-SSLeay/Makefile
+++ b/security/p5-Net-SSLeay/Makefile
@@ -6,14 +6,14 @@
#
PORTNAME= Net-SSLeay
-PORTVERSION= 1.07
+PORTVERSION= 1.09
CATEGORIES= security perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Net
-DISTNAME= Net_SSLeay.pm-${PORTVERSION}
PKGNAMEPREFIX= p5-
+DISTNAME= Net_SSLeay.pm-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.ORG
+MAINTAINER= shell@shellhung.org
RESTRICTED= "Cryptography"
PERL_CONFIGURE= yes
@@ -21,6 +21,16 @@ CONFIGURE_ARGS+= "/usr"
USE_OPENSSL= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-MAN3= Net::SSLeay.3
+MAN3= Net::SSLeay.3 Net::SSLeay::Handle.3
+
+PLDIR= ${PREFIX}/share/examples/p5-Net-SSLeay
+SRCDIR= ${WRKSRC}/examples
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${PLDIR}
+ ${INSTALL_SCRIPT} ${SRCDIR}/*.pl ${PLDIR}/
+ ${INSTALL_DATA} ${SRCDIR}/req.conf ${PLDIR}/req.conf
+.endif
.include <bsd.port.mk>
diff --git a/security/p5-Net-SSLeay/distinfo b/security/p5-Net-SSLeay/distinfo
index fb204e9dd5ce..49b1dbb90644 100644
--- a/security/p5-Net-SSLeay/distinfo
+++ b/security/p5-Net-SSLeay/distinfo
@@ -1 +1 @@
-MD5 (Net_SSLeay.pm-1.07.tar.gz) = cf5278dfd77535eaa04cb18a96eebd51
+MD5 (Net_SSLeay.pm-1.09.tar.gz) = 5eb08b9a5fb8ba02f47dd1dee0ff5d30
diff --git a/security/p5-Net-SSLeay/pkg-plist b/security/p5-Net-SSLeay/pkg-plist
index 56183f424b03..bf61f25b0f26 100644
--- a/security/p5-Net-SSLeay/pkg-plist
+++ b/security/p5-Net-SSLeay/pkg-plist
@@ -1,24 +1,51 @@
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SSLeay/SSLeay.so
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Net/SSLeay.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Net/SSLeay/Handle.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Net/ptrtstrun.pl
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SSLeay/SSLeay.bs
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SSLeay/open_tcp_connection.al
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SSLeay/ssl_read_all.al
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SSLeay/ssl_write_all.al
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SSLeay/ssl_read_until.al
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SSLeay/ssl_read_CRLF.al
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SSLeay/ssl_write_CRLF.al
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SSLeay/SSLeay.so
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SSLeay/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SSLeay/debug_read.al
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SSLeay/do_https.al
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SSLeay/do_https2.al
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SSLeay/dump_peer_certificate.al
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SSLeay/randomize.al
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SSLeay/sslcat.al
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SSLeay/get_https.al
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SSLeay/head_https.al
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SSLeay/https_cat.al
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SSLeay/set_server_cert_and_key.al
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SSLeay/make_form.al
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SSLeay/make_headers.al
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SSLeay/do_https.al
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SSLeay/get_https.al
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SSLeay/new_x_ctx.al
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SSLeay/open_tcp_connection.al
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SSLeay/post_https.al
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SSLeay/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SSLeay/put_https.al
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SSLeay/randomize.al
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SSLeay/set_cert_and_key.al
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SSLeay/set_server_cert_and_key.al
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SSLeay/ssl_read_CRLF.al
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SSLeay/ssl_read_all.al
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SSLeay/ssl_read_until.al
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SSLeay/ssl_write_CRLF.al
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SSLeay/ssl_write_all.al
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SSLeay/sslcat.al
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SSLeay/want_X509_lookup.al
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SSLeay/want_nothing.al
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SSLeay/want_read.al
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SSLeay/want_write.al
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SSLeay/.packlist
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Net/SSLeay.pm
+%%PORTDOCS%%/share/examples/p5-Net-SSLeay/bulk.pl
+%%PORTDOCS%%/share/examples/p5-Net-SSLeay/callback.pl
+%%PORTDOCS%%/share/examples/p5-Net-SSLeay/get_authenticated_page.pl
+%%PORTDOCS%%/share/examples/p5-Net-SSLeay/get_page.pl
+%%PORTDOCS%%/share/examples/p5-Net-SSLeay/https-proxy-snif.pl
+%%PORTDOCS%%/share/examples/p5-Net-SSLeay/makecert.pl
+%%PORTDOCS%%/share/examples/p5-Net-SSLeay/minicli.pl
+%%PORTDOCS%%/share/examples/p5-Net-SSLeay/req.conf
+%%PORTDOCS%%/share/examples/p5-Net-SSLeay/ssl-inetd-serv.pl
+%%PORTDOCS%%/share/examples/p5-Net-SSLeay/ssl_diff.pl
+%%PORTDOCS%%/share/examples/p5-Net-SSLeay/sslcat.pl
+%%PORTDOCS%%/share/examples/p5-Net-SSLeay/sslecho.pl
+%%PORTDOCS%%/share/examples/p5-Net-SSLeay/stdio_bulk.pl
+%%PORTDOCS%%@dirrm share/examples/p5-Net-SSLeay
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SSLeay
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Net/SSLeay
@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net 2>/dev/null || true
@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Net 2>/dev/null || true