aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2012-06-30 12:42:52 +0000
committerAndrej Zverev <az@FreeBSD.org>2012-06-30 12:42:52 +0000
commitc9b4f372f45de0fc56af0a64e1f851a1e22a9279 (patch)
tree7f80c1c66cbf0347e6332598f6c4b63f7fff070a /security
parent657447da66b38ad1fbbfe5d9829ede801ebd2923 (diff)
downloadports-c9b4f372f45de0fc56af0a64e1f851a1e22a9279.tar.gz
ports-c9b4f372f45de0fc56af0a64e1f851a1e22a9279.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/afterglow/Makefile2
-rw-r--r--security/amavisd-new/Makefile26
-rw-r--r--security/clusterssh/Makefile4
-rw-r--r--security/ftimes/Makefile4
-rw-r--r--security/fwknop/Makefile24
-rw-r--r--security/hunch/Makefile2
-rw-r--r--security/ipfilter2dshield/Makefile2
-rw-r--r--security/isnprober/Makefile2
-rw-r--r--security/log2timeline/Makefile46
-rw-r--r--security/makepasswd/Makefile4
-rw-r--r--security/monkeysphere/Makefile4
-rw-r--r--security/p5-CSP/Makefile6
-rw-r--r--security/p5-Crypt-Simple/Makefile6
-rw-r--r--security/p5-Net-Daemon-SSL/Makefile8
-rw-r--r--security/p5-Net-OpenID-Server/Makefile6
-rw-r--r--security/p5-POE-Filter-SSL/Makefile14
-rw-r--r--security/ppars/Makefile2
-rw-r--r--security/swatch/Makefile8
-rw-r--r--security/tinyca/Makefile6
19 files changed, 88 insertions, 88 deletions
diff --git a/security/afterglow/Makefile b/security/afterglow/Makefile
index 05e6b41d5729..9cb71127c951 100644
--- a/security/afterglow/Makefile
+++ b/security/afterglow/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= pauls@utdallas.edu
COMMENT= A collection of graph-generating scripts
RUN_DEPENDS= dot:${PORTSDIR}/graphics/graphviz \
- ${SITE_PERL}/Text/CSV.pm:${PORTSDIR}/textproc/p5-Text-CSV \
+ p5-Text-CSV>=0:${PORTSDIR}/textproc/p5-Text-CSV \
p5-Crypt-Rijndael>=0:${PORTSDIR}/security/p5-Crypt-Rijndael \
p5-IP-Anonymous>=0:${PORTSDIR}/net/p5-IP-Anonymous
diff --git a/security/amavisd-new/Makefile b/security/amavisd-new/Makefile
index f44d46e48d5f..fd9554a06fa2 100644
--- a/security/amavisd-new/Makefile
+++ b/security/amavisd-new/Makefile
@@ -19,11 +19,11 @@ COMMENT= Performance-enhanced daemonized version of amavis-perl
LICENCE= GPLv2
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Unix/Syslog.pm:${PORTSDIR}/sysutils/p5-Unix-Syslog \
- ${SITE_PERL}/MIME/Parser.pm:${PORTSDIR}/mail/p5-MIME-Tools \
- ${SITE_PERL}/Convert/TNEF.pm:${PORTSDIR}/converters/p5-Convert-TNEF \
+RUN_DEPENDS= p5-Unix-Syslog>=0:${PORTSDIR}/sysutils/p5-Unix-Syslog \
+ p5-MIME-Tools>=0:${PORTSDIR}/mail/p5-MIME-Tools \
+ p5-Convert-TNEF>=0:${PORTSDIR}/converters/p5-Convert-TNEF \
p5-Convert-UUlib>=1.08,1:${PORTSDIR}/converters/p5-Convert-UUlib \
- ${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip \
+ p5-Archive-Zip>=0:${PORTSDIR}/archivers/p5-Archive-Zip \
p5-Net-Server>=0.93:${PORTSDIR}/net/p5-Net-Server \
p5-Mail-DKIM>=0.33:${PORTSDIR}/mail/p5-Mail-DKIM
@@ -86,40 +86,40 @@ PLIST_SUB+= AMAVIS_NOP0F=${AMAVIS_NOP0F}
USE_RC_SUBR+= amavisd.sh
.if defined(WITH_IPV6)
-RUN_DEPENDS+= ${SITE_PERL}/IO/Socket/INET6.pm:${PORTSDIR}/net/p5-IO-Socket-INET6
+RUN_DEPENDS+= p5-IO-Socket-INET6>=0:${PORTSDIR}/net/p5-IO-Socket-INET6
.endif
.if defined(WITH_SNMP) && defined(WITH_BDB)
USE_RC_SUBR+= amavisd-snmp.sh
-RUN_DEPENDS+= ${SITE_PERL}/Net/SNMP.pm:${PORTSDIR}/net-mgmt/p5-Net-SNMP
+RUN_DEPENDS+= p5-Net-SNMP>=0:${PORTSDIR}/net-mgmt/p5-Net-SNMP
.endif
.if defined(WITH_BDB)
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/BerkeleyDB.pm:${PORTSDIR}/databases/p5-BerkeleyDB
+RUN_DEPENDS+= p5-BerkeleyDB>=0:${PORTSDIR}/databases/p5-BerkeleyDB
.endif
.if defined(WITH_SQLITE)
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/SQLite.pm:${PORTSDIR}/databases/p5-DBD-SQLite
+RUN_DEPENDS+= p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite
.endif
.if defined(WITH_MYSQL)
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql
+RUN_DEPENDS+= p5-DBD-mysql>=0:${PORTSDIR}/databases/p5-DBD-mysql
.endif
.if defined(WITH_PGSQL)
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
+RUN_DEPENDS+= p5-DBD-Pg>=0:${PORTSDIR}/databases/p5-DBD-Pg
.endif
.if defined(WITH_LDAP)
-RUN_DEPENDS+= ${SITE_PERL}/Net/LDAP.pm:${PORTSDIR}/net/p5-perl-ldap
+RUN_DEPENDS+= p5-perl-ldap>=0:${PORTSDIR}/net/p5-perl-ldap
.endif
.if defined(WITH_SASL)
-RUN_DEPENDS+= ${SITE_PERL}/Authen/SASL.pm:${PORTSDIR}/security/p5-Authen-SASL
+RUN_DEPENDS+= p5-Authen-SASL>=0:${PORTSDIR}/security/p5-Authen-SASL
.endif
.if defined(WITH_SPAMASSASSIN)
-RUN_DEPENDS+= ${SITE_PERL}/Mail/SpamAssassin.pm:${PORTSDIR}/mail/p5-Mail-SpamAssassin
+RUN_DEPENDS+= p5-Mail-SpamAssassin>=0:${PORTSDIR}/mail/p5-Mail-SpamAssassin
.endif
.if defined(WITH_P0F)
diff --git a/security/clusterssh/Makefile b/security/clusterssh/Makefile
index 2e011445d920..7e57ea139f63 100644
--- a/security/clusterssh/Makefile
+++ b/security/clusterssh/Makefile
@@ -14,8 +14,8 @@ MASTER_SITES= SF/${PORTNAME}/1.%20ClusterSSH%20Series%203/${PORTVERSION}
MAINTAINER= lx@FreeBSD.org
COMMENT= Controls multiple hosts simultaneously via xterms and ssh
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Tk.pm:${PORTSDIR}/x11-toolkits/p5-Tk \
- ${SITE_PERL}/X11/Protocol.pm:${PORTSDIR}/x11/p5-X11-Protocol
+RUN_DEPENDS= p5-Tk>=0:${PORTSDIR}/x11-toolkits/p5-Tk \
+ p5-X11-Protocol>=0:${PORTSDIR}/x11/p5-X11-Protocol
USE_PERL5= yes
GNU_CONFIGURE= yes
diff --git a/security/ftimes/Makefile b/security/ftimes/Makefile
index 36232c127db2..2d1f2e4802eb 100644
--- a/security/ftimes/Makefile
+++ b/security/ftimes/Makefile
@@ -31,7 +31,7 @@ OPTIONS= DIG_TOOLS "install dig tools" on \
.if defined(WITH_DIG_TOOLS) || defined(WITH_MAP_TOOLS)
. if ${PERL_LEVEL} < 500703
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
+RUN_DEPENDS+= p5-Digest-MD5>=0:${PORTSDIR}/security/p5-Digest-MD5
. endif
.endif
@@ -39,7 +39,7 @@ RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-D
PLIST_SUB+= DIG_TOOLS=""
CONFIGURE_ARGS+= --with-dig-tools
MAN1+= ftimes-crv2dbi.1 ftimes-crv2raw.1 ftimes-dig2ctx.1 ftimes-dig2dbi.1 hipdig.1
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1
+RUN_DEPENDS+= p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1
.else
PLIST_SUB+= DIG_TOOLS="@comment "
.endif
diff --git a/security/fwknop/Makefile b/security/fwknop/Makefile
index 184e16e40d09..a18ba5dc4850 100644
--- a/security/fwknop/Makefile
+++ b/security/fwknop/Makefile
@@ -15,18 +15,18 @@ MASTER_SITES= http://www.cipherdyne.org/fwknop/download/
MAINTAINER= sean.greven@gmail.com
COMMENT= An SPA implimentation for Linux and FreeBSD
-BUILD_DEPENDS= ${SITE_PERL}/Net/IPv4Addr.pm:${PORTSDIR}/net-mgmt/p5-Net-IPv4Addr \
- ${SITE_PERL}/${PERL_ARCH}/Unix/Syslog.pm:${PORTSDIR}/sysutils/p5-Unix-Syslog \
- ${SITE_PERL}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey \
- ${SITE_PERL}/${PERL_ARCH}/Net/Pcap.pm:${PORTSDIR}/net/p5-Net-Pcap \
- ${SITE_PERL}/${PERL_ARCH}/List/MoreUtils.pm:${PORTSDIR}/lang/p5-List-MoreUtils \
- ${SITE_PERL}/${PERL_ARCH}/Crypt/Rijndael.pm:${PORTSDIR}/security/p5-Crypt-Rijndael \
- ${SITE_PERL}/${PERL_ARCH}/Class/MethodMaker.pm:${PORTSDIR}/devel/p5-Class-MethodMaker \
- ${SITE_PERL}/${PERL_ARCH}/Net/RawIP.pm:${PORTSDIR}/net/p5-Net-RawIP \
- ${SITE_PERL}/GnuPG/Key.pm:${PORTSDIR}/security/p5-GnuPG-Interface \
- ${SITE_PERL}/Crypt/CBC.pm:${PORTSDIR}/security/p5-Crypt-CBC \
- ${SITE_PERL}/NetPacket.pm:${PORTSDIR}/net/p5-NetPacket \
- ${SITE_PERL}/Net/Ping/External.pm:${PORTSDIR}/net/p5-Net-Ping-External
+BUILD_DEPENDS= p5-Net-IPv4Addr>=0:${PORTSDIR}/net-mgmt/p5-Net-IPv4Addr \
+ p5-Unix-Syslog>=0:${PORTSDIR}/sysutils/p5-Unix-Syslog \
+ p5-Term-ReadKey>=0:${PORTSDIR}/devel/p5-Term-ReadKey \
+ p5-Net-Pcap>=0:${PORTSDIR}/net/p5-Net-Pcap \
+ p5-List-MoreUtils>=0:${PORTSDIR}/lang/p5-List-MoreUtils \
+ p5-Crypt-Rijndael>=0:${PORTSDIR}/security/p5-Crypt-Rijndael \
+ p5-Class-MethodMaker>=0:${PORTSDIR}/devel/p5-Class-MethodMaker \
+ p5-Net-RawIP>=0:${PORTSDIR}/net/p5-Net-RawIP \
+ p5-GnuPG-Interface>=0:${PORTSDIR}/security/p5-GnuPG-Interface \
+ p5-Crypt-CBC>=0:${PORTSDIR}/security/p5-Crypt-CBC \
+ p5-NetPacket>=0:${PORTSDIR}/net/p5-NetPacket \
+ p5-Net-Ping-External>=0:${PORTSDIR}/net/p5-Net-Ping-External
RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN8= fwknop.8 fwknopd.8 knopmd.8 knopwatchd.8
diff --git a/security/hunch/Makefile b/security/hunch/Makefile
index 1b3a163de494..5cf59bdbae9c 100644
--- a/security/hunch/Makefile
+++ b/security/hunch/Makefile
@@ -14,7 +14,7 @@ MASTER_SITES= http://s89813419.onlinehome.us/ \
MAINTAINER= daniel+hunch@pelleg.org
COMMENT= Scan httpd log files for vulnerability probes, mail admins
-RUN_DEPENDS= ${SITE_PERL}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net
+RUN_DEPENDS= p5-Net>=0:${PORTSDIR}/net/p5-Net
USE_PERL5= yes
diff --git a/security/ipfilter2dshield/Makefile b/security/ipfilter2dshield/Makefile
index 76d4dff4a0ca..0d1363edcd5e 100644
--- a/security/ipfilter2dshield/Makefile
+++ b/security/ipfilter2dshield/Makefile
@@ -15,7 +15,7 @@ EXTRACT_SUFX= .txt
MAINTAINER= fbsd_user@a1poweruser.com
COMMENT= Official DShield client for ipfilter firewall logs
-RUN_DEPENDS= ${SITE_PERL}/Net/Netmask.pm:${PORTSDIR}/net-mgmt/p5-Net-Netmask
+RUN_DEPENDS= p5-Net-Netmask>=0:${PORTSDIR}/net-mgmt/p5-Net-Netmask
USE_PERL5= yes
diff --git a/security/isnprober/Makefile b/security/isnprober/Makefile
index ebf461462353..82d592f33be6 100644
--- a/security/isnprober/Makefile
+++ b/security/isnprober/Makefile
@@ -16,7 +16,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= onatan@gmail.com
COMMENT= PenTest tool for TCP Initial Sequence Numbers research
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/RawIP.pm:${PORTSDIR}/net/p5-Net-RawIP
+RUN_DEPENDS= p5-Net-RawIP>=0:${PORTSDIR}/net/p5-Net-RawIP
PLIST_FILES= bin/${PORTNAME}
PORTDOCS= README
diff --git a/security/log2timeline/Makefile b/security/log2timeline/Makefile
index b4cb7967e297..91eaac997922 100644
--- a/security/log2timeline/Makefile
+++ b/security/log2timeline/Makefile
@@ -19,29 +19,29 @@ COMMENT= A log file parser for computer forensic investigations
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip \
- ${SITE_PERL}/${PERL_ARCH}/DBD/SQLite.pm:${PORTSDIR}/databases/p5-DBD-SQLite \
- ${SITE_PERL}/${PERL_ARCH}/DBI/DBD.pm:${PORTSDIR}/databases/p5-DBI \
- ${SITE_PERL}/Carp/Assert.pm:${PORTSDIR}/devel/p5-Carp-Assert \
- ${SITE_PERL}/Data/Hexify.pm:${PORTSDIR}/devel/p5-Data-Hexify \
- ${SITE_PERL}/Date/Manip.pm:${PORTSDIR}/devel/p5-Date-Manip \
- ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime \
- ${SITE_PERL}/DateTime/Format/Strptime.pm:${PORTSDIR}/devel/p5-DateTime-Format-Strptime \
- ${SITE_PERL}/DateTime/TimeZone.pm:${PORTSDIR}/devel/p5-DateTime-TimeZone \
- ${SITE_PERL}/${PERL_ARCH}/Glib.pm:${PORTSDIR}/devel/p5-Glib2 \
- ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate \
- ${SITE_PERL}/Mac/PropertyList.pm:${PORTSDIR}/devel/p5-Mac-PropertyList \
- ${SITE_PERL}/Parse/Win32Registry.pm:${PORTSDIR}/devel/p5-Parse-Win32Registry \
- ${SITE_PERL}/Image/ExifTool.pm:${PORTSDIR}/graphics/p5-Image-ExifTool \
- ${SITE_PERL}/${PERL_ARCH}/Net/Pcap.pm:${PORTSDIR}/net/p5-Net-Pcap \
- ${SITE_PERL}/NetPacket.pm:${PORTSDIR}/net/p5-NetPacket \
- ${SITE_PERL}/${PERL_ARCH}/Digest/CRC.pm:${PORTSDIR}/security/p5-Digest-CRC \
- ${SITE_PERL}/${PERL_ARCH}/XML/LibXML.pm:${PORTSDIR}/textproc/p5-XML-LibXML \
- ${SITE_PERL}/File/Mork.pm:${PORTSDIR}/www/p5-File-Mork \
- ${SITE_PERL}/${PERL_ARCH}/HTML/Parser.pm:${PORTSDIR}/www/p5-HTML-Parser \
- ${SITE_PERL}/HTML/Scrubber.pm:${PORTSDIR}/www/p5-HTML-Scrubber \
- ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
- ${SITE_PERL}/${PERL_ARCH}/Gtk2.pm:${PORTSDIR}/x11-toolkits/p5-Gtk2
+BUILD_DEPENDS= p5-Archive-Zip>=0:${PORTSDIR}/archivers/p5-Archive-Zip \
+ p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite \
+ p5-DBI>=0:${PORTSDIR}/databases/p5-DBI \
+ p5-Carp-Assert>=0:${PORTSDIR}/devel/p5-Carp-Assert \
+ p5-Data-Hexify>=0:${PORTSDIR}/devel/p5-Data-Hexify \
+ p5-Date-Manip>=0:${PORTSDIR}/devel/p5-Date-Manip \
+ p5-DateTime>=0:${PORTSDIR}/devel/p5-DateTime \
+ p5-DateTime-Format-Strptime>=0:${PORTSDIR}/devel/p5-DateTime-Format-Strptime \
+ p5-DateTime-TimeZone>=0:${PORTSDIR}/devel/p5-DateTime-TimeZone \
+ p5-Glib2>=0:${PORTSDIR}/devel/p5-Glib2 \
+ p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate \
+ p5-Mac-PropertyList>=0:${PORTSDIR}/devel/p5-Mac-PropertyList \
+ p5-Parse-Win32Registry>=0:${PORTSDIR}/devel/p5-Parse-Win32Registry \
+ p5-Image-ExifTool>=0:${PORTSDIR}/graphics/p5-Image-ExifTool \
+ p5-Net-Pcap>=0:${PORTSDIR}/net/p5-Net-Pcap \
+ p5-NetPacket>=0:${PORTSDIR}/net/p5-NetPacket \
+ p5-Digest-CRC>=0:${PORTSDIR}/security/p5-Digest-CRC \
+ p5-XML-LibXML>=0:${PORTSDIR}/textproc/p5-XML-LibXML \
+ p5-File-Mork>=0:${PORTSDIR}/www/p5-File-Mork \
+ p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser \
+ p5-HTML-Scrubber>=0:${PORTSDIR}/www/p5-HTML-Scrubber \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+ p5-Gtk2>=0:${PORTSDIR}/x11-toolkits/p5-Gtk2
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/security/makepasswd/Makefile b/security/makepasswd/Makefile
index 48655e64634a..925da105e577 100644
--- a/security/makepasswd/Makefile
+++ b/security/makepasswd/Makefile
@@ -25,8 +25,8 @@ LICENSE= GPLv1
NO_BUILD= yes
USE_PERL5_RUN= yes
-RUN_DEPENDS+= ${SITE_PERL}/Crypt/PasswdMD5.pm:${PORTSDIR}/security/p5-Crypt-PasswdMD5 \
- ${SITE_PERL}/${PERL_ARCH}/Crypt/OpenSSL/Random.pm:${PORTSDIR}/security/p5-Crypt-OpenSSL-Random
+RUN_DEPENDS+= p5-Crypt-PasswdMD5>=0:${PORTSDIR}/security/p5-Crypt-PasswdMD5 \
+ p5-Crypt-OpenSSL-Random>=0:${PORTSDIR}/security/p5-Crypt-OpenSSL-Random
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/security/monkeysphere/Makefile b/security/monkeysphere/Makefile
index 0b7382d698e2..4108ee14d41f 100644
--- a/security/monkeysphere/Makefile
+++ b/security/monkeysphere/Makefile
@@ -18,8 +18,8 @@ COMMENT= Use the OpenPGP web of trust to verify ssh connections
RUN_DEPENDS= gpg:${PORTSDIR}/security/gnupg1 \
lockfile:${PORTSDIR}/mail/procmail \
bash:${PORTSDIR}/shells/bash \
- ${SITE_PERL}/${PERL_ARCH}/Crypt/OpenSSL/RSA.pm:${PORTSDIR}/security/p5-Crypt-OpenSSL-RSA \
- ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1
+ p5-Crypt-OpenSSL-RSA>=0:${PORTSDIR}/security/p5-Crypt-OpenSSL-RSA \
+ p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1
MAN1= monkeysphere.1 openpgp2ssh.1 pem2openpgp.1
MAN7= monkeysphere.7
diff --git a/security/p5-CSP/Makefile b/security/p5-CSP/Makefile
index a2d410857e12..3dc676e8c2bd 100644
--- a/security/p5-CSP/Makefile
+++ b/security/p5-CSP/Makefile
@@ -15,9 +15,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lx@FreeBSD.org
COMMENT= A Perl tool for managing Certificate Authorities
-BUILD_DEPENDS= ${SITE_PERL}/Date/Calc.pm:${PORTSDIR}/devel/p5-Date-Calc \
- ${SITE_PERL}/Term/Prompt.pm:${PORTSDIR}/devel/p5-Term-Prompt \
- ${SITE_PERL}/IPC/Run.pm:${PORTSDIR}/devel/p5-IPC-Run
+BUILD_DEPENDS= p5-Date-Calc>=0:${PORTSDIR}/devel/p5-Date-Calc \
+ p5-Term-Prompt>=0:${PORTSDIR}/devel/p5-Term-Prompt \
+ p5-IPC-Run>=0:${PORTSDIR}/devel/p5-IPC-Run
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/security/p5-Crypt-Simple/Makefile b/security/p5-Crypt-Simple/Makefile
index 9b1a7186ef39..b5f4d7b052de 100644
--- a/security/p5-Crypt-Simple/Makefile
+++ b/security/p5-Crypt-Simple/Makefile
@@ -15,9 +15,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= avk@vl.ru
COMMENT= Perl encrypt stuff simply
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Crypt/Blowfish.pm:${PORTSDIR}/security/p5-Crypt-Blowfish \
- ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
- ${SITE_PERL}/FreezeThaw.pm:${PORTSDIR}/devel/p5-FreezeThaw
+RUN_DEPENDS= p5-Crypt-Blowfish>=0:${PORTSDIR}/security/p5-Crypt-Blowfish \
+ p5-MIME-Base64>=0:${PORTSDIR}/converters/p5-MIME-Base64 \
+ p5-FreezeThaw>=0:${PORTSDIR}/devel/p5-FreezeThaw
BUILD_DEPENDS:= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/security/p5-Net-Daemon-SSL/Makefile b/security/p5-Net-Daemon-SSL/Makefile
index 6240ae18d921..d947e9deb13a 100644
--- a/security/p5-Net-Daemon-SSL/Makefile
+++ b/security/p5-Net-Daemon-SSL/Makefile
@@ -16,10 +16,10 @@ COMMENT= Perl5 extension for portable daemons
PERL_CONFIGURE= yes
-BUILD_DEPENDS+= ${SITE_PERL}/Net/Daemon.pm:${PORTSDIR}/net/p5-Net-Daemon \
- ${SITE_PERL}/IO/Socket/SSL.pm:${PORTSDIR}/security/p5-IO-Socket-SSL
-RUN_DEPENDS+= ${SITE_PERL}/Net/Daemon.pm:${PORTSDIR}/net/p5-Net-Daemon \
- ${SITE_PERL}/IO/Socket/SSL.pm:${PORTSDIR}/security/p5-IO-Socket-SSL
+BUILD_DEPENDS+= p5-Net-Daemon>=0:${PORTSDIR}/net/p5-Net-Daemon \
+ p5-IO-Socket-SSL>=0:${PORTSDIR}/security/p5-IO-Socket-SSL
+RUN_DEPENDS+= p5-Net-Daemon>=0:${PORTSDIR}/net/p5-Net-Daemon \
+ p5-IO-Socket-SSL>=0:${PORTSDIR}/security/p5-IO-Socket-SSL
MAN3= Net::Daemon::SSL.3
diff --git a/security/p5-Net-OpenID-Server/Makefile b/security/p5-Net-OpenID-Server/Makefile
index 3eb89d0715ca..c389873187c5 100644
--- a/security/p5-Net-OpenID-Server/Makefile
+++ b/security/p5-Net-OpenID-Server/Makefile
@@ -15,9 +15,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kappa@rambler-co.ru
COMMENT= Reference implementation of OpenID server
-BUILD_DEPENDS= ${SITE_PERL}/Crypt/DH.pm:${PORTSDIR}/security/p5-Crypt-DH \
- ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1 \
- ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI
+BUILD_DEPENDS= p5-Crypt-DH>=0:${PORTSDIR}/security/p5-Crypt-DH \
+ p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1 \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/security/p5-POE-Filter-SSL/Makefile b/security/p5-POE-Filter-SSL/Makefile
index ff97bd803940..500a5a3f71a2 100644
--- a/security/p5-POE-Filter-SSL/Makefile
+++ b/security/p5-POE-Filter-SSL/Makefile
@@ -18,13 +18,13 @@ COMMENT= The easiest and flexiblest way to SSL in POEIntegrate SSL into POE
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/SSLeay.pm:${PORTSDIR}/security/p5-Net-SSLeay \
- ${SITE_PERL}/HTTP/Status.pm:${PORTSDIR}/www/p5-libwww \
- ${SITE_PERL}/POE/Filter/Stackable.pm:${PORTSDIR}/devel/p5-POE \
- ${SITE_PERL}/Test/Simple.pm:${PORTSDIR}/devel/p5-Test-Simple
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/SSLeay.pm:${PORTSDIR}/security/p5-Net-SSLeay \
- ${SITE_PERL}/HTTP/Status.pm:${PORTSDIR}/www/p5-libwww \
- ${SITE_PERL}/POE/Filter/Stackable.pm:${PORTSDIR}/devel/p5-POE
+BUILD_DEPENDS= p5-Net-SSLeay>=0:${PORTSDIR}/security/p5-Net-SSLeay \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+ p5-POE>=0:${PORTSDIR}/devel/p5-POE \
+ p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS= p5-Net-SSLeay>=0:${PORTSDIR}/security/p5-Net-SSLeay \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+ p5-POE>=0:${PORTSDIR}/devel/p5-POE
WRKSRC= ${WRKDIR}
diff --git a/security/ppars/Makefile b/security/ppars/Makefile
index a3505d597177..dd0054124bf1 100644
--- a/security/ppars/Makefile
+++ b/security/ppars/Makefile
@@ -14,7 +14,7 @@ DISTNAME= ${PORTNAME}
MAINTAINER= fbsd_user@a1poweruser.com
COMMENT= Proactive Probing Abuse Reporting System
-RUN_DEPENDS= ${SITE_PERL}/Net/Netmask.pm:${PORTSDIR}/net-mgmt/p5-Net-Netmask
+RUN_DEPENDS= p5-Net-Netmask>=0:${PORTSDIR}/net-mgmt/p5-Net-Netmask
USE_PERL5= yes
diff --git a/security/swatch/Makefile b/security/swatch/Makefile
index 0b86a75e9251..3e01e97fd10d 100644
--- a/security/swatch/Makefile
+++ b/security/swatch/Makefile
@@ -15,10 +15,10 @@ MAINTAINER= joseph@randomnetworks.com
COMMENT= The Simple WATCHer and filter
BUILD_DEPENDS= \
- ${SITE_PERL}/Date/Format.pm:${PORTSDIR}/devel/p5-TimeDate \
- ${SITE_PERL}/Date/Manip.pm:${PORTSDIR}/devel/p5-Date-Manip \
- ${SITE_PERL}/Date/Calc.pm:${PORTSDIR}/devel/p5-Date-Calc \
- ${SITE_PERL}/File/Tail.pm:${PORTSDIR}/devel/p5-File-Tail
+ p5-TimeDate>=0:${PORTSDIR}/devel/p5-TimeDate \
+ p5-Date-Manip>=0:${PORTSDIR}/devel/p5-Date-Manip \
+ p5-Date-Calc>=0:${PORTSDIR}/devel/p5-Date-Calc \
+ p5-File-Tail>=0:${PORTSDIR}/devel/p5-File-Tail
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/security/tinyca/Makefile b/security/tinyca/Makefile
index dd0a0c028803..54496e23220e 100644
--- a/security/tinyca/Makefile
+++ b/security/tinyca/Makefile
@@ -16,10 +16,10 @@ DISTNAME= ${PORTNAME}2-${PORTVERSION}
MAINTAINER= janos.mohacsi@bsd.hu
COMMENT= Simple graphical interface to manage a small Certification Authority
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Gtk2.pm:${PORTSDIR}/x11-toolkits/p5-Gtk2 \
- ${SITE_PERL}/${PERL_ARCH}/Locale/gettext.pm:${PORTSDIR}/devel/p5-Locale-gettext \
+RUN_DEPENDS= p5-Gtk2>=0:${PORTSDIR}/x11-toolkits/p5-Gtk2 \
+ p5-Locale-gettext>=0:${PORTSDIR}/devel/p5-Locale-gettext \
zip:${PORTSDIR}/archivers/zip \
- ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+ p5-MIME-Base64>=0:${PORTSDIR}/converters/p5-MIME-Base64
USE_BZIP2= yes
USE_PERL5= yes