aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-11-19 08:13:16 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-11-19 08:13:16 +0000
commitdbcaf755426a9475840a9cb9426cf627c7a226e1 (patch)
treecda5450b8246688ad8edaf2092110e1e1410d3d5 /security
parent5b333c88b38842044abfe643dc43b4ec1f748262 (diff)
downloadports-dbcaf755426a9475840a9cb9426cf627c7a226e1.tar.gz
ports-dbcaf755426a9475840a9cb9426cf627c7a226e1.zip
Diffstat (limited to 'security')
-rw-r--r--security/rubygem-gpgme/Makefile13
-rw-r--r--security/rubygem-gpgme/distinfo6
-rw-r--r--security/rubygem-gpgme/files/patch-ext-gpgme-extconf.rb10
-rw-r--r--security/rubygem-gpgme/files/patch-gemspec10
4 files changed, 29 insertions, 10 deletions
diff --git a/security/rubygem-gpgme/Makefile b/security/rubygem-gpgme/Makefile
index 99e27f92ed15..eceb7bda7fdd 100644
--- a/security/rubygem-gpgme/Makefile
+++ b/security/rubygem-gpgme/Makefile
@@ -1,5 +1,5 @@
PORTNAME= gpgme
-PORTVERSION= 2.0.20
+PORTVERSION= 2.0.21
CATEGORIES= security rubygems
MASTER_SITES= RG
@@ -9,10 +9,12 @@ WWW= https://github.com/ueno/ruby-gpgme
LICENSE= LGPL21+
-BUILD_DEPENDS= gpgme-config:security/gpgme
+BUILD_DEPENDS= gpgme>=gpgme:security/gpgme \
+ libassuan>=2.5.5:security/libassuan \
+ libgpg-error>=1.45:security/libgpg-error
LIB_DEPENDS= libassuan.so:security/libassuan \
- libgpg-error.so:security/libgpg-error
-RUN_DEPENDS= gpgme-config:security/gpgme
+ libgpg-error.so:security/libgpg-error \
+ libgpgme.so:security/gpgme
USES= gem shebangfix
USE_RUBY= yes
@@ -21,7 +23,4 @@ CONFIGURE_ARGS= --use-system-libraries
SHEBANG_FILES= test/pinentry
-post-patch:
- @${REINPLACE_CMD} -e '/mini_portile2/d' ${WRKSRC}/gpgme.gemspec ${WRKSRC}/ext/gpgme/extconf.rb
-
.include <bsd.port.mk>
diff --git a/security/rubygem-gpgme/distinfo b/security/rubygem-gpgme/distinfo
index e8acd3eb1853..5b0e72d63570 100644
--- a/security/rubygem-gpgme/distinfo
+++ b/security/rubygem-gpgme/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1582223008
-SHA256 (rubygem/gpgme-2.0.20.gem) = fc194689cff40cd4ccafb3086031e930650b3efc15348bbfdf7a2f8b5a826f75
-SIZE (rubygem/gpgme-2.0.20.gem) = 9185280
+TIMESTAMP = 1665648499
+SHA256 (rubygem/gpgme-2.0.21.gem) = e5b46c7a4eceee2df31b1a8383db65cb3351256839cc655ab55762b9383b6e9f
+SIZE (rubygem/gpgme-2.0.21.gem) = 3418112
diff --git a/security/rubygem-gpgme/files/patch-ext-gpgme-extconf.rb b/security/rubygem-gpgme/files/patch-ext-gpgme-extconf.rb
new file mode 100644
index 000000000000..e14b99204578
--- /dev/null
+++ b/security/rubygem-gpgme/files/patch-ext-gpgme-extconf.rb
@@ -0,0 +1,10 @@
+--- ext/gpgme/extconf.rb.orig 2022-10-13 10:24:31 UTC
++++ ext/gpgme/extconf.rb
+@@ -60,7 +60,6 @@ follows:
+ EOS
+
+ require 'rubygems'
+- require 'mini_portile2'
+
+ libgpg_error_recipe = MiniPortile.new('libgpg-error', '1.46').tap do |recipe|
+ recipe.target = File.join(ROOT, "ports")
diff --git a/security/rubygem-gpgme/files/patch-gemspec b/security/rubygem-gpgme/files/patch-gemspec
new file mode 100644
index 000000000000..43bd6c822b8f
--- /dev/null
+++ b/security/rubygem-gpgme/files/patch-gemspec
@@ -0,0 +1,10 @@
+--- gpgme.gemspec.orig 2022-10-13 14:19:20 UTC
++++ gpgme.gemspec
+@@ -24,7 +24,6 @@ Gem::Specification.new do |s|
+ end
+
+ if s.respond_to? :add_runtime_dependency then
+- s.add_runtime_dependency(%q<mini_portile2>.freeze, ["~> 2.7.0"])
+ s.add_development_dependency(%q<mocha>.freeze, ["~> 0.9.12"])
+ s.add_development_dependency(%q<minitest>.freeze, ["~> 2.1.0"])
+ s.add_development_dependency(%q<yard>.freeze, ["~> 0.9.11"])