aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorSofian Brabez <sbz@FreeBSD.org>2016-04-13 23:48:06 +0000
committerSofian Brabez <sbz@FreeBSD.org>2016-04-13 23:48:06 +0000
commite15c68ce10821aee7796b48a844be9ef51d739e6 (patch)
tree41aec608ecefa354fa37807300cba60a9b06cb7c /security
parenta261b442b24289ccdd05d41a61b8295d9ba0989b (diff)
downloadports-e15c68ce10821aee7796b48a844be9ef51d739e6.tar.gz
ports-e15c68ce10821aee7796b48a844be9ef51d739e6.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/honggfuzz/Makefile13
-rw-r--r--security/honggfuzz/distinfo4
-rw-r--r--security/honggfuzz/pkg-plist2
3 files changed, 13 insertions, 6 deletions
diff --git a/security/honggfuzz/Makefile b/security/honggfuzz/Makefile
index 5e743a554f2c..1867bd04e927 100644
--- a/security/honggfuzz/Makefile
+++ b/security/honggfuzz/Makefile
@@ -2,19 +2,24 @@
# $FreeBSD$
PORTNAME= honggfuzz
-PORTVERSION= 0.3
-PORTREVISION= 1
+PORTVERSION= 0.7
CATEGORIES= security
-MASTER_SITES= GOOGLE_CODE
MAINTAINER= sbz@FreeBSD.org
COMMENT= General-purpose fuzzer with simple, command-line interface
LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= gmake tar:tgz
+USE_GITHUB= yes
+GH_ACCOUNT= google
+GC_TAGNAME= 6d01e82
-USES= gmake tar:tgz
OPTIONS_DEFINE= EXAMPLES
+BROKEN_FreeBSD_9=Does not build on 9.x: compiler options unrecognized
+
# inplace replacement to remove relative binary path in examples scripts
post-patch:
${REINPLACE_CMD} -i "" -E "s,\.\./,," ${WRKSRC}/examples/*.sh
diff --git a/security/honggfuzz/distinfo b/security/honggfuzz/distinfo
index 716c7075da04..4bf70a6c0087 100644
--- a/security/honggfuzz/distinfo
+++ b/security/honggfuzz/distinfo
@@ -1,2 +1,2 @@
-SHA256 (honggfuzz-0.3.tgz) = 603f07bd364cbf7246539b1478943270bc47f716ce5faf167839626fd60ade26
-SIZE (honggfuzz-0.3.tgz) = 19767
+SHA256 (google-honggfuzz-0.7_GH0.tar.gz) = 611472a453c870165bb44e55900e7709aa4f7bca0159a81fc599cd66d1547d2a
+SIZE (google-honggfuzz-0.7_GH0.tar.gz) = 413122
diff --git a/security/honggfuzz/pkg-plist b/security/honggfuzz/pkg-plist
index 20fe92009400..aa85db194093 100644
--- a/security/honggfuzz/pkg-plist
+++ b/security/honggfuzz/pkg-plist
@@ -1,8 +1,10 @@
bin/honggfuzz
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/externalfuzzers/lowBytesIncrease.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/externalfuzzers/o20.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/externalfuzzers/rangeFuzz.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/inputfiles/badcode1.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/run-honggfuzz-on-badcode1-with-externalfuzzer.sh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/run-honggfuzz-on-badcode1.sh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/targets/Makefile
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/targets/badcode1.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/targets/badcode2.c